[SOLVED] Weird problem with imported ZFS disk.


Apr 15, 2019
I come from Freenas and had a lot of data on a ZFS pool I created (2 x 8 TB disk) and now I migrated to Proxmox, when I did zpool import it all went without error and the pool showed up under Server > Disks > ZFS.

But I noticed that it didn't appear in the left collom where all my other storage is located.

When I tried to mount the pool it also didn't appear in the option to mount.
Am I doing something wrong? did I miss something? please let me know because I can't miss this data.

Thanks in advance I attached some screenshots to make it more clear.

Tell me if you need more info.


  • 1.png
    69.7 KB · Views: 9
  • 2.png
    84.5 KB · Views: 8
you need to add a storage definition for your pool


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!