nathanchere

New Member
Nov 29, 2023
2
1
1
I'm not really looking for support here because I have everything working now with 8.0 and that's enough. I'm more writing as a 'bug report' of sorts.

I have purchased a new box intended for use as a router/firewall/etc with Proxmox VE at the top level. i7-1265u, 64Gb DDR4-3200 RAM, 1Tb main NVME drive, and a spare 2.5" SATA SSD intended for use to stage some local backups. I ran a memory test overnight with no issues found. Booting off the existing Win10 image on the spare SSD and poking around for half an hour was stable and issue-free.

I won't put all the steps I've followed since it will get very long-winded, and some conclusions are re-ordered for conciseness.

ISSUE 1: install from ISO not working

I tried installing PVE8.1 from an ISO copied onto a Ventoy stick. It gets to the point of:

```
searching for block device containing the ISO proxmox-ve-8.1.1
with ISO ID 1417249e-89f2-11ee-9dc2-bf4a21bd54a0
```
after failing several times it gives up. Normal or grub boot mode makes no difference. Switching USB ports, no difference. Using a different USB stick, no difference. Double-checking the checksum of the downloaded image confirms no corruption.

ISSUE 2: install from ISO flashed to USB works - but it's very buggy

Sometime I get a flash as X is started then it crashes out. Sometimes X won't start at all. I can at least switch TTY and see in X log it's a segfault for some reason. Maybe one in 5 times I can get through to the GUI installer and actually begin the installation.

If I try the terminal installer it gets through to the installer each time.

In both cases, once you've set the install configuration and the installer is running, it completes roughly 3/4 of the time. Roughly 1/4 of the time the entire device freezes up, and consistently (has happened maybe 7-8 times in total) it's frozen at around 30-40% when 'extracting base system'. Totally unresponsive, need to hard shutdown.

ISSUE 3: when it's installed, it freezes sporadically

On the five separate occasions that I've had a 'successful' installation, it will boot up and I can access the web admin UI from another device fine at first. After a few minutes of doing anything it will stop responding and the host device is seemingly frozen. I've noticed that if I run a recurring ping in the background it will be working at first, then time out for several minutes at a time, then start responding again for anywhere up to around 15 minutes, then time out again etc.

----------------

I would be inclined to assume these are indicative of some kind of local hardware fault - especially since I see many other people reporting successfully installing and using PVE 8.1 without incident. The reason I don't suspect it's strictly a local hardware issue is that the following apply to my investigations with both PVE 7.4 and 8.0:

- the installer works fine when booted from an ISO on a Ventoy stick
- the installer works first time, every time (tested about a half dozen times for each)
- no hanging or freezing encountered at all
- I was able to set up a few VMs and have everything running fine for about an hour without any interruptions
- pinging every second from another machine showed absolutely no outages

As I said this is not a support request as I'm happy to continue with 8.0 for now but it seems pretty clear there is something broken with 8.1. I'm leaving this in case anyone else encounters the same behaviour (then consider going back to 8.0 as a workaround), in which case let me know if I can provide any additional information to help identify the root cause(s).
 
  • Like
Reactions: semanticbeeng
the ventoy issue is likely because we had to change some parts of how our bootloader on the iso is configured to support secureboot.

the other issue might boil down to some bug/problem with the new(er) 6.5-based kernel. do you see instability when you upgrade your 8.0 install to the current package versions, but remain on the 6.2-based kernel? what about if you then reboot into the 6.5 based one?
 
I had the same issue attempting to install Proxmox VE (8.1) for the first time, on an old HP Z400 so I could play around with building and managing a home server.

I quickly added the ISO for 8.0 to my ventoy drive, and quickly installed it without issue on the same hardware.
 
... Same problem, the 8.0 version run from ventoy disk and the server is run, but this 8.1 fail from ventoy and rufus way ............

wha gwan?

Give thanks!!!
 
It took longer but I also got seemingly random freezing on 8.0. Nothing obvious in logs, leaving `top` open doesn't show anything interesting running or anomalous usage before it hangs. I then tried 7.4 out of curiosity and it hangs without clear reason anywhere from around 15 to 40 mins again. Before I gave up on proxmox (for now) I also tried swapping to a single RAM stick from another known stable system, swapping the SSD drive and in BIOS disabling sleep, disabling CPU efficiency cores, enabling and disabling secureboot, disabling various settings around turbo boost and power management, running with no display or USB peripherals connected, changing which ethernet ports are used, disabling all PCIE except for NVME and eventually accepted defeat.

Since then, I installed opnSense and Manjaro (with all features/hardware/etc set back to before the above mentioned troubleshooting) and both installed first go and ran for about 2 hours before I moved on to the next one. I could also install Hyper-V Server 2019 and it seemed fine other than not detecting the network cards (known i225-v driver issue, I'm not considering it a 'fault' as such).

I was then able to install ESXI and it has been running now for over 27 hours without issue (aside from needing to disable cpuUniformityHardCheckPanic), and also opnSense is up and running without issue in a VM. It doesn't completely rule out a hardware fault but it's looking that way.

I'd still greatly prefer to use Proxmox instead of anything VMware or Microsoft so I've ordered a serial to USB cable to see if anything in the console logs can shed any light on what is happening.
 
Last edited:
the ventoy issue is likely because we had to change some parts of how our bootloader on the iso is configured to support secureboot.

the other issue might boil down to some bug/problem with the new(er) 6.5-based kernel. do you see instability when you upgrade your 8.0 install to the current package versions, but remain on the 6.2-based kernel? what about if you then reboot into the 6.5 based one?
I had the same issue with ventoy. I've checked the sha256 and tried the isos for 6.4-1, 7.4-1 and 8.0-2, which I also had on the ventoy USB. They all worked.

I ended up installing 8.0 and upgraded immediately.
 
Do you guys know the following?

1. Should PVE boot using GRUB or systemd when booting off a Ventoy thumbdrive on a secured boot machine?
2. What if booting PVE off a thumbdrive directly without Ventoy? GRUB or systemd?
 
updating to Ventoy ci version did not work for me, i still get the
Code:
verification failed (0x1A) seruity violation
erorr
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!