New to Proxmox. How to log in?


New Member
Feb 25, 2022
Sorry for a sadly elementary question, but I'm stuck.

I just finished Proxmox installation. The system rebooted. I'm at a text screen that says,
Welcome to the Proxmox Virtual Environment. Please use your web browser to configure this server - connect to:

pve login:
I gather that, while the screen seems to be inviting me to log in, it's just kidding - I have to log in from a web browser on another machine. And I guess WiFi is not an option, since I haven't yet had an opportunity to configure password etc. for WiFi on the Proxmox machine. So I think I'm supposed to run an Ethernet cable from that machine to another one - in this case, an adjacent Acer laptop.

I'm told crossover cables aren't needed anymore, haven't been for ten years or so - which is just as well, because I seem to have unloaded mine somewhere. But I tried with and without a switch mediating between the two machines, and in either case the suggested https: address isn't giving me a connection.

I've dug through various websites enough to think that I'm doing what I'm supposed to do, but evidently something is missing: I'm still getting "Connection failed" on the Ubuntu machine. Would someone kindly give me a shove in the right direction?

peer2peer ethernet (cable) works like a charm.
Indeed crossover cables like back in the old days are not needed anymore.
Did you maybe miss configuring your NIC on the laptop?
If your server is on I would suggest setting the following network details on your machine:

Netmask: ( would technically be enough but yea I don't want to confuse you :D

then it should work.
You also should be able to set up wifi on your host but this won't perform that well for heavy usage.
You need to install some packages and configure them, then point your vmbr0 to the WLAN nic.
Have a look for wpla_supplicant on the net :)

You shouldn't use the default IP\24. Choose a free IP of the subnet your router is using that is not part of your routers DHCP range. And then use your routers IP as the gateway and DNS server. Then you should be able to access the webUI from any machine thats managed by your router.
Last edited:
  • Like
Reactions: Tmanok
Now that you mention it, I did stumble a bit when configuring the NIC at setup. So, OK, I'm starting over. Boot the installer, go through the steps ... and here we are, at the Management Network Configuration screen. Last time around, I went with the default Management Interface (enp12s0 ... ). Hostname was a mystery, and not for lack of research; eventually I used pve.example.local. Repeating that now.

For IP Address, this time I'm trying as suggested, partly because I'm not using a router - just a straight cable (see above), if that will work. Gateway and DNS server: absent a router, I guess I should use the values from the connected machine. Running route -n on that machine gives me Gateway =, and grep "nameserver" /etc/resolv.conf produces

It finishes, reboots, and puts me back at the same login screen, except this time it is instructing me to connect to . Sadly, that still fails, even after trying two different cables, with and without the Netgear switch. And that's a shame, because I really felt a lot better about the whole thing, this time around.

There is a sign of modest progress: this time, the browser says, "This site can’t be reached: took too long to respond." I don't think I got even that acknowledgement of a connection last time. But, obviously, I still don't have it right.
If your client don't got a IP in the subnet (so something between and you won't be able to access the server. And and sounds like your connected client is using so that won't work. And you gateway has to be in the subnet of the server too, so can't be used. And DNS is also not working because is a local loopback address.

So like Thomas Sossna already said, try to change your clients IP so that it is part of the same subnet your PVE server is using. Or change the IP of the server to the subnet that your client is using. But as long as both operate in different subnets they won't be able to communicate.
Last edited:
I thought Sossna was giving me settings for the server. You're saying those were suggestions for the client. OK, researching how to change client's IP. LinuxConfig provides guidance. I go to Ubuntu > Settings > Network > Wired > Settings icon > IPv4 tab > Manual > Addresses. Following Sossna's logic, since the server is now on, I set the laptop's Address to and its Netmask to the same as the server. Not sure if the latter is right; not sure what the alternative would be. I set Gateway to No idea if that makes sense. I leave DNS and Routes on Automatic. I click Apply. Settings still says Cable Unplugged and won't let me turn Wired on or off as LinuxConfig suggests.

It feels like progress. I am confused about much more specific things now. Just a few more tweaks and it'll work (he said, blowing on the dice) ...
Settings still says Cable Unplugged and won't let me turn Wired on or off as LinuxConfig suggests.
Does one of the computers maybe got multiple ethernet ports and you are using the wrong one?
Did you reboot them after changing network configs to changes take effect?
What will your ubuntu output if you run sudo ip addr and sudo lshw -class network?

You really should try to learn the network basics or you will have a hard time with that server if things like subnets, subnetmasks, gateway, DNS, routes, NAT, IPv4, IPv6, ports, iptables, public/private IPs and so on are unclear. But atleast you can't put yourself oder other people into danger as long as the server isn'T connected to the internet, so feel free to experiment and learn something new by doing it.
I have a learning disorder when it comes to networking. It's been that way for years. It just doesn't compute for me. Seems ridiculous, but I've fought that fight. But, never say die. One day at a time.

No luck from a reboot. Only one ethernet port.

From sudo ip addr:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp1s0f1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether fc:45:96:ed:96:8d brd ff:ff:ff:ff:ff:ff
3: wlp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether b0:35:9f:1e:93:c1 brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic noprefixroute wlp2s0
       valid_lft 258632sec preferred_lft 258632sec
    inet6 2603:8081:4b01:5cba:0:f52b:81a:c0c0/128 scope global dynamic noprefixroute
       valid_lft 604235sec preferred_lft 604235sec
    inet6 2603:8081:4b01:5cba:2deb:ad18:74c9:c682/64 scope global temporary dynamic
       valid_lft 604234sec preferred_lft 85393sec
    inet6 2603:8081:4b01:5cba:33fa:62d1:e5d9:6072/64 scope global dynamic mngtmpaddr noprefixroute
       valid_lft 604786sec preferred_lft 604786sec
    inet6 fe80::4321:a1b4:84f:5f7d/64 scope link noprefixroute
       valid_lft forever preferred_lft forever

From sudo lshw -class network:

       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0.1
       bus info: pci@0000:01:00.1
       logical name: enp1s0f1
       version: 12
       serial: fc:45:96:ed:96:8d
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.13.0-30-generic firmware=rtl8411-2_0.0.1 07/08/13 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:16 ioport:3000(size=256) memory:b1104000-b1104fff memory:b1100000-b1103fff
       description: Wireless interface
       product: Dual Band Wireless-AC 3168NGW [Stone Peak]
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 10
       serial: b0:35:9f:1e:93:c1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.13.0-30-generic firmware=29.198743027.0 3168-29.ucode ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:131 memory:b1000000-b1001fff
How did you setup that ethernet port? Because its down, got no IP and only your Wifi is used.
I don't know. It's a bootable USB drive I've been using for a while. I could try booting from a live USB if that would make a difference.

Wait, now I remember. It's a V2P (virtual to physical). I made it via dd from a virtual machine. I guess creating the VM did not entail creating certain physical structures.
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!