HDD never spin down

Discussion in 'Proxmox VE: Installation and configuration' started by charlot rodolphe, Apr 18, 2019.

Tags:
  1. charlot rodolphe

    charlot rodolphe New Member

    Joined:
    Oct 31, 2018
    Messages:
    1
    Likes Received:
    0
    Hi,

    I have a Proxmox server (5.2.1) with the config below :
    - Xeon E5 2650 V2
    - 16Gb Ram ECC
    - 120 GB SSD (KINGSTON SV300S3)
    - 2x2To HDD (Hitachi HUS72403 and TOSHIBA DT01ACA3)
    The proxmox server is intalled on the SSD, the containers too.

    My two hard-drives are configured in RAID 1 with this thread :
    doc.ubuntu-fr.org/raid_logiciel

    It's mounted on my proxmox server, and shared through NFS with my 4 containers.

    Everything is working smoothly but hard drives never spin down.
    When i try a : hdparm -y /dev/sd[bc]
    It lasts for a few seconds then hard drives spin again

    I tried to stop the NFS server and stop all the containers but there are always 4096 bytes read or write every 1 or 2 seconds and I don't know where i comes from.

    They are driving me crazy because I sleep next to it :)
    Any idea that could help me understand where I did something wrong ?

    PS : Sorry for my english

    Attachments :
    Result of
    - dstat -D sdb,sdc
    - mdadm --detail /dev/md0
    - iostat -d 10 /dev/x
    - iotop
    capture d'écran.png capture d'écran.png capture d'écran_1.png capture d'écran_2.png capture d'écran_3.png
     
  2. wolfgang

    wolfgang Proxmox Staff Member
    Staff Member

    Joined:
    Oct 1, 2014
    Messages:
    4,598
    Likes Received:
    306
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. martin_bk

    martin_bk New Member

    Joined:
    Yesterday
    Messages:
    1
    Likes Received:
    0
    Hello,

    is there a known solution for hdd sleep now?
    I want to use proxmox (install it on a ssd) and create a zfs pool (with 4 disks) and share it via SMB to my Windwos systems.
    The ZFS Pool is used maybe 4 or 5 times a week, so it is necessary for me to send my disks from the ZFS pool to sleep when they are idle.

    as far as i know the pvestatd keeps the disks awake because it scans them every few seconds.

    I really want to use Proxmox but as long as there is no real solution for this its a pain to use it.
    Proxmox needs a function to exclude disks from pvestatd.

    Or is there any solution to get disk sleep working?
     
  4. Dark26

    Dark26 Member

    Joined:
    Nov 27, 2017
    Messages:
    65
    Likes Received:
    3
    the filesystem is ext4 ?

    you can this to see what access the disk :

    Hi

    Another option is to enable hard drive access dumping to syslog.

    That may tell you what is accessing the particular drive. I used it myself may moons ago and found it useful.

    To turn it on...

    Code:
    and to turn it off

    Code:
    You can then check syslog to try to determine what is writing to the drive.


    BECAREFUL --> the log file grows very fast.


    If you have ext4 filesystem, the system chek the health and wake up the disk.

    No problem with ext2
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice