FreeBSD guests are challenging

After the prior post on FreeBSD (OPNSense and FreeNAS) failing to boot due to hotplug being enabled there remain issues.

Both install just fine and boot just fine. It is only after a while they become unresponsive. I have yet to find an indication or metric to watch to understand what is going on.

My question is if there are known configuration requirements for either of OPNSense, FreeNAS. I found none for FreeBSD but i did find a post about known network performance issues, this approach appears unusual to me but does seem to work https://forum.opnsense.org/index.php?topic=16531.0 according to the author.

OPNSense, boots very slowly yet boots.

FreeNAS boots fine but somehow suddenly runs into a 'no swap space left on device' and freezes, knowing i have not assigned any swap to begin with.
 

Alwin

Proxmox Staff Member
Staff member
Aug 1, 2017
4,617
433
88
Maybe redirecting the dmesg/syslog or even a remote kdump might shed some light on it.
 
  • Like
Reactions: Joris L.

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!