Upgrade from 6 to 7 stuck at 93% - File descriptor leaked

pl11x

Member
Jun 2, 2018
20
1
23
37
Hi,

I've been following the suggestions and steps from the Upgrade_from_6.x_to_7.0 wiki and, right now, I am stuck at 93% for more than an hour or so in the apt dist-upgrade execution. This is what the SSH screen shows now:

Code:
Setting up libmath-random-isaac-perl (1.004-1.1) ...
Setting up g++-10 (10.2.1-6) ...
Setting up libfile-listing-perl (6.14-1) ...
Setting up mime-support (3.66) ...
Setting up gpg-wks-client (2.2.27-2+deb11u1) ...
Setting up openssh-server (1:8.4p1-5) ...
Installing new version of config file /etc/init.d/ssh ...
Installing new version of config file /etc/ssh/moduli ...
rescue-ssh.target is a disabled or a static unit, not starting it.
Setting up libtool (2.4.6-15) ...
Setting up grub-efi-ia32-bin (2.04-20) ...
Setting up libfile-fcntllock-perl (0.22-3+b7) ...
Setting up libclone-perl (0.45-1+b1) ...
Setting up grub2-common (2.04-20) ...
Setting up libhtml-tagset-perl (3.20-4) ...
Setting up libglusterfs-dev (9.2-1) ...
Setting up libfilesys-df-perl (0.92-6+b6) ...
Setting up libspice-server1:amd64 (0.14.3-2.1) ...
Setting up libperl4-corelibs-perl (0.004-2) ...
Setting up libpango-1.0-0:amd64 (1.46.2-3) ...
Setting up liblwp-mediatypes-perl (6.04-1) ...
Setting up libyaml-libyaml-perl (0.82+repack-1+b1) ...
Setting up libcommon-sense-perl (3.75-1+b4) ...
Setting up liblinux-inotify2-perl:amd64 (1:2.2-2+b1) ...
Setting up libxml-namespacesupport-perl (1.12-1.1) ...
Setting up libnet-http-perl (6.20-1) ...
Setting up libanyevent-http-perl (2.25-1) ...
Setting up libencode-locale-perl (1.05-1.1) ...
Setting up python3 (3.9.2-3) ...
running python rtupdate hooks for python3.9...
running python post-rtupdate hooks for python3.9...
Setting up libnet-dns-perl (1.29-1) ...
Setting up libterm-readline-gnu-perl (1.37-1) ...
Setting up dnsutils (1:9.16.27-1~deb11u1) ...
Setting up grub-pc-bin (2.04-20) ...
Setting up libcairo2:amd64 (1.16.0-5) ...
Setting up gcc (4:10.2.1-1) ...
Setting up libcephfs2 (14.2.21-1) ...
Setting up libpve-u2f-server-perl (1.1-2) ...
Setting up ifupdown2 (3.1.0-1+pmx3) ...
Setting up pve-docs (7.2-2) ...
Setting up libpython2.7-stdlib:amd64 (2.7.18-8) ...
Setting up liberror-perl (0.17029-1) ...
Setting up grub-pc (2.04-20) ...
Replacing config file /etc/default/grub with new version
Installing for i386-pc platform.
File descriptor 3 (pipe:[101579989]) leaked on vgs invocation. Parent PID 31478: grub-install.real
File descriptor 3 (pipe:[101579989]) leaked on vgs invocation. Parent PID 31478: grub-install.real
File descriptor 3 (pipe:[101579989]) leaked on vgs invocation. Parent PID 31478: grub-install.real



Progress: [ 93%] [######################################################################################################################################################################..............]

I am not quite sure about what "File descriptor 3 (pipe:[101579989]) leaked on vgs invocation. Parent PID 31478: grub-install.real" means.

Unfortunately, pve-version -v says that most of the packages are not correctly installed:

Code:
[root@pve:~]# pveversion -v
proxmox-ve: not correctly installed (running kernel: 5.4.119-1-pve)
pve-manager: not correctly installed (running version: 7.2-4/ca9d43cc)
pve-kernel-5.15: 7.2-3
pve-kernel-helper: 7.2-3
pve-kernel-5.4: 6.4-17
pve-kernel-5.15.35-1-pve: 5.15.35-3
pve-kernel-5.4.189-1-pve: 5.4.189-1
pve-kernel-5.4.119-1-pve: 5.4.119-1
ceph-fuse: not correctly installed
corosync: not correctly installed
criu: not correctly installed
glusterfs-client: not correctly installed
ifupdown: residual config
ifupdown2: not correctly installed
ksm-control-daemon: 1.4-1
libjs-extjs: 7.0.0-1
libknet1: 1.22-pve2
libproxmox-acme-perl: not correctly installed
libproxmox-backup-qemu0: 1.3.1-1
libpve-access-control: not correctly installed
libpve-apiclient-perl: not correctly installed
libpve-common-perl: not correctly installed
libpve-guest-common-perl: not correctly installed
libpve-http-server-perl: not correctly installed
libpve-storage-perl: not correctly installed
libqb0: 1.0.5-1
libspice-server1: not correctly installed
lvm2: not correctly installed
lxc-pve: not correctly installed
lxcfs: 4.0.12-pve1
novnc-pve: 1.3.0-3
proxmox-backup-client: 2.2.1-1
proxmox-backup-file-restore: 2.2.1-1
proxmox-mini-journalreader: 1.3-1
proxmox-widget-toolkit: 3.5.1
pve-cluster: not correctly installed
pve-container: not correctly installed
pve-docs: not correctly installed
pve-edk2-firmware: 3.20210831-2
pve-firewall: not correctly installed
pve-firmware: 3.4-2
pve-ha-manager: not correctly installed
pve-i18n: 2.7-2
pve-qemu-kvm: not correctly installed
pve-xtermjs: 4.16.0-1
qemu-server: not correctly installed
smartmontools: 7.2-pve3
spiceterm: not correctly installed
swtpm: 0.7.1~bpo11+1
vncterm: 1.7-1
zfsutils-linux: not correctly installed

I hope that someone shed me some light about this.

Thank you in advance.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!