quorum problem, creating cluster

Dec 29, 2016
5
0
6
40
Dear,

We try to create a cluster, when we add the second node, we receive the following errors:


From the web interface: cluster not ready - no quorum?
From command line where we created the cluster on:

Quorum information
------------------
Date: Thu Dec 29 12:58:38 2016
Quorum provider: corosync_votequorum
Nodes: 1
Node ID: 0x00000001
Ring ID: 1/8
Quorate: No

Votequorum information
----------------------
Expected votes: 2
Highest expected: 2
Total votes: 1
Quorum: 1 Activity blocked
Flags: 2Node WaitForAll

Membership information
----------------------
Nodeid Votes Name
0x00000001 1 217.23.8.13 (local)


When we tried to at the new node to the cluster it was stuck on Waiting for quorum...
 

Morehouse

New Member
Dec 4, 2016
5
0
1
We had a similar issue when we upgraded our data center to ciscos relatively new Nexus line of switches. Nodes would join the cluster for about 2 mins then fall offline.

Adding "ip igmp snooping querier x.x.x.x" to vlan 1's config fixed the issue. Even more bizarre we had to specify a random IP in the vlan-config command. If a nodes IP was used that node would lose communication after 2 mins.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!