PVE 7 migration to PVE 8: Windows 11


Well-Known Member
Apr 11, 2019

i am doing a migration from PVE7.1 with LVM to PVE8.0 with ZFS using fresh hardware.
So far 4 linux migrations went flawless: Create a backup, transfer the backup file and the configuration. Do the restore on the new host.

But then there is also a W11 VM and this ends in a Bluescreen. The restore is doing as expected, disks are created (Including TPM and EFI).
When i start the VM i get a bluescreen with the error code: 0xc0000001. When i try to start the recovery environment: Missing file \BCD and code: 0xc0000098.
Selection of safe mode does work and W11 will start in safe mode. There fore i dont expect this is a issue with the virtio device drivers.

I tried several suggestions using a W11 recovery stick but those doesnt work, I mainly i guess because in this environemnt some drivers are missing (Can't see TPM and EFI with diskpart / list disk, mains FS is visible).

I am stuck right now, maybe i om overseeing something? Happy for any advice.
I tried some more: Loading vio drivers on the recovery mode using a W11 USB stick.
Now i can see the bootdisk but still i cant see the attached EFI devices. Do they need any other drivers different to the main disk?

Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!