[SOLVED] Proxmox with HBA installed doesnt list Internal Nic in "ip a"

bbaxter18

New Member
Jan 4, 2023
2
0
1
So i have scoured the web for hours looking for my problem and i find things that are close but not clearly the same. Im seasoned in linux but its still a bit foreign to me so please forgive me.

Anyway, as the title states, When I install my HBA (LSI 9210-8i with FW P20 IT), I lose integrated networking on my motherboard(Supermicro H8DGU-f). Everything that i have come across states to change the names within "/etc/network/Interfaces", and i have. The Original names of my Nics were enp2s0f0 and enp2s0f1. The HBA is installed via a riser card, and that card does infact move the PCI numbering +1, I have a GPU installed as well on the riser and within proxmox>hardware>Pci Device the GPU has changed from 3.00.0 to 4.00.0. With that in mind i tried changing the nic names to enp3s0f0 and enp3s0f1 respectively with no change. I also added higher numbers up to 6 (enp#s0f0/1) hoping for the best with no luck.

I removed the HBA and set the interfaces file back to original, and ran an "ip a" command, and it numbers devices 1 though 8, with my nics in postion 2 and 3. When i reinstall the HBA, and run "ip a" again, it still lists out 1 through 8 but 2 and 3 are entirely skipped. The left side of the terminal counts 1,4,5,6,7,8 entirely omitting 2 and 3.

This is where i have been stuck. The HBA does see my drives during post, and i believe the IPMI port on the supermicro is still functional with the HBA installed. The Nics are dual Intel 82576, which operate fine without the HBA installed. Im not currently near the machine but can post screenshots once i get back to it. Any advice or suggestions on getting this figured out would be greatly appreciated. Thanks
 
Well I figured it out. Sometimes its best to look a little closer. while i was grabbing screens, i noticed that while it did skip the 2 and 3, 4 had become enp3s0f0. I modified the network interfaces by changing the enp2s0f0 to enp3s0f0 and it worked. Also, with the GPU installed directly on the motherboard it was PCI ID 3, On the riser with only the GPU populated in it was PCI ID 4, and with both the HBA and GPU populated in the riser, The GPU was PCI ID 5. im using a Supermicro RSC-R2UU-E8E16 with the GPU installed in the X16 slot.

For those with the same problem, im including screens and once you update the IFACE AND BRIDGEPORTS, use the command "ifreload -a" to reload the interfaces and see if your change worked.

Photos with HBA in the name have the HBA installed. Hope this helps others.
 

Attachments

  • HBAgrep enp.jpg
    HBAgrep enp.jpg
    253.4 KB · Views: 16
  • HBAinterfaces.jpg
    HBAinterfaces.jpg
    53.5 KB · Views: 17
  • HBAip a.jpg
    HBAip a.jpg
    96.3 KB · Views: 13
  • HBAlspci.jpg
    HBAlspci.jpg
    258.2 KB · Views: 11
  • Grep enp.jpg
    Grep enp.jpg
    253.6 KB · Views: 12
  • interfaces.jpg
    interfaces.jpg
    146.7 KB · Views: 12
  • ip a.jpg
    ip a.jpg
    135.2 KB · Views: 10
  • lspci.jpg
    lspci.jpg
    263.1 KB · Views: 12

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!