nic

  1. Internal NIC stopped working with Proxmox

    My on-board NIC stopped randomly working and I am completely stuck. Upon booting, leds on the nic cable appear fine then disappear as soon as Proxmox has booted. Tested by booting on an old hard drive that had windows installed, internal nic works fine and cables too (I had internet connection...
  2. NIC passthrough with physical router vs virtual NIC

    I am relatively new to Proxmox. I have a proxmox server with 4 physical NICs (two are 10Gbe). On this server there are currently two VMs, one for Nextcloud and one for a Windows Desktop. I use the desktop VM for everyday work. Would it be better/faster to pass a NIC to every VM and connect...
  3. maxprox

    [SOLVED] after proxmox update Network Cart on Windows changed => VM are offline

    Hi, this week on two proxmox VE server after an Upgrade to the new kernel 5.4.101-1-pve we have on Windows Server VMs the same fault: after the reboot and new start of the windows servers VMs the virtual NIC changed (I dont know how and why) to an other with the same name. The result was: the...
  4. [SOLVED] Installation of NIC removes onboard network interfaces

    BLUF: The onboard interfaces register in linux/Proxmox as well as an additional NIC but just not at the same time. I have a X9DRD-LF-TW008 that I aim to use as an external server/firewall with Proxmox hosting pfSense among other things. The motherboard comes with two interfaces and an...
  5. NIC port speed ethtool cannot set

    Hello, I am trying to change the port speed of my server port to 100baseT/Full. The port is part of a supermicro motherboard. The port is being used as a Linux bridge. The ethtool output: root@pve:~# ethtool eno1 Settings for eno1: Supported ports: [ TP ] Supported link modes...
  6. 1x NIC to 2x NICs (Keep VMs/WAN on 1st & Move PVE/Corosync/etc to 2nd)

    Hi there, I'm looking to update the networking setup for Proxmox VE now that the switches have been swapped out for more capable models. At the moment, each host has 1x NIC connected, which is serving VMs (WAN) and PVE (Web GUI, SSH, Corosync, etc). Static addressing for PVE is set against...
  7. VMs not getting DHCP response and are unaccessible

    tl;dr same config on different machines, different results. How to debug? This is all with a fresh install of 6.3 downloaded today. I've installed on a Aorus Pro AX Z490 board and am using the onboard NIC. After install I set the net interface to DHCP auto vmbr0 iface vmbr0 inet dhcp...
  8. pass through only 1 on 2 identical NIC cards

    I have 2 identical nic cards but I only wish to pass through one of them (not both). Unfortunately the vfio.conf file would point to both instances of the card as they they same xxxx:yyyy code and therefore I presume load the vfio-pci driver for both cards. 04:00.0 Ethernet controller [0200]...
  9. Installing new NIC. Can't locate package.

    I am trying to install a new NIC driver. Whenever I try to apt-get packages, I get E: Unable to locate package. I updated the no-subscription repository in the sources.list and disabled the enterprise repository. Not sure what else to try here.
  10. Windows VM NIC disconnects and how to fix it

    As we moved to PVE 6.2 (just several hosts, not huge install), we noticed that Windows server VMs we used to run on PVE are to see sudden NIC stop working. The fix is really simple: set NIC to not connected (no link) in PVE web interface, apply changes, the connect it again and apply again - all...
  11. Proxmox NIC should behave like a switch

    Hello Proxmox Community, I'm currently setting up a industrial IoT Server right next to an experimental machine setup at a university. My Server runs Proxmox 6.2-11 and has 5 NICs. 1x Onboard NIC 1x Intel NIC with four interfaces. The onboard NIC is connected to the local network with many...
  12. No interfaces shown on Web GUI after NIC change

    Hello, I had to change the NIC in my server running proxmox 6.1-3. New nic got named enp1s0 while the old one was enp4s0. From cli I updated /etc/network/interfaces and /etc/hosts accordingly and can now access web gui correctly. However now it does not show any network interfaces. What am I...
  13. No Network Interface Found for RTL8125B

    Hey, i was trying to install Proxmox onto an Odroid h2+ with the 2.5gbe Realtek Nics. Apparently windows includes it no problem but for Linux you have to install them manually, how can i do that with Proxmox? When i boot up the usb to install it, it fails with the No network interface found...
  14. Virtual NICs with different CIDR ranges

    Hi, I am trying to set up a second subnet in my environment and having trouble working out the virtual NIC configuration. I can get virtual NICs working if the IP addresses are a subset of the CIDR of the bridge associated with the physical NIC, but I cannot get it to work if the CIDR is outside...
  15. Can not access proxmox web interface from second nic

    Hey everyone, i have a little "problem" with my setup. Initially i installed proxmox with two ethernet nics, one built into the motherboard and the other as extra pcie card. BUT: i only plugged one ethernet cable into the pcie ethernet port during the installation. So, right now i reach my web...
  16. Proxmox VE multiple Gateways

    Hi, I want to utilize IPs pointing to my server. Some of them are failover IPs, that are set to my server and can be redirected to other machines in case of dedicated machine failure. What I want to do is setting up IP address and gateway to my second Network Device, but I get default...
  17. [SOLVED] PVE Cluster change/replace NIC

    Hello, i just replaced the NIC's on all my 3 nodes and i upgraded to 10 Gbit's SFP+. All nodes can access each other over ssh without any problems. But since i replaced the NIC's im not able to access the nodes at the web GUI or at least node1 cannot access node 3 or node 2 anymore. I only see...
  18. 2nd NIC

    my VM's are using Ubuntu 18.04 I'm on ProxMox VE 6.1-5 Dell R610 with 96Gig Ram, 2 Tb of storage I have 2 public IP 98.179.240.a and a 2nd 98.179.240.b server a Dell R610 has 4 NIC's 1st NIC is working fine using a IP 98.179.240.a and nat (WORKS) 2nd NIC IP 98.179.240.b is plugged into my ISP...
  19. 2 NIC's configuration

    I have 2 NIC's on a Dell R610 one is using IP 98.179.240.a going to 1 Vm, fully functional and the other IP 98.179.240.b I would like to configure to anther vm they both have the same subnet, Gateway and DNS settings both are Linux Servers 18.04. how is this done, my modem has one port bridge...
  20. replace sfp+nic in a ceph cluster

    I need to replace a 10gb sfp+ 2ports nic with a similar nic that provides 4 ports instead of 2. This particular nic is serving the internodal ceph network in a meshed network configuration, so no switches inside the ring. I'm in a production 3 node cluster with ceph and latest proxmox. replica...

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!