macnug

New Member
Mar 20, 2021
2
0
1
33
Hi everyone,
I have my PROXMOX server installed on a intel nuc10i5 8gb ram and two ssds
On one Home assistant VM, pihole in a CT and in the second ssd a Ubuntu VM with zoenminder.

I tried to passthrough the GPU but when i restarted proxmox, now it's stuck whitout GUI and terminal.

Here two screenshots:
The shorter code is the normal boot where the boot is stuck on /dev/mapper/pve-root: clean.

Using the recovery mode using the Proxmox ISO it is stuck on vfio-pci XXXX vgaarb:changed VGA decodes: oldecodes=io+mem,decodes=io+mem:eek:wns=io+mem

Thanks in advance to anyone can help to solve this mess.

Marco
 

Attachments

  • PHOTO-2021-03-19-23-54-25.jpg
    PHOTO-2021-03-19-23-54-25.jpg
    403.7 KB · Views: 46
  • PHOTO-2021-03-19-22-26-48.jpg
    PHOTO-2021-03-19-22-26-48.jpg
    129.8 KB · Views: 44
Last edited:

leesteken

Famous Member
May 31, 2020
1,525
298
88
Can you press the e key in the boot menu? You can then change the kernel parameters temporarily and prevent the VM from starting (like removing intel_iommu=on). Do you then get a console to login? Hopefully you can undo your changes after login.
 
  • Like
Reactions: macnug

andro0

New Member
Jul 13, 2021
9
0
1
40
Anyone found solution for this? I got a dead Proxmox server because of this too
 

leesteken

Famous Member
May 31, 2020
1,525
298
88
Anyone found solution for this? I got a dead Proxmox server because of this too
Can you see the boot menu? Can you press the e key and change the kernel parameters? Maybe we can prevent your broken VM from automatically starting.
 

andro0

New Member
Jul 13, 2021
9
0
1
40
@avw I see grub boot, I pressed "e", I removed iommu and pcie passthrough related stuff after "quiet", still nothing. I can't prevent guest VM from starting automatically so I can go and remove the PCIE passthrough from VM config
 

leesteken

Famous Member
May 31, 2020
1,525
298
88
@avw I see grub boot, I pressed "e", I removed iommu and pcie passthrough related stuff after "quiet", still nothing. I can't prevent guest VM from starting automatically so I can go and remove the PCIE passthrough from VM config
intel_iommu or amd_iommu (you didn't specify which) could be enable automatically. PLease try intel_iommu=off amd_iommu=off. The iommu parameter does not do what you think it does.
 

andro0

New Member
Jul 13, 2021
9
0
1
40
@avw I set it to on/off, with/without adding it, it still crashes. the PCIE device I'm passing through a 4x 10GB ethernet card.

It's AMD
 

leesteken

Famous Member
May 31, 2020
1,525
298
88
@avw I set it to on/off, with/without adding it, it still crashes. the PCIE device I'm passing through a 4x 10GB ethernet card.

It's AMD
Did you set amd_iommu=off or iommu=off? Sorry, but this is not clear from your message. That should disable PCI(e) passthrough. If this does not work, I'm sorry, I don't know another way.
Maybe PCI(e) passthrough is not the problem in your case? Can you describe your problem in more detail? What did you change? What is not working? What do you see on the console? Can you connect to the machine remotely? Can you boot the machine with another Linux Live CD (systemrescue or Ubuntu or other)?
 

andro0

New Member
Jul 13, 2021
9
0
1
40
@avw It's 100% PCIe passthrough, I set it off specifically, amd_iommu=off, I removed amd_iommu entirely and I left it on. All 3 cases, leads to VM autostarting and crashing the system immediately. How can I enter recover mode and edit the conf file? I did init=/bin/bash as option, dropped to shell, tried to mount lvm storage one by one but couldn't find the conf file. How do I enter proper recovery mode in proxmox?
 

leesteken

Famous Member
May 31, 2020
1,525
298
88
If this "easy" way does not work for you, you need to boot the system using something else and disable the VM from automatically starting. I don't know how to do that because /etc/pve is not a filesystem but a database. Sorry. Maybe someone else here knows a way without reinstalling and using backups?
 

leesteken

Famous Member
May 31, 2020
1,525
298
88
Have you tried disabling all virtualization option in the BIOS? Maybe that can prevent the VM from starting and breaking your system.
 

wowe

New Member
Apr 19, 2022
1
1
3
Have you tried disabling all virtualization option in the BIOS? Maybe that can prevent the VM from starting and breaking your system.
I have registered only to thank you for that hint.
I had the same issue as described here and disabling the virtualization on the host cpu did the trick to avoid auto startup of my VMs.
Thank you! :D
 
  • Like
Reactions: leesteken
May 23, 2022
9
1
3
Have you tried disabling all virtualization option in the BIOS? Maybe that can prevent the VM from starting and breaking your system.
Dear @leesteken you are a live saver! Thanks for that hint. My scenario of total fail:
- moved a VM with GPU requirements from one node in a cluster to another
- there was also a GPU installed but as soon as I passed that through the whole system went down when the VM started
- Having a AMD CPU, I disabled BIOS > Advanced > CPU > SVM Mode
- Reboot, proxmox booted again as expected, VM stayed turned off
- Adjust settings of the VM (disable auto boot, remove failing HW)
- Reboot into BIOS, enable virtualization again
- Test and done
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!