Proxmox 6 lxc container not generate mac address error message in syslog

OliverB

Active Member
Apr 22, 2016
105
3
38
25
Hello,

I have Proxmox 6 Server with LXC Containers. If I added some network adapter to one container everything works fine, mac address is on default settings (auto). But no mac address will generate. In syslog I have this error message:

Code:
systemd-udevd[22359]: link_config: autonegotiation is unset or enabled, the speed and duplex are not writable.
systemd-udevd[22360]: link_config: autonegotiation is unset or enabled, the speed and duplex are not writable.
systemd-udevd[22359]: Using default interface naming scheme 'v240'.
systemd-udevd[22360]: Using default interface naming scheme 'v240'.
systemd-udevd[22360]: Could not generate persistent MAC address for veth116i0: No such file or directory
systemd-udevd[22374]: Using default interface naming scheme 'v240'.
systemd-udevd[22374]: link_config: autonegotiation is unset or enabled, the speed and duplex are not writable.
systemd-udevd[22374]: Could not generate persistent MAC address for fwbr116i0: No such file or directory
systemd-udevd[22360]: link_config: autonegotiation is unset or enabled, the speed and duplex are not writable.
systemd-udevd[22375]: link_config: autonegotiation is unset or enabled, the speed and duplex are not writable.
systemd-udevd[22360]: Could not generate persistent MAC address for fwpr116p0: No such file or directory
systemd-udevd[22375]: Using default interface naming scheme 'v240'.
systemd-udevd[22375]: Could not generate persistent MAC address for fwln116i0: No such file or directory

Any idea what must I do now? How can I solv this problem fast?

Regards,

Oliver
 

OliverB

Active Member
Apr 22, 2016
105
3
38
25
[QUOTE = "oguz, Beitrag: 278609, Mitglied: 63681"]
Hallo,

Ich bin mir nicht ganz sicher, ob dies dasselbe Problem ist, aber es gab diesen Fehler [0], der mit pve-container> = 3.0-11 behoben werden sollte

[0]: https://bugzilla.proxmox.com/show_bug.cgi?id=2453
[/ZITAT]

Hello,

Thanks for fast reply. I have installed proxmox 6 with:
proxmox-ve: 6.0-2 (running kernel: 5.0.21-5-pve)
pve-container: 3.0-10

How can I fix the problem or can install the patch? Will the patch available via apt-get?

Regards
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!