[SOLVED] No local-lvm after Join Cluster/proxmox ve 5.4-3

Zaman

New Member
Apr 15, 2019
29
0
1
26
Hello,
after installation of proxmox ve 5.4-3 when i try to create vm using GUI there is no storage and checking it on GUI list there no local-lvm,so what to do?, there is docs?is it issue?
it's added to cluster.
the installation of two node,the same result.
and i need one of the nodes for backup,so which type of storage to use Ceph,GlusterFS,NFS(on host),NFS(using freenas....),others..
thanks
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
1,501
213
63
South Tyrol/Italy
Hi,

normally a "local-lvm" will always get create if using our provided installation ISO, the only exception currently is when using ZFS during install (as rpool). Did you selected ZFS as installation root filesytem?

My recent local installations which did not got installed with ZFS have all the "lvm-local".

How did you install Proxmox VE? Note that if you install Proxmox VE on top of a Debian installation you need to create the storages you want yourself.
 

Zaman

New Member
Apr 15, 2019
29
0
1
26
I installed proxmox using official iso downloaded from proxmox website,the root filesystem is ext4 filesystem if u mean of first installation option for Hard Drive.
the both (two) nodes having the same issue if it's.
thanks
 

Zaman

New Member
Apr 15, 2019
29
0
1
26
Hi,

normally a "local-lvm" will always get create if using our provided installation ISO, the only exception currently is when using ZFS during install (as rpool). Did you selected ZFS as installation root filesytem?

My recent local installations which did not got installed with ZFS have all the "lvm-local".

How did you install Proxmox VE? Note that if you install Proxmox VE on top of a Debian installation you need to create the storages you want yourself.
check my answer above:)
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
1,501
213
63
South Tyrol/Italy
Also, can you see if it's possible add a "local-lvm" storage via the web GUI? (Datacenter -> Storage -> Add 'LVM-Thin')?
Maybe the cluster join just overwrote the /etc/pve/storage.cfg and thus the local-lvm storage is just not listed anymore (but exists physically).
 

Zaman

New Member
Apr 15, 2019
29
0
1
26
thank u,was mention as template not disk space ,sorry
so delete this thread or make it as solved ?!
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
1,501
213
63
South Tyrol/Italy
so delete this thread or make it as solved ?!
We normally do not delete threads, maybe then can help someone else when searching the net some day.

You could mark it as solved, but no need, you can also just let it as is :)
 

Zaman

New Member
Apr 15, 2019
29
0
1
26
We normally do not delete threads, maybe then can help someone else when searching the net some day.

You could mark it as solved, but no need, you can also just let it as is :)
Hello,
look like there is misunderstood bcs i have 2 nodes,when use one of them ask me for template so was im wrong, but when checking the another node was there is node but there is no storage of disk.
Code:
#lvs
  LV   VG  Attr       LSize   Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
  data pve twi-a-tz-- 703.47g             0.00   0.04                         
  root pve -wi-ao----  96.00g                                                 
  swap pve -wi-ao----   8.00g
#pvesm status
Name             Type     Status           Total            Used       Available        %
local             dir     active        98559220         2842532        90667140    2.88%
local-lvm     lvmthin   disabled               0               0               0      N/A
#cat /etc/pve/storage.cfg
dir: local
        path /var/lib/vz
        content iso,vztmpl,backup
        maxfiles 2
        shared 1
lvmthin: local-lvm
        thinpool data
        vgname pve
        content rootdir,images
        nodes pve,nd3,nd2
Thanks
 
Last edited:

Zaman

New Member
Apr 15, 2019
29
0
1
26
Hello,
look like there is misunderstood bcs i have 2 nodes,when use one of them ask me for template so was im wrong, but when checking the another node was there is node but there is no storage of disk.
Code:
#lvs
  LV   VG  Attr       LSize   Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
  data pve twi-a-tz-- 703.47g             0.00   0.04                         
  root pve -wi-ao----  96.00g                                                 
  swap pve -wi-ao----   8.00g
#pvesm status
Name             Type     Status           Total            Used       Available        %
local             dir     active        98559220         2842532        90667140    2.88%
local-lvm     lvmthin   disabled               0               0               0      N/A
#cat /etc/pve/storage.cfg
dir: local
        path /var/lib/vz
        content iso,vztmpl,backup
        maxfiles 2
        shared 1

lvmthin: local-lvm
        thinpool data
        vgname pve
        content rootdir,images
        nodes pve,nd3,nd2
Thanks
so :):confused:
 

Zaman

New Member
Apr 15, 2019
29
0
1
26
Hello,
after Upgrade (New Node) and connect it to the cluster look like the "local-lvm" removed on GUI,so what to do ?
Code:
root@pve5:~# lvs
  LV            VG  Attr       LSize   Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
  data          pve twi-aotz-- 703.47g             0.12   0.27                          
  root          pve -wi-ao----  96.00g                                                  
  swap          pve -wi-ao----   8.00g                                                  
  vm-100-disk-0 pve Vwi-a-tz--  32.00g data        2.63                                  
  vm-100-disk-1 pve Vwi-a-tz-- 600.00g data        0.00                                  
  vm-101-disk-0 pve Vwi-a-tz--  32.00g data        0.00                                  
  vm-101-disk-1 pve Vwi-a-tz-- 100.00g data        0.00
Code:
root@pve5:~# pvecm status
Quorum information
------------------
Date:             Mon Sep  9 14:00:39 2019
Quorum provider:  corosync_votequorum
Nodes:            4
Node ID:          0x00000004
Ring ID:          1/76
Quorate:          Yes

Votequorum information
----------------------
Expected votes:   4
Highest expected: 4
Total votes:      4
Quorum:           3 
Flags:            Quorate
Membership information
----------------------
    Nodeid      Votes Name
0x00000001          1 192.168.99.5
0x00000002          1 192.168.99.6
0x00000003          1 192.168.99.7
0x00000004          1 192.168.99.9 (local)
Code:
root@pve5:~# pvesm status
Name             Type     Status           Total            Used       Available        %
local             dir     active        98559220        21961668        71548004   22.28%
local-lvm     lvmthin   disabled               0               0               0      N/A
Code:
root@pve5:~# cat /etc/pve/storage.cfg
dir: local
        path /var/lib/vz
        content iso,vztmpl,backup
        maxfiles 2
        shared 1

lvmthin: local-lvm
        thinpool data
        vgname pve
        content rootdir,images
        nodes pve,pve3,pve2
and look like was OS from the same installation ISO,at storage.cfg local like there is no pve5 at lvmthin !
so where is the issue ?
Best Regards
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!