[SOLVED] No internet on Host but VMs and LXCs can be accessed

xyz2610

Member
Mar 12, 2018
3
0
6
Hi,

This is the first time I've ever had a problem with my proxmox server that I could not solve myself. For some weird reason my Proxmox host loses internet access after a reboot. If I restart the networking service, the host often comes back online. But it would never survive a reboot.

My /etc/network/interfaces looks like this
Code:
auto lo
iface lo inet loopback

auto enp2s0
iface enp2s0 inet manual

auto vmbr0
iface vmbr0 inet static
    address  192.168.0.200
    netmask  255.255.255.0
    gateway  192.168.0.1
    bridge-ports enp2s0
    bridge-stp off
    bridge-fd 0
    bridge-vlan-aware yes
    bridge-vids 2-4094
Can anybody please help me?

I am running Proxmox 6.0-6
 
Last edited:

Andreas Piening

Active Member
Mar 11, 2017
75
10
28
42
The only part of your config that looks suspicious to me are the last two lines for vmbr0:
Code:
    bridge-vlan-aware yes
    bridge-vids 2-4094

If you're using VLANs, this might be a source for your issue if not configured correctly.
If you don't use VLANs I would remove these two lines.

However, your post is already solved?
If so, can you explain how it was solved?
 

xyz2610

Member
Mar 12, 2018
3
0
6
There was a dhcp ip route for enp2s0. I deleted that and disabled dhcpd on the host. Rebooted and voila the problem was fixed
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!