Migration fails everytime - found stale ....

nbittinger

New Member
May 30, 2018
1
0
1
38
Receiving the below when performing:
Code:
qm migrate 109 pve1 -with-local-disks -migration_type insecure

Not sure what the deal is or if i am doing something wrong. Simple 3 node cluster.

Code:
15:37:19   43.5G   pool/vm-109-disk-1@__migration__
15:37:20   43.6G   pool/vm-109-disk-1@__migration__
15:37:21   43.7G   pool/vm-109-disk-1@__migration__
volume 'pool/vm-109-disk-1' already exists
exit code 255
full send of pool/vm-109-disk-1@__migration__ estimated size is 43.3G
total estimated size is 43.3G
TIME        SENT   SNAPSHOT
command 'zfs send -Rpv -- pool/vm-109-disk-1@__migration__' failed: got signal 13
send/receive failed, cleaning up snapshot(s)..
2018-08-13 15:37:25 ERROR: Failed to sync data - command 'set -o pipefail && pvesm export vessel-pool:vm-109-disk-1 zfs - -with-snapshots 0 -snapshot __migration__' failed: exit code 255
2018-08-13 15:37:25 aborting phase 1 - cleanup resources
2018-08-13 15:37:25 ERROR: found stale volume copy 'pve1-pool:vm-109-disk-1' on node 'pve1'
2018-08-13 15:37:25 ERROR: found stale volume copy 'vessel-pool:vm-109-disk-1' on node 'pve1'
2018-08-13 15:37:25 ERROR: migration aborted (duration 00:11:42): Failed to sync data - command 'set -o pipefail && pvesm export vessel-pool:vm-109-disk-1 zfs - -with-snapshots 0 -snapshot __migration__' failed: exit code 255
migration aborted

pveversion -v

Code:
proxmox-ve: 5.2-2 (running kernel: 4.15.17-1-pve)
pve-manager: 5.2-6 (running version: 5.2-6/bcd5f008)
pve-kernel-4.15: 5.2-4
pve-kernel-4.15.18-1-pve: 4.15.18-17
pve-kernel-4.15.17-1-pve: 4.15.17-9
pve-kernel-4.13.13-2-pve: 4.13.13-33
corosync: 2.4.2-pve5
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.0-8
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-37
libpve-guest-common-perl: 2.0-17
libpve-http-server-perl: 2.0-9
libpve-storage-perl: 5.0-24
libqb0: 1.0.1-1
lvm2: 2.02.168-pve6
lxc-pve: 3.0.0-3
lxcfs: 3.0.0-1
novnc-pve: 1.0.0-2
proxmox-widget-toolkit: 1.0-19
pve-cluster: 5.0-29
pve-container: 2.0-24
pve-docs: 5.2-5
pve-firewall: 3.0-13
pve-firmware: 2.0-5
pve-ha-manager: 2.0-5
pve-i18n: 1.0-6
pve-libspice-server1: 0.12.8-3
pve-qemu-kvm: 2.11.2-1
pve-xtermjs: 1.0-5
qemu-server: 5.0-30
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.9-pve1~bpo9
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!