Memory Usage not same as in VM

rvdk92

Member
Nov 8, 2020
33
1
8
30
Hello,

My summary of virtual machine Memeory Usage is not correct by all linux servers.

For my windows vm's i have installed the virtio drivers en the guest agent en they memory usage is perfect the same as in task manager.

Only how do i set this in debian and centos servers? I have installed on all linux disti's qemu-guest-agent but it is not correct:

example my zabbix centos 8 server in PVE Summary of the virtual machine show in use: 11GB
1610986144232.png

But in the machine with htop it is: 4GB
1610986070144.png
 

Attachments

  • 1610986036460.png
    1610986036460.png
    28.3 KB · Views: 21
Last edited:

aaron

Proxmox Staff Member
Staff member
Jun 3, 2019
2,865
444
88
Did you disable the "Ballooning Device" checkbox in the (advanced) Memory settings of the VMs?

The device is needed to communicate with the VM and get stats on the internal memory consumption. If that is not possible, PVE is showing the memory consumption of the qemu virtualization process of the VM.
 

rvdk92

Member
Nov 8, 2020
33
1
8
30
No, that is not disbabled.. but what is better? disable them or enabed them?
 

dylanw

Proxmox Staff Member
Staff member
Jul 6, 2020
373
70
28
Also note that the 4GB that you are seeing in htop only refers to the memory being consumed by processes. The blue and brown bars (which consume the rest of your memory) correspond to the memory used by the kernel for buffers and cache. So as Aaron said, Proxmox may just be reading the entire memory used by the VM, without knowledge of what it can reclaim.
free -h provides a better overview of memory use in these situations.

See the htop faq for source:
https://htop.dev/faq.html
 

rvdk92

Member
Nov 8, 2020
33
1
8
30
Also note that the 4GB that you are seeing in htop only refers to the memory being consumed by processes. The blue and brown bars (which consume the rest of your memory) correspond to the memory used by the kernel for buffers and cache. So as Aaron said, Proxmox may just be reading the entire memory used by the VM, without knowledge of what it can reclaim.
free -h provides a better overview of memory use in these situations.

See the htop faq for source:
https://htop.dev/faq.html
Hi, thank you for reply.. but with free -h is about the same as htop and not corresponds with the promox value:

1611227639897.png
 

aaron

Proxmox Staff Member
Staff member
Jun 3, 2019
2,865
444
88
No, that is not disbabled.. but what is better? disable them or enabed them?
It should be enabled as this is the channel via which PVE talks to the VM to gather RAM statistics.

You can check what the VM returns by going to the <vm> -> Monitor panel and entering info balloon at the bottom.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!