LXC containers shows host's load average

Discussion in 'Proxmox VE: Installation and configuration' started by decibel83, Jul 26, 2018.

Tags:
  1. decibel83

    decibel83 Member

    Joined:
    Oct 15, 2008
    Messages:
    147
    Likes Received:
    0
    Hi,
    my LXC containers are showing the same load average of the host.
    I know this is due to some limitations of LXC and I had the same problem with CPU and memory too until some months ago.
    Now after some upgrades containers are showing the correct information about CPU and memory limits. Why it's not the same for load average too?

    The container 911 (staging3) is running on node9:

    Code:
    root@node09:~# pct list
    VMID       Status     Lock         Name               
    904        running                 mediaspooler1       
    905        running                 mediaspooler2       
    909        running                 staging4           
    910        running                 staging2           
    911        running                 staging3           
    1105       running                 wifi       
    Load average on node9 is 1.37, 1.73, 1.46:

    Code:
    root@node09:~# w
     08:33:25 up 171 days, 10:39,  1 user,  load average: 1.37, 1.73, 1.46
    [...]
    
    Load average on staging3 is 1.37, 1.73, 1.46:

    Code:
    root@staging3:/# w
     08:33:24 up 1 day, 20:34,  1 user,  load average: 1.37, 1.73, 1.46
    [...]
    
    I verified that if host's load average goes up, also the container's one grows, so they are synchronized.

    Could you help me please?
    Thanks!
     
  2. sahostking

    sahostking Member

    Joined:
    Oct 6, 2015
    Messages:
    311
    Likes Received:
    8
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    fireon likes this.
  3. dbartus

    dbartus New Member

    Joined:
    Aug 8, 2018
    Messages:
    2
    Likes Received:
    0
    any idea when the fix will be applied to proxmox?
     
  4. fabian

    fabian Proxmox Staff Member
    Staff Member

    Joined:
    Jan 7, 2016
    Messages:
    3,191
    Likes Received:
    493
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    fireon likes this.
  5. dbartus

    dbartus New Member

    Joined:
    Aug 8, 2018
    Messages:
    2
    Likes Received:
    0
    Hi Proxmox team,

    I've been checking the bugzilla for a while on this issue, and it's still on status "Assigned". Any update on this issue?

    I've also seen there are few other threads on this in this forum as well.

    Thanks for your reply. Really looking forward for this feature to be implemented on Proxmox.
     
  6. mailinglists

    mailinglists Active Member

    Joined:
    Mar 14, 2012
    Messages:
    349
    Likes Received:
    33
    By the looks of things in mailing list it seems like this patch was included today.
     
    dbartus likes this.
  7. oguz

    oguz Proxmox Staff Member
    Staff Member

    Joined:
    Nov 19, 2018
    Messages:
    315
    Likes Received:
    26
    This is now resolved. Whether to enable it default or not, will be decided later.

    Willing users can enable this behaviour by editing:

    Code:
    /lib/systemd/system/lxcfs.service
    
    and by adding the `-l` flag in ExecStart. Then restart service and containers.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. jmcorrea

    jmcorrea New Member
    Proxmox Subscriber

    Joined:
    Jul 16, 2018
    Messages:
    13
    Likes Received:
    0
    Hello!
    we have 2 hosts running Proxmox 5.2.1. I checked and lxc-pve is version 3.0.0-3. Did a apt-get upgrade and rebooted server, after that added the -l to /lib/systemd/system/lxcfs.service, but still top shows the host load.
    Do we need to upgrade anything else?
    Thanks!
    Juan Correa
     
  9. oguz

    oguz Proxmox Staff Member
    Staff Member

    Joined:
    Nov 19, 2018
    Messages:
    315
    Likes Received:
    26
    The package is `lxcfs` and the version with this patch is 3.0.3-pve1

    Did you do `apt update` before `apt upgrade`? Was the lxcfs package upgraded at all? Which repository are you using? This is not in the enterprise repository yet, but you should be able to find it in pve-no-subscription
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. jmcorrea

    jmcorrea New Member
    Proxmox Subscriber

    Joined:
    Jul 16, 2018
    Messages:
    13
    Likes Received:
    0
    Hello Oguz,

    thank you! I just noticed that I didnt have the no-subscription repositories enabled. I added them, updated lxcfs, added the -l to
    /lib/systemd/system/lxcfs.service and now the load is showing correctly.

    Best regards,
    Juan Correa
     
  11. oguz

    oguz Proxmox Staff Member
    Staff Member

    Joined:
    Nov 19, 2018
    Messages:
    315
    Likes Received:
    26
    Which repository were you using? Use no-subscription repository only if you don't use the enterprise repositories. It will cause package management problems to have both repositories.

    https://pve.proxmox.com/wiki/Package_Repositories
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. jmcorrea

    jmcorrea New Member
    Proxmox Subscriber

    Joined:
    Jul 16, 2018
    Messages:
    13
    Likes Received:
    0
    Hello Oguz,

    we have the enterprise repositories enabled, but we don't have a subscription yet, we are going to buy it but im waiting for my boss to do it. I commented the enterprise repository and enabled the no-suscription ones. Run a apt clean, apt update and apt upgrade lxcfs. After that I undid the changed made to the repositories, so we are back to the enterprise ones.

    Thanks!

    Juan Correa
     
  13. oguz

    oguz Proxmox Staff Member
    Staff Member

    Joined:
    Nov 19, 2018
    Messages:
    315
    Likes Received:
    26
    How are you using the enterprise repository without a subscription? It should be returning a 401 Unauthorized error if you didn't enable subscription yet (which means you are not going to be able to get any updates).

    I suggest you to switch to the pve-no-subscription repository and do a
    Code:
    apt update
    apt full-upgrade
    
    to get the latest version from everything. You can re-enable the enterprise repositories once you get your subscription.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. jmcorrea

    jmcorrea New Member
    Proxmox Subscriber

    Joined:
    Jul 16, 2018
    Messages:
    13
    Likes Received:
    0
    Hello Oguz,

    thanks! Indeed the updates get 401 error. I saw that the no-subscription packages has a warning on the docs:
    It can be used for testing and non-production use. Its not recommended to run on production servers, as these packages are not always heavily tested and validated.
    Our servers are in production and they already have quite a few servers. That's why I only updated lxcfs instead of a full upgrade.

    Anyway, we should be getting the subscription in a few days, we have it on our to-do list, so I guess its safer to wait and upgrade with the enterprise safe and tested packages.

    Best regards,

    Juan Correa
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice