[SOLVED] LXC container fails to start


New Member
Mar 26, 2018
So i tried to make my first LXC container, got the ubuntu 16.04 image from Proxmox. When i try to start it it give me this:

Job for pve-container@101.service failed because the control process exited with error code.
See "systemctl status pve-container@101.service" and "journalctl -xe" for details.
TASK ERROR: command 'systemctl start pve-container@101' failed: exit code 1

When i try running it in the foreground i get:
lxc-start: 101: lxccontainer.c: do_lxcapi_start: 984 Permission denied - Failed to make / rslave at startup

I'm brand new to this stuff so I'm guessing there's something simple I'm missing, any help would be appreciated.
you don't have a correct repository configuration for PVE, and thus didn't receive upgrades to workaround a recent apparmor change in Debian 9.4. configure the repositories, do an upgrade ('apt update; apt full-upgrade') and your containers will start again.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!