GPU passthrough tutorial/reference

IvanAngelplus

New Member
Sep 2, 2019
2
0
1
31
Thank you very much for responding so quickly.

I tried that configuration, but does not work.

I paste my .conf file:

# nano /etc/pve/qemu-server/100.conf
args: -machine type=q35,kernel_irqchip=on
bios: ovmf
boot: dcn
bootdisk: virtio0
cores: 4
cpu: host
efidisk0: local-lvm:vm-100-disk-1,size=128K
hostpci0: 04:00.0,pcie=1,x-vga=1
ide2: local:iso/virtio-win-0.1.141.iso,media=cdrom,size=309208K
machine: pc-q35-3.1
memory: 5120
name: w10
net0: virtio=E2:C0:87:FE:C5:FC,bridge=vmbr0,firewall=1
numa: 1
onboot: 1
ostype: win10
scsihw: virtio-scsi-pci
smbios1: uuid=5ced3810-d8fe-4438-bf80-a6bf2058ce51
sockets: 1
virtio0: local-lvm:vm-100-disk-0,cache=writethrough,size=240G
vmgenid: ece257c6-281b-4c2d-a8c0-03a90dbda226
 

elurex

Active Member
Oct 28, 2015
172
4
38
Taiwan
  1. machine type needs to be pc-q35-3.1 please remove args: -machine type=q35,kernel_irqchip=on
  2. you need to pass pcie 04:00 entire card
  3. do you have iommu enabled in /etc/default/grub
  4. does your cpu and motherboard support VT-d
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!