debian and ubuntu passthrough vga install failures

machstem

New Member
Jul 18, 2018
2
0
1
40
Version:

pve-manager/5.2-5/eb24855a (running kernel: 4.15.18-1-pve)

/etc/default/grub:


GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on video=efifb=off"

System Information:

Gigabyte Z370 Aorus Gaming 3
Intel i7 8700k
16gb DDR4
SSD
nvidia 1070GTX 8gb
nvidia 710 1gb

I run two virtual machines, and I wish to run both simultaneously, and both with their own kb/mouse, gpu/hdaudio.

Windows 10 is currently running with the 1070 and I get a nice steady 60FPS in most of my bigger games. I don't seem to have any issues (thus far) with performance, etc.

/etc/pve/qemu-server/100.conf

agent: 1
bios: ovmf
boot: dcn
bootdisk: virtio0
cores: 12
cpu: host
efidisk0: local-lvm:vm-100-disk-2,size=128K
hostpci0: 01:00.0;01:00.1,pcie=1,x-vga=on
hostpci1: 00:1f.3
machine: q35
memory: 9537
name: win10-turtle
net0: virtio=92:3F:34:73:54:B3,bridge=vmbr0
numa: 1
ostype: win10
scsihw: virtio-scsi-single
smbios1: uuid=3c179d61-90f6-455d-8810-07a3bb17887f
sockets: 1

My current issue is running the secondary virtual machine, which correctly uses the nvidia 710. I will succeed some times at installing ubuntu, but almost every other 10-15 minutes the entire computer locks up and I cannot access anything. dmesg shows nothing in particular.

I've also tried to install both debian netinstall 9.3 and 9.5, and both immediately lock up after selecting any of the available options at the initial debian installation screen.

I've noticed a flood of errors on the guest regarding the nouveau driver, so my thought process was to run debian in nomodeset to create my machine, but it refuses to install.

/etc/pve/qemu-server/101.conf
agent: 1
bios: ovmf
boot: dc
bootdisk: virtio0
cores: 12
cpu: host
efidisk0: ssd120gb:101/vm-101-disk-2.qcow2,size=128K
hostpci0: 08:00.0;08:00.1,x-vga=on,pcie=1
machine: q35
memory: 3072
name: ubuntu-desktop
net0: virtio=12:FA:64:04:0A:A1,bridge=vmbr0
numa: 0
ostype: l26
sata2: nfsserver:iso/debian-9.5.0-amd64-netinst.iso,media=cdrom,size=291M
scsihw: virtio-scsi-single
smbios1: uuid=e90721b4-211e-4734-ad8f-9cc7749ed2f9
sockets: 1

Any advice, or has anyone else noticed it?

I can reproduce this while the Windows 10 virtual machine is running, and when it's offline.
 

machstem

New Member
Jul 18, 2018
2
0
1
40
For what it's worth, I've successfully launched and installed, currently running manjaro linux. When I was having some issues, errors in dmesg, I ran the installation with nvidia instead of nouveau and thing were much better.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!