Windows VMs won't start

theleviwasbri

Member
Dec 14, 2019
5
0
6
31
So I recently upgraded to Proxmox 6.1 on the same hardware (r710) I was running 5.4 on, but ever since the update my Windows VM's WILL NOT start no matter if they were existing (from backup) or if I create new ones. The syslog isn't very helpful either. The error I keep getting is:

TASK ERROR: start failed: command '/usr/bin/kvm -id 500 -name DC-01 -chardev 'socket,id=qmp,path=/var/run/qemu-server/500.qmp,server,nowait' -mon 'chardev=qmp,mode=control' -chardev 'socket,id=qmp-event,path=/var/run/qmeventd.sock,reconnect=5' -mon 'chardev=qmp-event,mode=control' -pidfile /var/run/qemu-server/500.pid -daemonize -smbios 'type=1,uuid=3ec3b121-46bf-446b-b73a-8f1b7f746b9e' -smp '4,sockets=1,cores=4,maxcpus=4' -nodefaults -boot 'menu=on,strict=on,reboot-timeout=1000,splash=/usr/share/qemu-server/bootsplash.jpg' -vnc unix:/var/run/qemu-server/500.vnc,password -no-hpet -cpu 'kvm64,+lahf_lm,+sep,+kvm_pv_unhalt,+kvm_pv_eoi,hv_spinlocks=0x1fff,hv_vapic,hv_time,hv_reset,hv_vpindex,hv_runtime,hv_relaxed,hv_synic,hv_stimer,hv_ipi,enforce' -m 10240 -device 'pci-bridge,id=pci.1,chassis_nr=1,bus=pci.0,addr=0x1e' -device 'pci-bridge,id=pci.2,chassis_nr=2,bus=pci.0,addr=0x1f' -device 'vmgenid,guid=35518e99-e8a0-4e39-a72f-843a135c8ad4' -device 'piix3-usb-uhci,id=uhci,bus=pci.0,addr=0x1.0x2' -device 'usb-tablet,id=tablet,bus=uhci.0,port=1' -device 'VGA,id=vga,bus=pci.0,addr=0x2' -device 'virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3' -iscsi 'initiator-name=iqn.1993-08.org.debian:01:584c3e663c7a' -drive 'file=/mnt/pve/proxmox-nfs/template/iso/Windows Server 2019 Eval.iso,if=none,id=drive-ide2,media=cdrom,aio=threads' -device 'ide-cd,bus=ide.1,unit=0,drive=drive-ide2,id=ide2,bootindex=200' -drive 'file=/var/lib/vz/template/iso/virtio-win-0.1.171.iso,if=none,id=drive-ide3,media=cdrom,aio=threads' -device 'ide-cd,bus=ide.1,unit=1,drive=drive-ide3,id=ide3,bootindex=201' -drive 'file=/dev/pve/vm-500-disk-0,if=none,id=drive-virtio0,cache=writeback,format=raw,aio=threads,detect-zeroes=on' -device 'virtio-blk-pci,drive=drive-virtio0,id=virtio0,bus=pci.0,addr=0xa,bootindex=100' -netdev 'type=tap,id=net0,ifname=tap500i0,script=/var/lib/qemu-server/pve-bridge,downscript=/var/lib/qemu-server/pve-bridgedown,vhost=on' -device 'virtio-net-pci,mac=96:96:24:F5:DD:7C,netdev=net0,bus=pci.0,addr=0x12,id=net0,bootindex=300' -rtc 'driftfix=slew,base=localtime' -machine 'type=pc+pve1' -global 'kvm-pit.lost_tick_policy=discard'' failed: got timeout

I've tried many different virtualized hardware configurations including the recommended one on the wiki and trying both no cache and write back disk configs, but nothing I do seems to fix the issue.

Here's the current config of the machine (I've also tried the recommended SCSI config but no dice):

onboot: 1
ostype: win10
scsihw: virtio-scsi-pci
smbios1: uuid=3ec3b121-46bf-446b-b73a-8f1b7f746b9e
sockets: 1
startup: order=1
virtio0: local-lvm:vm-500-disk-0,cache=writeback,size=50G
vmgenid: 35518e99-e8a0-4e39-a72f-843a135c8ad4
root@VH-01:/var/log# balloon: 5120
name: DC-01
net0: virtio=96:96:24:F5:DD:7C,bridge=vmbr0
-bash: balloon:: command not found
numa: 0
onboot: 1
root@VH-01:/var/log# bootdisk: virtio0
-bash: bootdisk:: command not found
sockets: 1
startup: order=1
virtio0: local-lvm:vm-500-disk-0,cache=writeback,size=50G
vmgenid: 35518e99-e8a0-4e39-a72f-843a135c8ad4


anyway I'm at my wits end with this. They worked great on 5.4 but now I can't use the existing VM's I had or create new ones without running into this error. I've googled my ass off but it doesn't seem that anyone else is having this issue. It's probably also worth mentioning that the 6.1 upgrade was a clean install not an actual upgrade in place. When I do try and start them the GUI shows that they are started and using 526mb of memory, but no cpu or anything else and no VNC and it will keep showing this pseudo running mode until I stop the machine. I've attached a picture of this weird started state, and as you can see in it I have a running qemu linux box as well as 2 lxc containers
 

Attachments

  • proxmox start issue.jpg
    proxmox start issue.jpg
    398.1 KB · Views: 22
what is your 'pveversion -v' ?
 
This is solved. I ended up running and update/upgrade, which didn't fix the problem by itself, but after a reboot of proxmox everything worked fine again.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!