vm cannot receive packets

ysmreg

New Member
Jan 30, 2025
3
0
1
After changing my proxmox router, things that used to work over wifi no longer work.
The proxmox host is online, but the VM is offline because it cannot access the gateway even if a fixed IP is set.
The static IP of the router is 192.168.0.1
 

Attachments

  • Screenshot_20250131_130300.jpg
    Screenshot_20250131_130300.jpg
    63.5 KB · Views: 4
  • Screenshot_20250131_130641.jpg
    Screenshot_20250131_130641.jpg
    79.8 KB · Views: 4
  • Screenshot_20250131_130758.jpg
    Screenshot_20250131_130758.jpg
    121.7 KB · Views: 4
Hi,
as far as I can recall the described setup with wifi is not officially supported.
If you just changed your router, most likely the issue will be found in the configuration there.
Are the VMs configured to get their IP addresses via DHCP?
If yes, can you see on the router, that it receives the DHCP requests? Or does it have a log you might look into for that?

If you share more information about your setup, like router type and configuration, vm configuration, help can be more specific.
 
Thank you for your reply. The router is using openwrt and the VM is set to get an IP address via DHCP. In tcpdump, the router is sending a v4 DHCP offer, but it does not appear in the proxmox host dump or vm dump.
router network settings
Code:
config interface 'loopback'
    option device 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd4a:edf5:9be1::/48'

config device
    option name 'br-lan'
    option type 'bridge'
    option bridge_empty '1'
    option ipv6 '1'

config interface 'lan'
    option proto 'static'
    option ipaddr '192.168.0.1'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option broadcast '192.168.0.255'
    option device 'br-lan'

dhcp settings
Code:
config dnsmasq
    option domainneeded '1'
    option localise_queries '1'
    option rebind_protection '1'
    option rebind_localhost '1'
    option local '/lan/'
    option domain 'lan'
    option expandhosts '1'
    option cachesize '1000'
    option authoritative '1'
    option readethers '1'
    option leasefile '/tmp/dhcp.leases'
    option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
    option localservice '1'
    option ednspacket_max '1232'
    option port '53'
    option allservers '1'
    option logdhcp '1'
    list interface 'lan'

config dhcp 'lan'
    option interface 'lan'
    option start '2'
    option limit '150'
    option leasetime '12h'
    option dhcpv4 'server'
    option dhcpv6 'server'
    option ra 'relay'
    option ndp 'relay'

config dhcp 'wan'
    option interface 'wan'
    option ignore '1'

config odhcpd 'odhcpd'
    option maindhcp '0'
    option leasefile '/tmp/hosts/odhcpd'
    option leasetrigger '/usr/sbin/odhcpd-update'
    option loglevel '4'

config dhcp 'wan6'
    option interface 'wan6'
    option ignore '1'
    option master '1'
    option ra 'relay'
    option dhcpv6 'relay'
    option ndp 'relay'

config host
    option name 'pve'
    option dns '1'
    list mac 'pve mac address'
    option ip '192.168.0.5'
    option instance 'cfg01411c'
    option broadcast '1'

config host
    option name 'vm1'
    option dns '1'
    list mac 'BC:24:11:0C:5F:DF'
    option ip '192.168.0.25'
    option instance 'cfg01411c'
    option broadcast '1'
 

Attachments

  • スクリーンショット 2025-01-31 170939.png
    スクリーンショット 2025-01-31 170939.png
    463.2 KB · Views: 3
  • imafge.png
    imafge.png
    54.1 KB · Views: 4