Unable to Authenticate with AD User

clbx

New Member
Dec 29, 2020
2
0
1
24
I have a Windows Domain that all of my boxes are joined too. I joined my two Proxmox hosts to the domain, and I'm able to su to Active Directory users and use them as normal on the local machine.

However, when I go into proxmox, I get "Login Failed. Please try again" and in the syslog I get:

Dec 28 19:40:33 [HOSTNAME] pvedaemon[100139]: authentication failure; rhost=192.168.1.xxx user=[USERNAME]@pam msg=Authentication failure

I'm not all that familiar with Linux auth methods. How could I set it up to allow my active directory users to authenticate in Proxmox?
 

ph0x

Renowned Member
Jul 5, 2020
1,326
212
68
/dev/null
I also joined my cluster members to a samba domain but pam logins only work with local users.
So I configured LDAP/AD within PVE GUI for the samba users and that works fine.
 

clbx

New Member
Dec 29, 2020
2
0
1
24
I also joined my cluster members to a samba domain but pam logins only work with local users.
So I configured LDAP/AD within PVE GUI for the samba users and that works fine.
I completely missed the active directory integration. That's a lot easier than messing around with PAM
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!