Suspended: LACP currently not enabled on the remote port.

Fay

New Member
Aug 26, 2018
1
0
1
34
Hi Everyone.

I am trying to get the bonding work with my Cisco WS-C3850-24T switch but I keep getting "Suspended: LACP currently not enabled on the remote port" when I check my logs on the switch, here's my configuration on switch side.

Code:
interface Port-channel22
 description Access PROXMOX-SRV
 switchport trunk native vlan 999
 switchport trunk allowed vlan 148
 switchport mode trunk

!
interface GigabitEthernet1/0/8
 description Access PROXMOX-SRV
 switchport trunk native vlan 999
 switchport trunk allowed vlan 148
 switchport mode trunk
 channel-protocol lacp
 channel-group 22 mode active
 spanning-tree portfast trunk
 spanning-tree bpduguard enable

!
interface GigabitEthernet1/0/9
 description Access PROXMOX-SRV
 switchport trunk native vlan 999
 switchport trunk allowed vlan 148
 switchport mode trunk
 channel-protocol lacp
 channel-group 22 mode active
 spanning-tree portfast trunk
 spanning-tree bpduguard enable

And here's my interface file.
Code:
auto lo
iface lo inet loopback

iface eno1 inet manual

iface eno2 inet manual

iface eno3 inet manual

iface eno4 inet manual

auto en02
iface en02 inet manual

auto en03
iface en03 inet manual

auto bond0
iface bond0 inet static
    address  192.168.48.55
    netmask  255.255.255.0
    slaves en02 en03
    bond_miimon 100
    bond_mode 802.3ad
    bond_xmit_hash_policy layer3+4

auto vmbr0
iface vmbr0 inet static
    address  192.168.0.28
    netmask  255.255.255.0
    gateway  192.168.0.1
    bridge_ports eno1
    bridge_stp off
    bridge_fd 0

Error.
Code:
Aug 26 15:55:06.644: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/8, changed state to up
Aug 26 15:55:06.792: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/9, changed state to up
Aug 26 15:55:15.920: %EC-5-L3DONTBNDL2: Gi1/0/8 suspended: LACP currently not enabled on the remote port.
Aug 26 15:55:16.072: %EC-5-L3DONTBNDL2: Gi1/0/9 suspended: LACP currently not enabled on the remote port.

Thanks!
 
Hi
The same thing happend to me... I removed a GPU-card, and then I got the same messages. Didn't understand why...
After som digging I found out that the ethernet card had changed name from
enp2s0f0 to enp1s0f0 and so on (multiple network cards)

i found the network cards new name here:
/sys/class/net

And I then had to change all the network names in /etc/network/network
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!