Nov 15, 2015
Hi good people.
I am trying to install proxmox ve 5.2 on supermicro server. I have 2x SSD Intel DC3510 800GB connected to internal SATA controller (AHCI mode) on the motherboard Supermicro X10DRi. I want to make ZFS RAID10 installation but installation process ended with error:
"unable to get device for partition 1 on device /dev/sdae"
I used both UEFI and Legacy mode in BIOS without success.
After a lot of attempts with different settings I made proxmox ve 4.4 usb flash and installation process was successful (in Legacy BIOS mode). But after installation i can't boot system.

PS i have connected HGST JBOD to the server using LSI 3008 HBA (3 SAS SSD + 12 SAS HDD multipath configuration), but i excluded it from boot process. Btw i have disconnected JBOD, but error is same. So i think that connected JBOD is not affecting installation process.


  • 20180626_143253.jpg
    90.9 KB · Views: 12

Proxmox VE installer does not allow more than 26 devices(sd[a-z]).
If you must unplug your DAS.
Hi. Big thx. It's worked. DIsconnected jbod, successfuly installed proxmox 5.2-1, attached jbod - and now i see all disks! Perfect. Maybe you will add this info (about installer disks limit) to wiki installation manual? JBOD is cheap and effective method of disk attaching.
I already fixed it now 256 disks are possible.
The fix will available in the next iso.
So I guess PVE 5.3 or something greater proxmox-ve_5.2-1.iso


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!