Stuck at EFI stub


New Member
Jul 8, 2023
Hi everyone,
I've been using Proxmox for a few years now and I've been extremely happy with it.
I'm making a new deployment on a Dell Poweredge r530 Server and I'm having some strange problems.
I had previously used Proxmox 7.4 with no issues at all, however a fresh Proxmox 8.0 install is giving me plenty of headaches.
It installs fine on a ZFS RAID 1 pool, however it wont boot. It hangs after "EFI stub: Loaded initrd from LINUX_EFI_INITRD_MEDIA_GUID device path".
I'm using a PERC HBA330 as a HBA controller. However I tried replacing it with a PERC H730 RAID controller in HBA mode and it boots fine. It's very weird.
Does anyone know any way I can diagnose this booting issue? I don't want to deploy a new server on a previous Proxmox release.

I add that the Proxmox 8.0 install is on kernel 6.2.16-3 while the Proxmox 7.4 install was on the opt-in kernel 6.2.11-2, so i think we can rule out a kernel problem.

Last edited:
I tried to install 8.0 on Dell R730xd yesterday at night, installation went fine, but it also hands on the "EFI stub: Loaded initrd from LINUX_EFI_INITRD_MEDIA_GUID device path". Also using PERC HBA330.
Does an installation of (only) Debian 12 succeed? If so - you could install Proxmox 8.0 after the fact.
I did not try to install Debian 12, but what I tried was - I installed 7.4, and then did in place upgrade to 8. It booted. Several observations:
1. The version of the instance after boot is 8.0.3, the image I downloaded and used to install version 8 was 8.0-2. It's possible something has changed in the repos after the installation image was built.
2. The message EFI prints was something like "EFI stub: Loaded initrd from command line." or something like that, but not LINUX_EFI_INITRD_MEDIA_GUID. So it's possible the old version and upgrade configure boot loader slightly different than the installer of 8.0.

If you are ok with reinstall - you can do the 7.4 install and upgrade to 8.
Having the same issue with a clean reload on some nodes with 8.0-2.
Same. Tried a clean install of PVE8.0-2 on a dell r730xd with a perc hba330.
Gets stuck at efi stub: loaded initrd from linux_efi_initrd_media_guid device path.

I will try installing PVE 7 and upgrading to PVE 8.

Screenshot from 2023-07-29 12-10-15.png

Edit - Installing PVE7 and then updating to PVE8 works.

  1. Install the PVE7 iso.
  2. I used this tutorial to update PVE7 to the latest version of PVE7.
  3. I used this tutorial to upgrade PVE7 to PVE8.
Last edited:
My R730xd servers loaded 8.02 fine. It was the odd QCT nodes that failed to boot for me. Reloading with 7.4 and upgrading worked fine.
Is a Dell server with HBA330 is some sort of exotic configuration? I would think this fairly common? Is this not a valid hardware configuration that the developers might want to support? I have been waiting on a fix on this for a while now and I am trying to figure out if it is getting fixed any time soon or if I should just install 7.4.
r740xd with HBA330 trying to install Proxmox on to zfs raid 1 on 2x intel s3710 400GB drives.
I do have a similar issue with my Primergy RX1330 M3 & CP400i IT-Mode controller, but I get this second message "EFI stub: Measured initrd data into PCR 9" and that's it. No access via browser nor SSH.
Didn't try to install PVE7 yet, because I was wondering if anything new came up solving this issue, perhaps an 8.0.3 iso anytime soon?

Many Thanks
I had a similar issue on an intel NUC (PCR 9 error like Umbrealla-Corp) when switching from a debian 12 installation to proxmox 8 kernel (using systemd-boot). I found out the kernel cmdline was wrong (ROOT= instead of root=) but even after that it wouldn't show anything after those lines. However it turned out that it was actually booting, but if it needed the console in initramfs (for example if the root device could not be found and it dropped to a shell or in my case it needed a LUKS password) it woudn't display anything. If I blindly typed in my LUKS password it would actually boot.
The latest debian kernels (6.1) would boot fine btw, only the PVE kernel had this problem. I suspect it has something to do with CONFIG_FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER or related settings being different in this kernel but I'm not sure. In any case I was able to fix it by including the display driver module in initramfs:
When booted find out what display driver is used (hwinfo --gfxcard after "Driver:", or dmesg | grep 'framebuffer'), in my case i915. Add it to /etc/initramfs-tools/modules and run update-initramfs -u (optionally -k all for all kernels). After that I was able to access the console in initramfs again. If you have a weird keyboard setup and your keyboard is not working you may need something similar for that.
I just hit this issue today. Ironically I've been looking for a reason to try xcpng but wasn't quite ready for that yet. Hoping there's an elegant fix rather than inhaling 7.x and upgrading
Seems hit this issue today. I don't remember exactly full line, but was stuck , hang , no keyboard with line "EFI stub"
My case was Baremetal conversion to PVE 8.0 / Kernel 6.2 with install in EFI ZFS RAID1 (so SystemD Boot loader)
HW was AMD Ryzen 5 3600 on MB MSI B450.
in BIOS turning SVM (virtualization) from Off to On,
but was turning Off NX mode since don't care about any protection or mitigations for this system ..
Then stuck at EFI Stub line
Re-enabling NX mode was required. I though was optional but not.
Last edited:
Same exact issue with 2 different servers of mine, Both R620s with a H310 Mono Mini RAID card that I flashed to IT mode. Im sure the flashing process is what caused this because it was installing fine before this. Either way problem was resolved by installing 7 and upgrading to 8 on both machines. It would be nice if whatever is working on 7 that isnt on 8 could be moved over or fixed because I dont want to have to hold onto this ISO "Just incase" for this problem

(For reference to anyone interested in fixing this issue)
The UEFI I use is the one included from Fohdeesha
flashboot /root/Bootloaders/x64sas2.rom
Last edited:
has anyone updated the problem machines to the newest update? i think proxmox is not able to handle these problem or not interested.... since the 8.1-1 iso the whole installation process will not start and an upgrade from clean install with proxmox-ve_8.0-2.iso will also fail booting. all older versions than 8.1.1 working fine. Dell t340 with flashed perc 330 to hba330. but this can not be the problem, because if i disable the controller (via idrac pci slots disabled) the error is the same. there must be a change fail between 6.2.16-20 and 6.5.11-7 and i have the problem with grub and systemd.
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!