[SOLVED] Shared storage (nfs) in a cluster not online.


New Member
May 23, 2023

I am trying to create a shared storage (nfs) to a Truenas machine in a 2 machine VE 8.x cluster.

I have direct 25Gb connections between the VE hosts and the Truenas host


I have updated the hosts file on the proxmox hosts and confirmed I can ping CIRRUS (truenas) from both hosts.

root@galaxy:/# cat /etc/hosts localhost.localdomain localhost galaxy.office.vsoft.local galaxy raptor.office.vsoft.local raptor diamond.office.vsoft.local diamond cirrus.office.vsoft.local cirrus

root@raptor:/# cat /etc/hosts localhost.localdomain localhost raptor.office.vsoft.local raptor galaxy.office.vsoft.local galaxy diamond.office.vsoft.local diamond cirrus.office.vsoft.local cirrus

I configured the nfs storage using the host name (cirrus),

nfs: vmbackup
        export /mnt/rusty/proxomox-backup
        path /mnt/pve/vmbackup
        server cirrus
        content backup
        prune-backups keep-all=1

however the web ui shows the storage status as unknown.

looking at journalct | grep vmbackup

on raptor (the first host I setup) the most recent entry is from a backup I ran before creating the cluster

on galaxy

Nov 22 17:43:30 galaxy pvestatd[5549]: storage 'vmbackup' is not online
Nov 22 17:43:30 galaxy pvedaemon[310161]: storage 'vmbackup' is not online

pvesm status shows vmbackup inactive on both servers

root@raptor:/# pvesm status
Name             Type     Status           Total            Used       Available        %
ISOs             cifs     active     34959300864       287504512     34671796352    0.82%
local             dir     active       223507200        12766976       210740224    5.71%
local-zfs     zfspool     active       210740352              96       210740256    0.00%
scratch       zfspool     active      7365197824       284516100      7080681724    3.86%
vmbackup          nfs   inactive               0               0               0    0.00%
vmdata        zfspool     active     11089739776      3033251768      8056488008   27.35%

Any ideas why this wouldn't work?

Edit: forgot to mention this storage was working when I had a single pve host (raptor).
Last edited:
Additional info, I rebooted both hosts, now the storage is active on raptor (where it was originally defined) but still inactive on galaxy.

On raptor
root@raptor:~# mount | grep vmbackup
cirrus:/mnt/rusty/proxomox-backup on /mnt/pve/vmbackup type nfs4 (rw,relatime,vers=4.2,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,clientaddr=,local_lock=none,addr=

on galaxy there is no mount for the storage.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!