[SOLVED] Proxmox Web GUI Problems

Tarek Damak

New Member
Dec 19, 2016
22
0
1
24
Hello Evrybody ,
i can not acces to my proxmox web interface ,
i tried to restart the pveproxy,pvedaemon,pve-manager , it started with no errors but then i find that the status is active:exits
Code:
● pvedaemon.service - LSB: PVE Daemon
   Loaded: loaded (/etc/init.d/pvedaemon)
   Active: active (exited) since Mon 2018-02-12 14:21:57 CET; 27min ago
  Process: 9263 ExecStart=/etc/init.d/pvedaemon start (code=exited, status=0/SUCCESS)

Feb 12 14:21:57 virtual1 systemd[1]: Started LSB: PVE Daemon.
Feb 12 14:22:46 virtual1 systemd[1]: Started LSB: PVE Daemon.
Code:
● pveproxy.service - LSB: PVE API Proxy Server
   Loaded: loaded (/etc/init.d/pveproxy)
   Active: active (exited) since Mon 2018-02-12 12:51:00 CET; 1h 59min ago

Feb 12 12:51:00 virtual1 systemd[1]: Started LSB: PVE API Proxy Server.
Code:
systemctl status pve-manager
● pve-manager.service - LSB: PVE VM Manager
   Loaded: loaded (/etc/init.d/pve-manager)
   Active: active (exited) since Mon 2018-02-12 12:51:00 CET; 2h 0min ago

Feb 12 12:51:00 virtual1 systemd[1]: Started LSB: PVE VM Manager.

i found in the forims that it could be because of an apt upgrade , so i did a dist-upgrade and rebooted the server but i'm always having the same problem ,
another thing , when i do ps i can't find the processes of those services running
and when i check the ports running i can't see the 8006
(i can't run pveversion it told me that it doesn't exist)

anyone have an idea pelase ?

Thank you
 

udo

Well-Known Member
Apr 22, 2009
5,864
161
63
Ahrensburg; Germany
Hello Evrybody ,
i can not acces to my proxmox web interface ,
...
i found in the forims that it could be because of an apt upgrade , so i did a dist-upgrade and rebooted the server but i'm always having the same problem ,
another thing , when i do ps i can't find the processes of those services running
and when i check the ports running i can't see the 8006
(i can't run pveversion it told me that it doesn't exist)

anyone have an idea pelase ?

Thank you
Hi,
if pveversion don't exist, your installation is broken.

Please post the content of following commands:
Code:
dpkg -l | grep pve

 cat /etc/apt/sources.list.d/*.list

lsb_release -a
Udo
 

Tarek Damak

New Member
Dec 19, 2016
22
0
1
24
Thnk you udo for the answer , i'm using it from a while , something like one year so i suppose that it's not an install problem , may be an upgrade but not an install

so for the 1st command
Code:
ii  corosync-pve                   2.4.0-1                                 amd64        Standards-based cluster framework (daemon and modules)
ii  dmeventd                       2:1.02.93-pve3                          amd64        Linux Kernel Device Mapper event daemon
ii  dmsetup                        2:1.02.93-pve3                          amd64        Linux Kernel Device Mapper userspace library
ii  grub-common                    2.02-pve4                               amd64        GRand Unified Bootloader (common files)
ii  grub-efi-amd64-bin             2.02-pve4                               amd64        GRand Unified Bootloader, version 2 (EFI-AMD64 binaries)
ii  grub-efi-ia32-bin              2.02-pve4                               amd64        GRand Unified Bootloader, version 2 (EFI-IA32 binaries)
ii  grub-pc                        2.02-pve4                               amd64        GRand Unified Bootloader, version 2 (PC/BIOS version)
ii  grub-pc-bin                    2.02-pve4                               amd64        GRand Unified Bootloader, version 2 (PC/BIOS binaries)
ii  grub2-common                   2.02-pve4                               amd64        GRand Unified Bootloader (common files for version 2)
ii  libcorosync4-pve               2.4.0-1                                 amd64        Standards-based cluster framework (libraries)
ii  libdevmapper-event1.02.1:amd64 2:1.02.93-pve3                          amd64        Linux Kernel Device Mapper event support library
ii  libdevmapper1.02.1:amd64       2:1.02.93-pve3                          amd64        Linux Kernel Device Mapper userspace library
ii  liblvm2app2.2:amd64            2.02.116-pve3                           amd64        LVM2 application library
ii  liblvm2cmd2.02:amd64           2.02.116-pve3                           amd64        LVM2 command library
ii  libnvpair1                     0.6.5.7-pve10~bpo80                     amd64        Solaris name-value library for Linux
ii  libpve-access-control          4.0-19                                  amd64        Proxmox VE access control library
ii  libpve-common-perl             4.0-73                                  all          Proxmox VE base library
ii  libpve-storage-perl            4.0-61                                  all          Proxmox VE storage management library
ii  libuutil1                      0.6.5.7-pve10~bpo80                     amd64        Solaris userland utility library for Linux
ii  libzfs2                        0.6.5.7-pve10~bpo80                     amd64        Native ZFS filesystem library for Linux
ii  libzpool2                      0.6.5.7-pve10~bpo80                     amd64        Native ZFS pool library for Linux
ii  lvm2                           2.02.116-pve3                           amd64        Linux Logical Volume Manager
ii  lxc-pve                        2.0.4-1                                 amd64        Linux containers usersapce tools
ii  lxcfs                          2.0.3-pve1                              amd64        LXC userspace filesystem
ii  novnc-pve                      0.5-8                                   amd64        HTML5 VNC client
ii  pve-cluster                    4.0-46                                  amd64        Cluster Infrastructure for Proxmox Virtual Environment
ii  pve-container                  1.0-75                                  all          Proxmox VE Container management tool
ii  pve-docs                       4.3-1                                   all          Proxmox VE Documentation
ii  pve-firewall                   2.0-29                                  amd64        Proxmox VE Firewall
ii  pve-firmware                   1.1-9                                   all          Binary firmware code for the pve-kernel
ii  pve-ha-manager                 1.0-35                                  amd64        Proxmox VE HA Manager
ii  pve-kernel-4.4.19-1-pve        4.4.19-66                               amd64        The Proxmox PVE Kernel Image
ii  pve-libspice-server1           0.12.8-1                                amd64        SPICE remote display system server library
rc  pve-manager                    4.3-1                                   amd64        The Proxmox Virtual Environment
ii  pve-qemu-kvm                   2.6.1-6                                 amd64        Full virtualization on x86 hardware
ii  spl                            0.6.5.7-pve6~bpo80                      amd64        Solaris Porting Layer user-space utilities for Linux
ii  tar                            1.27.1+pve.3                            amd64        GNU version of the tar archiving utility
ii  zfs-initramfs                  0.6.5.7-pve10~bpo80                     amd64        Native ZFS root filesystem capabilities for Linux
ii  zfsutils                       0.6.5.7-pve10~bpo80                     amd64        command-line tools to manage ZFS filesystems
for the 2nd one :
Code:
deb https://enterprise.proxmox.com/debian jessie pve-enterprise
and for the 3rd he can not find it
Code:
-bash: lsb_release: command not found
and i wanna add for you the sources.list may be that will be useful
Code:
deb http://ftp.fr.debian.org/debian jessie main contrib

# security updates
deb http://security.debian.org jessie/updates main contrib

deb-src http://security.debian.org/ jessie/updates main contrib

###deb [arch=amd64,i386] http://releases.galeracluster.com/debian/ stretch main

deb http://security.debian.org/debian-security jessie/updates main
deb http://ftp.de.debian.org/debian jessie main

#Depot paquets proprietaires
deb http://ftp2.fr.debian.org/debian/ jessie main non-free
deb-src http://ftp2.fr.debian.org/debian/ jessie main non-free

#Depot Dotdeb
deb http://packages.dotdeb.org jessie all
deb-src http://packages.dotdeb.org jessie all

#Depot Multimedia
deb http://www.deb-multimedia.org jessie main non-free
Thank you again for your answer Udo .
 

udo

Well-Known Member
Apr 22, 2009
5,864
161
63
Ahrensburg; Germany
Thnk you udo for the answer , i'm using it from a while , something like one year so i suppose that it's not an install problem , may be an upgrade but not an install

so for the 1st command
Code:
ii  pve-kernel-4.4.19-1-pve        4.4.19-66                               amd64        The Proxmox PVE Kernel Image
rc  pve-manager                    4.3-1                                   amd64        The Proxmox Virtual Environment
for the 2nd one :
Code:
deb https://enterprise.proxmox.com/debian jessie pve-enterprise
Hi,
that pve-manager insn't installed is an problem.

Do you have an valid subscription?
If you do an "apt-get update", do you get some errors about enterprise.proxmox.com?

If you don't have an subscription, you must use the pve-no-subscription repo. In this case do this:
Code:
## disable pve-enterprise
sed -i 's/^deb/#deb/g' /etc/apt/sources.list.d/pve-enterprise.list

## create pve-no-subscription repo list
cat > /etc/apt/sources.list.d/pve-no-subscription.list << EOF
#
deb http://download.proxmox.com/debian/pve jessie pve-no-subscription
EOF

apt update
apt install pve-manager

apt dist-upgrade
Udo
 
  • Like
Reactions: Jbere

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!