Proxmox GUI and System Journal Errors after VM Disk Configuration Changes

slopez

New Member
Nov 10, 2023
1
0
1
Hello Proxmox Community,

I am in need of some assistance with a serious issue that arose after modifying disk configurations for a VM instance in Proxmox. Following these changes, I've lost access to both the Proxmox GUI and the TrueNAS VM. The TrueNAS VM was completely inaccessible (no TrueNAS GUI and does not startup) after shutting it (TureNAS VM instance) down and before losing the Proxmox GUI.

Problem Description:
After adding what I believe were incorrect hard disks to a TrueNAS VM intended for backing up our Active Directory, I lost access to the TrueNAS GUI. I decided to restart the VM to troubleshoot this. However, the following day, I discovered that the Proxmox GUI was also unavailable. The system logs are flooded with the following error:
Code:
Failed to write entry (24 items, 6345 bytes), ignoring: Read-only file system
It appears the filesystem has been remounted as read-only, which is preventing writes to the system journal and likely affecting the GUI's functionality.

Troubleshooting Steps Taken:
  • Confirmed SSH access is still possible and all VMs and containers are running.
  • Attempted to restart Proxmox services without success.
  • Checked for and ruled out network issues and firewall configurations.
  • Inspected disk space to ensure there is no shortage.
  • Considered running a filesystem check but have not yet done so due to concerns about data integrity.
Given these events, I suspect that the disk changes may have caused some system-wide issues, possibly affecting critical storage paths or system files, leading to the GUI becoming inaccessible.

Seeking Advice:
Could the disk configuration changes have caused Proxmox to lock the filesystem in a read-only state? If so, what steps can I take to safely resolve this and restore access to the GUIs without risking data loss?

I would greatly appreciate any insights or recommendations for further troubleshooting steps from anyone who may have experienced something similar or has expertise in this area.

Thank you for your time and assistance!
 

Attachments

  • Screenshot 2023-10-28 at 10.05.27 PM.png
    Screenshot 2023-10-28 at 10.05.27 PM.png
    96.2 KB · Views: 4
Probably the most common reason for the rootfs getting remounted read-only is caused by errors from the controller. Another possibility is if you were trying to pass-thru the disk and used the wrong one and that caused corruption.

Have you tried to remount it: mount -o remount,rw /? Have you tried to boot from a live CD and check it with fsck?
 
  • Like
Reactions: slopez
  • Like
Reactions: slopez

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!