Oct 18, 2022
I have tried everything under the sun to get this to work, from PSK configuration to API Token, etc..., but nothing works, and this is just trying to add the PVE host, not a VM. Please let me know if you need any further information. I would really like to get this working.

What exactly isn't working? Just installed Zabbix 6.0 LTS agent yesterday to a PVE 7.2 server without a problem. Only had problems using the "zabbix-agent2" package. Not with the old "zabbix-agent" package.
Last edited:
  • Like
Reactions: ClintonITWorks
It seems to have corrected itself over night. -_- Apparently, though no guides mentioned it that I saw, I had to add the linux server template in addition to any Proxmox/PVE templates.
It looks like it will connect now, however the proxmox templates that are linked in zabbix keep saying that the proxmox api is unreachable. Perhaps it is connecting via linux server template due to discovery being on, but the proxmox api is still not connecting? Every time I acknowledge the problem and close it, it immediately returns.
Last edited:
Not sure about the official template, but the one from @vashvampir needs a token with some high privileges. Try to grant your token admin privileges. And verify your macros, if they are correct.
Last edited:
This issue is still plaguing me, as I cannot get the Proxmox API to work with Zabbix. Any advice would be much appreciated.
Cannot find a way to mark this thread solved, as the edit thread button has disappeared.
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!