Proxmox 8 will not connect to network


New Member
Jul 4, 2023
Good morning everyone. I am completely new to Proxmox and have read dozens of threads and am still having issues. I installed Proxmox 8 on a new SSD in a mini-PC (MULTIPLE times) but I am not able to connect to the UI or even have my router recognize that the PC is connected to the network.

I have verified that the NIC is working properly as I have swapped out the PROXMOX SSD with another SSD that has Windows 11 installed; Windows 11 successfully connected to the network with no issues. I have set the DHCP settings in my router to have the NIC MAC set to a static IP, which worked fine with the Windows SSD.

I am including a pic of the ip address, ip r, ip a and cat /etc/network/interfaces commands from the proxmox pc directly. The 'enp2s0' is the hardwire NIC (MAC 68-1D...) I selected in the setup process, whereas the 'wlp3s0' is the onboard wireless, which was NOT selected in the setup process.
Thank you to anyone that can help with this!


  • IMG_1301a.jpg
    777.4 KB · Views: 18
Link is down: NO-CARRIER.... vmbr0 state DOWN....
enp2s0 interface, that is part of your bridge and where the IP address is assigned, shows "NO CARRIER" , meaning the NIC did not detect a live cable.
Was your windows box using wireless connection by chance? Is the cable actually plugged in?
Wireless NICs are not encouraged with PVE.

Blockbridge : Ultra low latency all-NVME shared storage for Proxmox -
  • Like
Reactions: itNGO
Thank you both. Yes, I can confirm that Windows used the NIC when it connected. Confirmed in both windows and the router with the NIC MAC connected. Even now, the NIC has flashing lights and I have changed the cable and the port on the router. I can even see the router port flashing, confirming that data is being transmitted through the port.
I had thought originally that the subnet was incorrect as my router has programmed, however it appears that the setup process did choose that subnet.
Did you install PVE 7.4 or 8.0? Maybe the Kernel does not like your NIC?
Last edited:
Did you install PVE 7.4 or 8.0? Maybe the Kernel does not like you NIC?
I installed the latest v8 of Proxmox. I tried to reinstall 7.4 after the first several failed attempts at v8, but it would not install so I kept v8. In fact, I reinstalled as recently as this morning EST.

As for the NIC not being recognized by the OS…that is a very interesting hypothesis. I will try the Ubuntu option and see what happens.
Well, the NIC not being compatible seems to be the issue. I attempted to install Ubuntu and the only option to connect to the internet was wireless, despite the NIC being hardwired. Thanks for the help! Back to square one


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!