[SOLVED] Problem in creating template and cloning with an LVM VG


Mar 25, 2020
I followed the instructions from this page to create a vm:

wget https://cloud-images.ubuntu.com/bionic/current/bionic-server-cloudimg-amd64.img
qm create 9000 --memory 2048 --net0 virtio,bridge=vmbr0
qm importdisk 9000 bionic-server-cloudimg-amd64.img vms
qm set 9000 --scsihw virtio-scsi-pci --scsi0 vms:vm-9000-disk-0
qm set 9000 --ide2 vms:cloudinit
qm set 9000 --boot c --bootdisk scsi0
qm set 9000 --serial0 socket --vga serial0
qm template 9000
qm clone 9000 123 --name ubuntu2

vms is my LVM VG.
when I use an LVM-thin VG, everything works fine and I'm able to create a linked clone.
But with an LVM VG, when I run "qm template 9000" line, it doesn't convert the volume (vm-9000-disk-0) to a base volume (like it did with LVM-thin).
therefore when I run the clone command, it throws the error:
Linked clone feature is not supported for drive 'scsi0'
and it's only possible create a full clone.

Is there anything I'm missing here?
Glad that works for you.
Please mark the thread as 'SOLVED' - that helps other users with similar questions.
  • Like
Reactions: foadk


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!