No ping from PVE host to router (Fritzbox)

cmonty14

Active Member
Mar 4, 2014
338
4
38
Hello,

I have configured bond+bridge+vlan on my PVE host.
The relevant network configuration (in /etc/network/interfaces) is this:
Code:
source /etc/network/interfaces.d/*

auto lo
iface lo inet loopback

iface eno1 inet manual
iface enp4s0f2 inet manual
iface enp4s0f3 inet manual

auto bond0
iface bond0 inet manual
        bond-slaves eno1 enp4s0f3
        bond-miimon 100
        bond-mode 802.3ad
        bond-xmit-hash-policy layer2+3
        mtu 9000
#bond0

auto vmbr0
iface vmbr0 inet static
        address 192.168.1.11/24
        gateway 192.168.1.1
        bridge-ports bond0
        bridge-stp off
        bridge-fd 0
        bridge-vlan-aware yes
        bridge-vids 10-14
        mtu 9000
        post-up ifconfig eno1 mtu 9000 && ifconfig enp4s0f3 mtu 9000
#Fritz!Box

auto vmbr1
iface vmbr1 inet static
        address 192.168.0.11/24
        bridge-ports enp4s0f2
        bridge-stp off
        bridge-fd 0
        bridge-vlan-aware yes
        bridge-vids 9
        mtu 1500
#Management

auto vmbr1.9
iface vmbr1.9 inet static
        address 192.168.20.11/24
        mtu 1500
#PVE Corosync

iface vmbr0.10 inet manual
#PVE Guest

iface vmbr0.11 inet manual
#VPN

iface vmbr0.12 inet manual
#DMZ

iface vmbr0.13 inet manual
#SmartHome

auto vmbr0.14
iface vmbr0.14 inet static
        address 192.168.30.11/24
        mtu 9000
#PVE Migration

I've configured 2 bridges vmbr0 and vmbr1 because there are 2 routers in my network with 2 ISPs.

When I try to ping the router 192.168.1.1 (Fritzbox), I get an error: Destination Host Unreachable

However I can ping another client in network 192.168.1.0/24 with no error.

My assumption is that a relevant VLAN setting in the managed switch is incorrect.
Can you please advice, which VLAN mode must be selected on the relevant port connected to PVE host:
Access
Trunk
Hybrid

Currently I'm using VLAN mode
Hybrid
Native VLAN 1
Hybrid Untagged VLAN 1
Hybrid Tagged VLAN 10,11,12,13,14
Ingress Checking Enabled
Acceptable Frame Type Admit All

I cannot reproduce the error with this config:
Code:
source /etc/network/interfaces.d/*

auto lo
iface lo inet loopback

iface eno1 inet manual
iface enp4s0f2 inet manual
iface enp4s0f3 inet manual

auto bond0
iface bond0 inet manual
        bond-slaves eno1 enp4s0f3
        bond-miimon 100
        bond-mode 802.3ad
        bond-xmit-hash-policy layer2+3
        mtu 9000
#bond0

auto vmbr0
iface vmbr0 inet static
        address 192.168.1.11/24
        gateway 192.168.1.1
        bridge-ports bond0
        bridge-stp off
        bridge-fd 0
        bridge-vlan-aware yes
        #bridge-vids 10-14
        mtu 9000
        post-up ifconfig eno1 mtu 9000 && ifconfig enp4s0f3 mtu 9000
#Fritz!Box

auto vmbr1
iface vmbr1 inet static
        address 192.168.0.11/24
        bridge-ports enp4s0f2
        bridge-stp off
        bridge-fd 0
        bridge-vlan-aware yes
        bridge-vids 9
        mtu 1500
#Management

auto vmbr1.9
iface vmbr1.9 inet static
        address 192.168.20.11/24
        mtu 1500
#PVE Corosync

This means after removing any VLAN from vmbr0 I can ping router 192.168.1.1 w/o problems.

Can you please advise how to fix this issue?

THX
 
Last edited:

ph0x

Renowned Member
Jul 5, 2020
1,326
212
68
/dev/null
If you don't need other VLANs on the cable: access mode

If you need other VLANs on the cable: trunk mode and probably allow the correct bridge vids.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!