No Network Adapter in fresh Windows Server after Upgrade to Proxmox 7

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,620
959
163
What else could be a source of this issue?
Please download the english version of 2016 server and try again, works for me:

Windows_Server_2016_Datacenter_EVAL_en-us_14393_refresh.ISO

Code:
Downloads# sha256sum Windows_Server_2016_Datacenter_EVAL_en-us_14393_refresh.ISO

1ce702a578a3cb1ac3d14873980838590f06d5b7101c5daaccbac9d73f1fb50f  Windows_Server_2016_Datacenter_EVAL_en-us_14393_refresh.ISO
 

christian.g

Member
Jun 4, 2020
49
23
13
I used the german version right now on both PVE 6.4-8 and 7.0-8.
(I renamed the ISO)

Code:
3f0ee2b611f4600b236f7b10dbac6ba9766c52fb99b3eb9cf51a65ec72b1fc6d  WIN2016_Server_Datacenter_Eval_X64_DE.ISO

Works fine on 6.4-8 but doesn't on 7.0-8
 
  • Like
Reactions: Borotes

christian.g

Member
Jun 4, 2020
49
23
13
No, i didn't.
Did you try the German one as that's the one people in this thread are using?
Maybe this will let you reproduce the issue.
 
  • Like
Reactions: Borotes

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
5,511
1,760
164
South Tyrol/Italy
shop.proxmox.com
That's the point, the German one shows issues while the English one does not, same Server 2016 version - so this seems like it's an issue from Windows with some specific localizations - so I'd rather check with Microsoft about what weird stuff they do to make it break just by using a different language version.
 

christian.g

Member
Jun 4, 2020
49
23
13
Two things here:

1. You confirm that there are issues with the German version.
2. If this is a Windows issue then the issue should show up on any PVE version. But it doesn't.

Btw: I agree, MS is doing a lot of wired stuff ;)
 
Last edited:
  • Like
Reactions: Borotes

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
5,511
1,760
164
South Tyrol/Italy
shop.proxmox.com
1. You confirm that there are issues with the German version.
yes

2. If this is a Windows issue then the issue should show up on any PVE version. But it doesn't.
Not necessarily, the bug in that specific version with that specific language can be tied to a side effect, but as all other Windows Versions and at least the English variant of the same version work I really can only blame MS. That said, if we can find any workaround (and we will look into it) that does not fail other, now working, configurations we'll naturally implement that - like we did already so often for the proprietary mess that OS family is.
 

christian.g

Member
Jun 4, 2020
49
23
13
If i could, i would run everything on Linux but sadly that's not possible. Mixing Windows Installations with different Languages in the same environment is a pain and will bite you hard in many ways. That's why i'm using a Clone of a working VM right now until this gets (hopefully) sorted.

I've tested the English version and yes, it works.
But i see a noticeable difference in the interface naming.

PVE 6.4-8: Ethernet
PVE 7.0-8: Ethernet Instance 0

Maybe a change in qemu causes an unexpected interface name which the German version of Windows 2016 is not able to handle.
 
  • Like
Reactions: Borotes

timonych

Active Member
Aug 8, 2017
61
14
28
32
Hi Everyone!

Also have a such problem with Windows 8.1. After upgrading to Proxmox 7 sometimes there is no netowkr adapter in VM. After 2-3 reboots Network Adapter appears in VM and I can connect via RDP to it.

I also tryed virtio drivers from virtio-win-0.1.196.iso and have changed machine from i440fx-5.2 to [6.0, 5.2, 5.1, 5.0] but problem has not gone. I have 3 VM with Windows 8.1 and this problem appears on each VM sometimes.

So, for me workaround is reboot VM until network interface will up correctly.

Before upgrading, there was no such problem with Proxmox 6.4.9
root@brabus:~# pveversion -v
proxmox-ve: 7.0-2 (running kernel: 5.11.22-2-pve)
pve-manager: 7.0-10 (running version: 7.0-10/d2f465d3)
pve-kernel-5.11: 7.0-5
pve-kernel-helper: 7.0-5
pve-kernel-5.11.22-2-pve: 5.11.22-3
ceph-fuse: 14.2.21-1
corosync: 3.1.2-pve2
criu: 3.15-1+pve-1
glusterfs-client: 9.2-1
ifupdown: residual config
ifupdown2: 3.1.0-1+pmx2
ksmtuned: 4.20150326
libjs-extjs: 7.0.0-1
libknet1: 1.21-pve1
libproxmox-acme-perl: 1.1.1
libproxmox-backup-qemu0: 1.2.0-1
libpve-access-control: 7.0-4
libpve-apiclient-perl: 3.2-1
libpve-common-perl: 7.0-5
libpve-guest-common-perl: 4.0-2
libpve-http-server-perl: 4.0-2
libpve-storage-perl: 7.0-9
libspice-server1: 0.14.3-2.1
lvm2: 2.03.11-2.1
lxc-pve: 4.0.9-2
lxcfs: 4.0.8-pve2
novnc-pve: 1.2.0-3
proxmox-backup-client: 2.0.4-1
proxmox-backup-file-restore: 2.0.4-1
proxmox-mini-journalreader: 1.2-1
proxmox-widget-toolkit: 3.3-4
pve-cluster: 7.0-3
pve-container: 4.0-8
pve-docs: 7.0-5
pve-edk2-firmware: 3.20200531-1
pve-firewall: 4.2-2
pve-firmware: 3.2-4
pve-ha-manager: 3.3-1
pve-i18n: 2.4-1
pve-qemu-kvm: 6.0.0-2
pve-xtermjs: 4.12.0-1
qemu-server: 7.0-10
smartmontools: 7.2-pve2
spiceterm: 3.2-2
vncterm: 1.7-1
 
Last edited:
  • Like
Reactions: Borotes

Deleted member 116138

Guest
I have the same problem on migrated/upgraded PVE systems and even on fresh installs of PVE 7, as described in the German forum here.

Until a fix it wouldn't be a problem to install the NetKVM driver later on within Windows but another big problem is that every virtual hardware is now detected as "ejectable" (Windows 10/Server 2016/2019):

virtiodriver.jpg

This affects existing and new installs of Windows 10/Server2016/2019. And it's a serious issue because it really ejects the hardware when clicked.

Edit: same effect on Windows 10 21H1 and Windows Server 2019 English version (eval) except for the working NetKVM driver during setup:

virtiodriver2.jpg

Edit 2: I slightly modified a batch script from this thread to disable the "safely remove hardware".

Code:
:: Disable eject hard disk
reg.exe add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\VEN_1AF4&DEV_1000&SUBSYS_00011AF4&REV_00\3&13c0b0c5&0&90" /v Capabilities /t REG_DWORD /d 2 /f

:: Disable eject ballon
reg.exe add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\VEN_1AF4&DEV_1001&SUBSYS_00021AF4&REV_00\3&13c0b0c5&0&58" /v Capabilities /t REG_DWORD /d 2 /f

:: Disable eject network card
reg.exe add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\VEN_1AF4&DEV_1002&SUBSYS_00051AF4&REV_00\3&13c0b0c5&0&18" /v Capabilities /t REG_DWORD /d 2 /f

:: Disable VirtIO Serial
reg.exe add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\VEN_1AF4&DEV_1003&SUBSYS_00031AF4&REV_00\3&13C0B0C5&0&40" /v Capabilities /t REG_DWORD /d 2 /f

:: Disable StandardSATA Controller
reg.exe add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\VEN_8086&DEV_2922&SUBSYS_11001AF4&REV_02\3&13C0B0C5&0&38" /v Capabilities /t REG_DWORD /d 2 /f

:: Disable VirtIO SCSI pass-through
reg.exe add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\VEN_1AF4&DEV_1004&SUBSYS_00081AF4&REV_00\3&13C0B0C5&0&28" /v Capabilities /t REG_DWORD /d 2 /f
 
Last edited by a moderator:
  • Like
Reactions: Borotes

Deleted member 116138

Guest
Also have a such problem with Windows 8.1
A quick workaround for me on Server 2012R2 (same base as for Windows 8.1) was to delete the "old" NIC including the option to delete existing drivers, then force a re-detection of changed hardware within the device manager and choose the mounted guest tools iso as search source.
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,620
959
163
The issues disappear when using the q35 hardware model. Everything is working fine now.
Yes, I can also confirm that using the Q35 machine type fixes the issue.

Here is my VM config (German Windows 2016 Server)

Code:
root@host:~# qm config 101

agent: 1
boot: order=scsi0;net0
cores: 6
cpu: host
ide0: iso-templates:iso/virtio-win-0.1.196.iso,media=cdrom,size=486642K
ide2: iso-templates:iso/14393.0.161119-1705.RS1_REFRESH_SERVER_EVAL_X64FRE_DE-DE.ISO,media=cdrom,size=6867666K
machine: pc-q35-6.0
memory: 4096
name: win2016-de
net0: virtio=BE:B5:57:4C:B1:77,bridge=vmbr0,firewall=1
numa: 0
ostype: win10
parent: vor_q35
scsi0: sam970evo:101/vm-101-disk-0.qcow2,cache=writeback,discard=on,size=64G,ssd=1
scsihw: virtio-scsi-pci
smbios1: uuid=d7cc0b67-e6dc-4734-83fb-a80cfb901e58
sockets: 1
vmgenid: aa03c7fb-2fb0-4d1b-8e83-e5a3ebc92b92
 
  • Like
Reactions: fel0xleo

weirdwiesel

New Member
Jul 20, 2021
1
3
3
42
+1 from my side.

I have the same pve version as posted above plus Windows Server 2016 standard german.
One existing Maschine worked till i switched the net-Interface from E1000 to Virtio. Strangely I can get an IP-Adress/Network Connection when I use DHCP, but when I set a static IP-Adress, connection is gone. When I use E1000 both (DHCP and fixed IP-Adress) is working fine.

I just reactivated an old proxmox Server (QCOW2) Image and had the same experience. No Network-Adapters are showing up on i440fx-5.2 an i440fx-6.0. I was struggeling and sweating for two days till I found this thread.

THANKS A LOT FOR ALL YOUR HELP! The Idea with q35 saved me :)
I hope I can switch back to normal i440fx-6.0, when this issue is fixed.
 

Borotes

New Member
Apr 8, 2021
15
0
1
25
I have the same problem on proxmox 7. I just reinstalled two nodes, one with proxmox 7 and one with 6.

On 6, my machine has a network card and on 7 it does not. I have no VLANs, and changed nothing from the basic install. I tried different virtio versions, but the result is always the same.

The thing I have in common is the german Windows Server 2016 ISO. The Datacenter, Standard and Evaluation ISO are all not showing a network card on proxmox 7 and the install of the netkvm drivers is failing.
 

fel0xleo

New Member
Mar 3, 2021
1
0
1
32
Thanks for the solution. Changing the default machine version from i440fx to g35 works fine.
 

manwe

New Member
Aug 20, 2021
2
0
1
44
New fresh Proxmox 6.4 cluster. Windows machines no network. I've began changing the machine type, boot and reconfigure the network (the existing one is gone after changing the hardware type) and starts working.
Some days ago I managed to make one work without this change but I don't remember what I did :(
 

C64Axel

New Member
Aug 20, 2021
2
0
1
Germany
Hi. Thanks for the Tip, changing from i440fx to g35 works also on Win10 21H1 german edition.
vmbr0 is working fine but if i change the Adapter to vmbr1, the network card is not working any more.
 
Last edited:

Deleted member 116138

Guest
vmbr0 is working fine but if i change the Adapter to vmbr1, the network card is not working any more.

Did you try to remove the NIC within the VM‘s device manager and let Windows redetect it („nach geänderter Hardware suchen“ in German)?
 

C64Axel

New Member
Aug 20, 2021
2
0
1
Germany
Yes i did. Trying every network device in Proxmox (Intel/Realtek). And deleteing the old Adapter in the device manager. Always the same result, a "yellow triangle with exclamation mark".
Hardware is a Dell PowerEdge 720 using the integrated Broadcom network adapter.

But: i'm just cloning the VM for getting the error message from the adapter, change the machine back to i440fx and all is working fine.
No yellow triangle.
Deleting the adapter and redetect: no triangel
Deleting the adapter with driver, redetect and installing driver from CD: no triangle
So everything is working now with i440fx :oops:
This is crazy.

PS: My Proxmox version is 7.0-11
 
Last edited:

floh8

Active Member
Jul 27, 2021
300
35
28
i would like to give an advice about microsoft server versions i got in the past from an it consultant. you should always use the odd version of ms win server, because they are more stable and more bug free. that means u use not win server 2012 and not version 2016 or the current version 2021 but u should use ms windows server 2012 R2 or version 2019 etc.
proxmox can not clear the existing bugs in windows server or qemu.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!