NFS and Samba share to windows VM timeout/errors (mount works)

lejonpart

New Member
Dec 12, 2019
1
0
1
46
Hi

I’m on latest Proxmox (installed 6.0 and then upgraded) and my filesystem is ZFS. I run several bridge networks, my VMs are spread over several vlans.

NFS:
I'm trying to copy (to/from) files on my mounted NFS share in my VM Windows 10 but it fails with timeout errors after initial start. If I right click on a file and select properties it can take between 30-60 sec before it shows up. If I move the VM to same lan as proxmox the problem persists.
I did a packetdump that shows that after a short while the connection gets RST for some reason (then it keeps trying). There is never an NFS write command issued. When the copy finally fails windows wonder if the share is still connected to the host.
If I mount the same share in non VM (both Windows and Linux) it works perfect.
If I mount my NFS share from my Synology in the VM Windows 10, that share works normally.
All ports are open, and there is no errors in the windows log or in the kernel.log (even with debug turned on)

Samba:
I can access the share and see all files but if I transfer a file I get “0x8007003B An unexpected network error occurred” and it fails.
If I mount the same share in non VM (both Windows and Linux) it works perfect.

I have tried on a fresh new install (different source) of Windows 10 pro but same issue. Where should I look next? Am I the only one having this issue (on fresh install)?

Regards
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!