Mounting Samba Share for Plex Container

plexquestion

New Member
Nov 16, 2023
2
0
1
Trying to mount an SSD attached to my router to Proxmox to use as a Plex directory. There is already a bunch of media on the drive which was used on an Nvidia Shield acting as the media server up until now since I have a Proxmox machine which can be the server. I have an Asus AX86U router with AsusWRT-Merlin on it.

When I run
pvesm scan cifs 192.168.1.1 --username=username --password=password

I get
Shared Sandisk

Which doesn't really make sense to me because the SSD hierarchy (see pic) is Sandisk Extreme 55AE -> Shared, so I don't know why both Sandisk and Shared are shown at the top level. Regardless, I have been trying every which way to mount the drive and everything ends up with
mount error(22): Invalid argument Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I've installed cifs-utils, used mkdirto make /media/plex as a mounting point for the drive, and from there I've used both mount, pvesm add, and fstab to try and get the drive mounted with no success. I've also changed the password (and used guest mode) to make sure that a typo in the credentials wasn't the issue.
For reference, this is what I tried (so you can hopefully see where I went wrong)
mount -t cifs //192.168.1.1/Shared /media/plex -o username=username,password=password,vers=1.0

Using pvesm add:
pvesm add cifs PlexStorage --server 192.168.1.1 --share Shared --username=username --password=password --path /media/plex

And in /etc/fstab (reloading the daemon after any changes):
//192.168.1.1/Shared /media/plex cifs -o username=username,password=password,vers=1.0,iocharset=utf8,rw

All of these return mount error(22): Invalid argument, and when I use dmesg it just repeats the same 22 error. One time it had an invalid credentials error, but I fixed that by removing a special character from my password. I have also tried replacing //192.168.1.1/Shared with //192.168.1.1/Sandisk with no luck.
 

Attachments

  • IMG_2504.jpg
    IMG_2504.jpg
    151.1 KB · Views: 8
  • IMG_2505.jpg
    IMG_2505.jpg
    331.9 KB · Views: 8
Don't use SMB version 1. It's super vulnerable and blocked by most modern OSs because of the security risks.

mount -t cifs //192.168.1.1/Shared /media/plex -o username=username,password=password,vers=1.0
You have to follow the order of the arguments according to the manual:
https://man7.org/linux/man-pages/man8/mount.8.html said:
mount [-fnrsvw] [-t fstype] [-o options] device mountpoint
So try it with: mount -t cifs -o username=username,password=password //192.168.1.1/Shared /media/plex
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!