Keepalived LXC Debian 9 vs >=10 (IP no ping)


New Member
Oct 25, 2022
Hello, we have two LXC containers acting as load balancers which share a public IP using keepalived. This public IP is moved from one LXC container to the other using eth1 which is on VLAN 77. At this point we encountered a strange issue when we upgraded this Debian 9 LXC containers to 10 or 11, basically the public IP is not pingable anymore when we are on Debian 10 or 11, on Debian 9 everything is fine.

We tried to downgrade keepalived from 2.x to 1.x (as it is on Debian 9) and the issue still persists on Debian 10 and 11. Also if we manually add the IP address via ip addr add ... the IP is not pingable. We suspect that the problem must be something related to OS version, not Kernel or similar (as far as this comes from Proxmox itself).

When we add another interface with another public IP to the LXC container via Proxmox everything works fine so probably Proxmox does something under the hood to make it work.

Thanks in advance for any suggestions on this.
Last edited:

Glad that you fix your issue yourself! And thank you for sharing your workaround.

I wanna ask you; what will happen if you disable the second network interface (that you added recently) in the LXC?

Can you maybe post the container config pct config <CTID>?

Have you tried to see the syslog during the LXC booting using lxc-start -n CTID -F -l DEBUG -o /tmp/lxc-CTID.log?


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!