[SOLVED] Is is possible to specify the NIC used for storage replication?

jsalas424

Member
Jul 5, 2020
124
1
18
32
I have a 3 node cluster running PVE 7.1-10. I am successfully replicating a pfsense VM between two nodes in my cluster, but it's going over my LAN NIC instead of my dedicated cluster network. Is there a way I can specify the NIC for replication?

Even better, can I specify a primary and fallback network?
 

Fabian_E

Proxmox Staff Member
Staff member
Aug 1, 2019
1,746
308
88
Hi,
I think you can use the migration setting in your /etc/pve/datacenter.cfg (see man 5 datacenter.cfg for details). The network given there should also be used for replication.
 

jsalas424

Member
Jul 5, 2020
124
1
18
32
Hi,
I think you can use the migration setting in your /etc/pve/datacenter.cfg (see man 5 datacenter.cfg for details). The network given there should also be used for replication.
I'm struggling with the syntax :( would you mind taking a look?

This is what the man says:

Code:
FILE FORMAT
       The file uses a simple colon separated key/value format. Each line has the following format:

           OPTION: value

       Blank lines in the file are ignored, and lines starting with a # character are treated as comments and are
       also ignored.

..................................................................................................

migration: [type=]<secure|insecure> [,network=<CIDR>]
           For cluster wide migration settings.

           network=<CIDR>
               CIDR of the (sub) network that is used for migration.

           type=<insecure | secure> (default = secure)
               Migration traffic is encrypted using an SSH tunnel by default. On secure, completely private
               networks this can be disabled to increase performance.

What I have:
Code:
# cat /etc/pve/datacenter.cfg
keyboard: en-us
migration: type=insecure ,network=10.0.0.0/24

Error code:
Code:
()
parse error in '/etc/pve/datacenter.cfg' - 'migration': invalid format - format error
migration.type: value 'insecure ' does not have a value in the enumeration 'secure, insecure'
 
Last edited:
Oct 29, 2018
37
6
13
19
Code:
migration: insecure,network=172.17.93.0/24

copy pasted from mine....

I'd remove the "type=" and maybe the space around the ,
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!