[SOLVED] Intel NUC with multiple NICs keep dropping network.


Apr 28, 2021
Hi Guys
This is my very first post and having had a 5 day workout with proxmox I have found a problem mentioned all over and that is the network that does not become active on a Windows 10 VM. I tried everything to get it to work, but wait, let me first tell you what I am running:
  1. Intel NUC GEN 8 i5, 12GB memory, 128GB SDD.
  2. 2 x "USB to Ether" 1Gb LAN devices.
Everything works 100% until I create a bond and combine all 3 NICs together. I then get only the very first VM to come up nicely, but the rest, not so much. I am running a very "light-weigh" Linux Desktop, called Q4OS and Windows 10 debloated. The moment I create a bond using "MODE: balance-rr" and reboot the server (I love using this small device as a server!) I start loosing connectivity. Well, after about 5 days of going back and forth (I did not mention I have a 2nd NUC exactly the same spec) I finally found the problem is due to the switch connected, a DGS-1210-20 from DLink, having LACP enabled, to be the culprit.

Changing the MODE from balance-rr to LACP gave me no more problems.

I hope I am helping someone who is having the same kind of problems.
kind regards
cyber7 (aka Aubrey, Cape Town, South Africa)
Great that you found that out, but it's not only your D-Link switch that needs to be configured to support a balance-rr trunk.
It's more like every switch ... ;)
  • Like
Reactions: cyber7


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!