Install Windows 2016 Server on Proxmox VE (Video tutorial)

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
13,688
435
83
Check if your installation ISO (windows) is ok.

e.g. check the md5sum of the iso
 

eddie

New Member
Jun 21, 2017
11
0
1
38
I've tried today to install Window Server 2016 on the new PVE 5 (fresh install) and got stuck with disk drivers. I've tried virtio and scsi for the disk and the drivers version 0.1.126 und 0.1.139 (/vioscsi/2k16/amd64). Window tells me that there are no drivers found ...

How to get this rolling ?
You need re-download and check with MD5 or SHA. this is caused download incomplete.
 

Amilcar Lélis

New Member
Sep 29, 2017
4
0
1
28
Hi guys! I´m having a problem with proxmox NOVNC, the main node´s NOVNC(pve) works fine the lxc too, but the VMs´s does not, neither in firefox, chrome nor safari. Please help, do I have to ativate something? how can I proced
 

wolfgang

Proxmox Staff Member
Staff member
Oct 1, 2014
4,966
331
83
This is not related to this thread please open a new thread.
 

rodrigerzz

New Member
Oct 24, 2017
1
0
1
32
Hi guys! I've problem with installing windows 2016 on proxmox 5, proxmox installed on Sata SSD disk, I mount another nvmeSSD disk to directory, create new VM with scsi HDD on that nvme SSD disk, such in tutorial video, and when I load drivers for virtioscsi, installer found my disk, but I couldn't press next, i have error: "windows cannot be installed on this disk. Couldn't find boot disk on this bios-based computer". I don't know what to do, if create sata vm disk, installation finished good. Can somebody help me?

Big tanks.

Update 25.10: Install newer Proxmox 5.1 and update debian to 9.2. Windows 2016 Install run good, no errors. I don't know where was the problem.
 
Last edited:

edward jung

New Member
Nov 1, 2017
1
0
1
34
Dear proxmox staff:
I've tried to build pve5.0 at experimental place, which is my home,
however, no matter how i tried, by using proxmox default zfs raid0 or raid1 installation,
after the pve installed, everything looked right,
until i tried to create win2012r2 or 2016 vm,
the vm installation idled or stop at installing windows system files about 8-10% progress,
then pve just shut the vm down,

this problem didn't show when i just install pve on ext4 format,
my testing environment is on ASUS BM5675/MD500 PC with two 500GB disks, 16 GB DDR3 ram

thanks for your reply
 

wolfgang

Proxmox Staff Member
Staff member
Oct 1, 2014
4,966
331
83
Hi @edward jung,
I think you have problems with your memory.
ZFS required ECC memory.
Generell I can tell you any Windows run fine on ZFS.
If you want to discuss in detail please open a new thread.
 

jayg30

New Member
Nov 8, 2017
15
1
3
33
Tried to install SPICE in Windows Server 2016 Standard (https://pve.proxmox.com/wiki/SPICE) and it tells me it's an unsupported Windows version. I looked around and it seemed like this was patched in the latest release. My 2016 server is fully patched but it the guest tools just won't finish installing. Anyone have success with this?

EDIT: well I was able to get it working by installing the qxl driver and vdagent manually and then restarting. Works great, so much better.
 
Last edited:

ChuckNoxis

New Member
Dec 23, 2017
3
0
1
127.0.0.1
Hi guys, I followed this tutorial but I'm not able to get the Network working on Win10 1703 (I know this is a tutorial on Windows server 2k16 but it should be pretty similar install process no ?).
I always got an "Unidentified Network / No Internet" with the bridge on vmbr0 with virtio 0.1.141 drivers. I have made a thread here if someone knows what's I'm doing wrong ^^.
 

Alwin

Proxmox Staff Member
Staff member
Aug 1, 2017
2,816
247
63
@ChuckNoxis, please do not hijack other threads. You will get help on your thread.
 

vikozo

Member
May 4, 2014
280
2
18
suisse
www.wombat.ch
i have big Problems downloading virtio-win-0.1.141.iso
file it stops after 50MB

another question, i installed win7 and win10 and it seems to work without this virtio - could this be a problem.

have a nice day
vinc
 

alaintno

New Member
Aug 13, 2014
6
0
1
Hello guys,

I saw in the video that you are using SCSI drives. Do you guys recommend SCSI Virtio over Virtio block devices ?

Thanks
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
13,688
435
83
Hello guys,

I saw in the video that you are using SCSI drives. Do you guys recommend SCSI Virtio over Virtio block devices ?

Thanks
yes.
 

Thomas15

New Member
Oct 3, 2016
5
0
1
25
Hello,

I came to this video because I have problems with ballooning on Windows Server 2016. Unfortunately the ballooning doesn´t work for me. I installed the ballooning driver, in device manager it is shown as ok. Also I installed the service with Administrator user trough cmd and the service definetly runs fine. Though the ballooning doesn´t work, all RAM is taken by Windows. Do you have any idea what I probably missed or is there any issue currently? Of course I also set static RAM with ballooning tick in Proxmox.

Greetings,
Thomas
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
1,500
213
63
South Tyrol/Italy
Of course I also set static RAM with ballooning tick in Proxmox.
Actually you need to use "Automatic Memory Allocation" for this sort of ballooning, see:
https://pve.proxmox.com/pve-docs/chapter-qm.html#qm_memory
It's a bit confusing, I know, but the ballooning checkbox is actually for correct memory accounting in the fixed memory range case.
In the variable case it does both, accurate accounting and setting the memory target.
(the device makes sometimes problems for certain windows versions, thus it can also be disabled for the fixed memory case).
 

Thomas15

New Member
Oct 3, 2016
5
0
1
25
Hello,

Thank you for your reply. I saw my mistake, the RAM usage on the host does not change, but on the VM Proxmox will see how much RAM Windows actually consumes. So let´s say I start Windows with 28GB + ballooning on a 32GB host, the nodes OS will say 28GB is populated and 4GB is free, although Windows might use only 2GB currently. Will I be able to start another VM with lets say 8GB of RAM of will KVM be on strike because it can not allocate 8GB at startup?

Further when I choose Automatic Memory Allocation can Proxmox still reduce the RAM of the Windows guest without knowing from the ballooning device how much RAM is really used and which part can be taken away from the VM?

Greetings,
Thomas
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!