IGD Passthrough doesn't work after upgrade

coyote

New Member
Dec 4, 2018
29
0
1
36
Done. :rolleyes:

But not working:

Code:
kvm: -device cirrus-vga,id=vga,bus=pci.0,addr=0x2: PCI: slot 2 function 0 not available for cirrus-vga, in use by vfio-pci

TASK ERROR: start failed: command '/usr/bin/kvm -id 106 -name MintVM -chardev 'socket,id=qmp,path=/var/run/qemu-server/106.qmp,server,nowait' -mon 'chardev=qmp,mode=control' -pidfile /var/run/qemu-server/106.pid -daemonize -smbios 'type=1,uuid=c72b67eb-f1c9-4b0f-931c-4adcb061f734' -smp '4,sockets=1,cores=4,maxcpus=4' -nodefaults -boot 'menu=on,strict=on,reboot-timeout=1000,splash=/usr/share/qemu-server/bootsplash.jpg' -vnc unix:/var/run/qemu-server/106.vnc,x509,password -cpu kvm64,+lahf_lm,+sep,enforce -m 2048 -device 'vfio-pci,host=00:02.0,addr=0x02,x-vga=on,x-igd-opregion=on' -device 'pci-bridge,id=pci.1,chassis_nr=1,bus=pci.0,addr=0x1e' -device 'piix3-usb-uhci,id=uhci,bus=pci.0,addr=0x1.0x2' -readconfig /usr/share/qemu-server/pve-usb.cfg -device 'usb-tablet,id=tablet,bus=uhci.0,port=1' -device 'usb-host,hostbus=1,hostport=2.3,id=usb0' -device 'cirrus-vga,id=vga,bus=pci.0,addr=0x2' -chardev 'socket,path=/var/run/qemu-server/106.qga,server,nowait,id=qga0' -device 'virtio-serial,id=qga0,bus=pci.0,addr=0x8' -device 'virtserialport,chardev=qga0,name=org.qemu.guest_agent.0' -device 'virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3' -iscsi 'initiator-name=iqn.1993-08.org.debian:01:1bddd032e383' -drive 'file=/mnt/pve/QNAP/template/iso/linuxmint-19-cinnamon-64bit-v2.iso,if=none,id=drive-ide2,media=cdrom,aio=threads' -device 'ide-cd,bus=ide.1,unit=0,drive=drive-ide2,id=ide2,bootindex=200' -device 'virtio-scsi-pci,id=scsihw0,bus=pci.0,addr=0x5' -drive 'file=/mnt/pve/QNAP/images/106/vm-106-disk-0.qcow2,if=none,id=drive-scsi0,format=qcow2,cache=none,aio=native,detect-zeroes=on' -device 'scsi-hd,bus=scsihw0.0,channel=0,scsi-id=0,lun=0,drive=drive-scsi0,id=scsi0,bootindex=100' -netdev 'type=tap,id=net0,ifname=tap106i0,script=/var/lib/qemu-server/pve-bridge,downscript=/var/lib/qemu-server/pve-bridgedown,vhost=on' -device 'virtio-net-pci,mac=D6:82:B6:5B:81:2A,netdev=net0,bus=pci.0,addr=0x12,id=net0,bootindex=300,romfile=pxe-virtio.rom' -machine 'type=pc-i440fx-2.2'' failed: exit code 1
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
3,798
345
83
31
Vienna
then you copied the wrong output, because there was no 'cirrus' device...
 

coyote

New Member
Dec 4, 2018
29
0
1
36
Take a look, something i'm doing wrong:
output.PNG

Insert and press enter. That's the screenshot.

After pressing enter -> "Ctrl + C" and "qm start 106" ?.


Thanks for your patience:)
 
Last edited:

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
3,798
345
83
31
Vienna
no pressing enter should already start the vm
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
3,798
345
83
31
Vienna
oh i see it now, you missed the closing quote in the vfio-pci line
 

coyote

New Member
Dec 4, 2018
29
0
1
36
Oh, your right. Now it starts.

I'm not at home to check if the display is working, but i think it's not.
Teamviewer is not showing up VM, so i think VM starts without error in proxmox, but Mint doesn't boot correctly.
I don't think the Display is working :(


Why does this config works fine before....
Code:
agent: 1
args: -device vfio-pci,host=00:02.0,addr=0x02
bootdisk: scsi0
cores: 4
ide2: QNAP:iso/linuxmint-19-cinnamon-64bit-v2.iso,media=cdrom
machine: pc-i440fx-2.2
memory: 2048
name: test
net0: virtio=7A:27:43:CC:06:1F,bridge=vmbr0
numa: 0
ostype: l26
scsi0: QNAP:104/vm-104-disk-0.qcow2,size=15G
scsihw: virtio-scsi-pci
smbios1: uuid=2a330518-b5bd-47e9-b0b8-3c24ad43353b
sockets: 1
usb0: host=1-2.3
vga: none
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
3,798
345
83
31
Vienna
could you try a different machine type than 'pc-i440fx-2.2' ? eg. pc-i440fx-2.12
 

coyote

New Member
Dec 4, 2018
29
0
1
36
Tried "pc-i440fx-2.12", unfortunately same. No Signal on HDMI Display.
 

coyote

New Member
Dec 4, 2018
29
0
1
36
And now?

Maybe you can tell me how can i rollback to an older proxmox version, so i can test if it works. Display is for my Home Automation and it's not cool if i had a black display in the flat:(
 

coyote

New Member
Dec 4, 2018
29
0
1
36
New test yesterday evening. Started from the scratch with a new Mint VM.

This is the config:

Code:
agent: 1
bootdisk: scsi0
cores: 2
hostpci0: 00:02.0,romfile=undefined,rombar=0
ide2: QNAP:iso/linuxmint-19-cinnamon-64bit-v2.iso,media=cdrom
machine: pc-i440fx-2.12
memory: 1024
name: test
net0: virtio=BE:29:73:2E:B8:5C,bridge=vmbr0
numa: 0
ostype: l26
scsi0: QNAP:104/vm-104-disk-0.qcow2,size=32G
scsihw: virtio-scsi-pci
smbios1: uuid=cc029143-7ef1-4d66-8628-25923575cec6
sockets: 1
vmgenid: 0840d4b8-0335-43f2-b001-b230263d4413
VM boots up, i see the Mint bootlogo on my HDMI Display for a few Seconds and the i get the green Stripes

8575-6927040bd8a14401068472aa7ca47e2c.jpg

On noVNC Console Mint starts fine and i see the Desktop.
Same on Debian Desktop VM
Any idea?
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
3,798
345
83
31
Vienna
New test yesterday evening. Started from the scratch with a new Mint VM.

This is the config:
this cannot work, please remove the 'romfile=undefined' from your config (except you put a romfile in /usr/share/kvm/undefined )
also you should add 'x-vga=on' so that the qemu gpu gets deactivated and the intel will be the primary

what you can do further is to boot an older kernel and see if it fixes that, or upgrade your bios/firmware of the nuc
 

coyote

New Member
Dec 4, 2018
29
0
1
36
also you should add 'x-vga=on' so that the qemu gpu gets deactivated
this was just for test. I have primary GPU activated in GUI, but same result.

ok, i will check if i can Update Bios/Firmware on the NUC.

what you can do further is to boot an older kernel
How can i do that?
 

coyote

New Member
Dec 4, 2018
29
0
1
36
during boot, there should be a list of installed kernels in grub, just select one with the keyboard and press enter
Your idea is good, but i can't choose a kernel during boot, because (if x-vga=on enabled) i don't see anything on the Display :confused:

If it's disabled (just to look, which Kernel i can choose), i can choose between 4.15.0-30 and 4.15.0-20
Think, i only can try to upgrade Bios. Don't no why Bootlogo is showing and after that, i have a green screen :(
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
3,798
345
83
31
Vienna
Your idea is good, but i can't choose a kernel during boot, because (if x-vga=on enabled) i don't see anything on the Display :confused:
no i meant the pve kernel on the host (so maybe it could be a driver bug/issue)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!