GPU Passthrough not working

La Matchata

Nov 24, 2020
Hi everyone!

I recently install Macos Monterey on Proxmox 7, everything is fine, i can install it without problem.
I use OpenCore and setup OVMF as Bios. The problem is, when i try to passing my GPU to MacOS, i've got a blank screens, nothing happen... But VM start properly ( i guess cause it dosen't crash... )

My GPU is not UEFI compatible, so i use GOP to add EFI to it. When i use rom-parser here's the output:

Valid ROM signature found @400h, PCIR offset 190h
PCIR: type 0 (x86 PC-AT), vendor: 10de, device: 1180, class: 030000
PCIR: revision 0, vendor revision: 1
Valid ROM signature found @10000h, PCIR offset 1ch
PCIR: type 3 (EFI), vendor: 10de, device: 1180, class: 030000
PCIR: revision 3, vendor revision: 0
EFI: Signature Valid, Subsystem: Boot, Machine: X64
Last image

So from here i'm stuck, i don't know what i can do to pass this GPU..

Here's my configuration:

Supermicro X8DAH+
Intel Xeon X5687
Gainward Phantom GTX 680 4GB

VM configuration:

agent: 1
args: -device isa-applesmc,osk="ourhardworkbythesewordsguardedpleasedontsteal(c)AppleComputerInc" -smbios type=2 -device usb-kbd,bus=ehci.0,port=2 -global nec-usb-xhci.msi=off -global ICH9-LPC.acpi-pci-hotplug-with-bridge-support=off -cpu host,kvm=on,vendor=GenuineIntel,+kvm_pv_u>
balloon: 0
bios: ovmf
boot: order=virtio0;net0
cores: 4
cpu: Penryn
efidisk0: local-lvm:vm-100-disk-0,efitype=4m,size=4M
hostpci0: 0000:02:00.0,romfile=test_updGOP.rom,x-vga=1
hostpci1: 0000:02:00.1,romfile=test_updGOP.rom,x-vga=1
machine: q35
memory: 12288
meta: creation-qemu=6.1.0,ctime=1642593235
name: Monterey
net0: virtio=76:06:1B:9D:CC:6A,bridge=vmbr0,firewall=1
numa: 0
ostype: other
scsihw: virtio-scsi-pci
smbios1: uuid=36587f9c-05e0-439a-aec7-6a1322681d85
sockets: 1
usb0: host=145f:022a,usb3=1
vga: none
virtio0: ssd:100/vm-100-disk-0.raw,cache=unsafe,discard=on,size=111G
vmgenid: ec342adb-9d37-453e-9a93-074b24145283

( i tried with and without HDMI audio controller, rom file, Pcie, etc )

Maybe i do something wrong with vfio or with the VM configuration ... I'm really new to Proxmox/Linux and virtualization...

I hope my thread is understandable, cause i'm not really good in english !

Thanks you for taking the time to read this!
Hi! Thanks for your answer! I'll never search in that way, it help me a lot !!!
So, i install a fresh Big Sur VM but the way that my GPU passthrough works is kinda weird ..
After installing Big Sur i tried to passthrough my GPU as i normaly do with the romfile that support UEFI. It didn't work,
To verify if GPU passthrough works on this VM i boot an Linux Live CD and it works !
Finaly i wanted to check if my GPU was detected by Macos so i set my display adapter to "Virtio-GPU" and boom! my GPU works !!
But... There's just a problem.. Macos see 2 Display .... One is my monitor and the other is the Virtio-GPU ( and i can't accès it, in the console view it stuck on Apple Logo and progression bar .. )
So again, i'm stuck here..... I didn't found anything that helped me....
If you don't want a second virtual display, set Display to none (vga: none) or enable Primary GPU ,x-vga=1). But maybe you have already tried this?

Note that you should not use
hostpci0: 0000:02:00.0,romfile=test_updGOP.rom,x-vga=1 hostpci1: 0000:02:00.1,romfile=test_updGOP.rom,x-vga=1
instead use one line
hostpci0: 0000:02:00,romfile=test_updGOP.rom,x-vga=1
(without the .0 and the .1 it will passthrough all functions of the device).
Hi, i have also gtx 680 with none eufi bios and would like to know how to add gpu passthrough to get fully graphic support in monterey or older os x versions ?
I have been searching forums to virtualize my MacOS server. Having GPU passthrough working is a must. However, I wanted to comment here to possibly provide some help. I have not tired yet personally with proxmox, but have been successful with ESXi The point of the reply is that simply Nvidia Kepler cards will not work with anything newer than Big Sur. The VM is still limited to the OS versions of kexts and libraries. I guess I'm not saying its impossible, after all OCLP allows for running Monterey and now Ventura on Kepler based "real" Macs. However, pointing to that direction may help lead you into making this near impossible task happen. I have not come across anything else for a bare metal MacOS install or a VM install that allows for Kepler based cards to be used on newer versions of MacOS on non-apple hardware. Using what is already available from OCLP may be your best hope. I'm not one to comment on anyone's financial situation or sentimental value, but selling the Kepler card, and purchasing an r9 270x, or r9 285 (on the lower end) would definitely cause less headache for the newer MacOS versions. As I play around with proxmox and virtualizing my server, if I come across anything, I will add to the forum. On the note of VMware ESXi, as it allows for natively supporting MacOS with out Clover or OpenCore, it lacks the ability to inject a fake ID to allow my WX4100 or W5100 to look like a supported card.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!