Error upgrading pve 6 to 7

Armando Ramos Roche

Well-Known Member
May 19, 2018
38
0
46
39
Hey,
I have 3 nodes in cluster.. I already upgraded 2 of them, but when I try to upgrade the one I have left, I always get this error:

After this operation, 8,862 kB of additional disk space will be used. Do you want to continue? [Y/n] y W: (pve-apt-hook) !! WARNING !! W: (pve-apt-hook) You are attempting to remove the meta-package 'proxmox-ve'! W: (pve-apt-hook) W: (pve-apt-hook) If you really want to permanently remove 'proxmox-ve' from your system, run the following command W: (pve-apt-hook) touch '/please-remove-proxmox-ve' W: (pve-apt-hook) run apt purge proxmox-ve to remove the meta-package W: (pve-apt-hook) and repeat your apt invocation. W: (pve-apt-hook) W: (pve-apt-hook) If you are unsure why 'proxmox-ve' would be removed, please verify W: (pve-apt-hook) - your APT repository settings W: (pve-apt-hook) - that you are using 'apt full-upgrade' to upgrade your system E: Sub-process /usr/share/proxmox-ve/pve-apt-hook returned an error code (1) E: Failure running script /usr/share/proxmox-ve/pve-apt-hook

pveversion:
root@pve:~# pveversion pve-manager/6.4-15/af7986e6 (running kernel: 5.4.157-1-pve)
Now after so many attempts I don't get this error, but i notice that it will remove several promox packages (see in underlines):
root@pve:/etc/apt# apt dist-upgrade Reading package lists... Done Building dependency tree... Done Reading state information... Done Calculating upgrade... Done The following packages were automatically installed and are no longer required: cloud-guest-utils cryptsetup-bin dconf-gsettings-backend dconf-service distro-info glib-networking glib-networking-common glib-networking-services gsettings-desktop-schemas gstreamer1.0-libav gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-x i965-va-driver intel-media-va-driver liba52-0.7.4 libaa1 libaacs0 libaom0 libass9 libavc1394-0 libavcodec58 libavfilter7 libavformat58 libavutil56 libbdplus0 libbluray2 libboost-iostreams1.67.0 libboost-system1.67.0 libbs2b0 libcairo-gobject2 libcdio18 libcdio19 libcdparanoia0 libcephfs2 libcgi-fast-perl libcgi-pm-perl libchromaprint1 libclass-accessor-perl libcodec2-0.8.1 libcodec2-0.9 libcroco3 libcrystalhd3 libcwidget3v5 libdav1d4 libdconf1 libdv4 libdvdnav4 libdvdread4 libdvdread8 libegl1-mesa libfcgi-perl libfftw3-double3 libflite1 libfuse3-3 libgcc1:i386 libgdk-pixbuf-2.0-0 libgdk-pixbuf-xlib-2.0-0 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-bin libgdk-pixbuf2.0-common libgfdb0 libgfortran5 libglusterfs-dev libgme0 libgsm1 libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libicu63 libiec61883-0 libigdgmm11 libigdgmm5 libio-string-perl libjack-jackd2-0 libjemalloc2 libjs-sphinxdoc libjs-underscore liblapack3 libleveldb1d liblilv-0-0 libllvm7 libmfx1 libmp3lame0 libmpeg2-4 libmpg123-0 libmysofa0 libmysofa1 libnorm1 libopencore-amrnb0 libopencore-amrwb0 libopenjp2-7 libopenmpt0 liborc-0.4-0 libparse-debianchangelog-perl libperl5.28 libpgm-5.2-0 libpgm-5.3-0 libpocketsphinx3 libpostproc55 libprotobuf17 libproxmox-backup-qemu0 libproxy1v5 libpve-cluster-perl libpython3.7-minimal libpython3.7-stdlib libqrencode4 libraw1394-11 librsvg2-2 librsvg2-common librubberband2 libsamplerate0 libserd-0-0 libshine3 libshout3 libsidplay1v5 libsodium23 libsord-0-0 libsoup2.4-1 libsoxr0 libspeex1 libsphinxbase3 libspice-server1 libsratom-0-0 libsrt1.4-gnutls libssh-gcrypt-4 libswresample3 libswscale5 libtag1v5 libtag1v5-vanilla libtheora0 libtwolame0 libudfread0 libv4l-0 libv4lconvert0 libva-drm2 libva-x11-2 libva2 libvdpau-va-gl1 libvdpau1 libvidstab1.1 libvisual-0.4-0 libvorbisfile3 libvpx5 libvpx6 libwavpack1 libwebpmux3 libx264-155 libx264-160 libx265-165 libx265-192 libxv1 libxvidcore4 libzmq5 libzpool4linux libzvbi-common libzvbi0 mesa-va-drivers mesa-vdpau-drivers ocl-icd-libopencl1 perl-modules-5.28 pocketsphinx-en-us proxmox-archive-keyring proxmox-backup-client proxmox-backup-file-restore proxmox-backup-restore-image proxmox-mini-journalreader pve-kernel-helper pve-lxc-syscalld python3-ceph-argparse python3-ceph-common python3-yaml python3.7-minimal qrencode va-driver-all vdpau-driver-all zstd Use 'apt autoremove' to remove them. The following packages will be REMOVED: ceph-base ceph-common cloud-image-utils cloud-utils criu libldb1 libperl5.24 libpolkit-backend-1-0 libpve-access-control libpve-cluster-api-perl libpve-guest-common-perl libpve-storage-perl libpve-u2f-server-perl libpython-stdlib librados2-perl lxc-pve perl-modules-5.24 [B][U]proxmox-ve pve-cluster pve-container pve-firewall pve-ha-manager pve-manager pve-qemu-kvm[/U][/B] python python-asn1crypto python-certifi python-cffi-backend python-chardet python-configparser python-cryptography python-enum34 python-future python-idna python-ipaddr python-ipaddress python-minimal python-openssl python-protobuf python-rados python-rbd python-requests python-talloc python-urllib3 python3-cephfs python3-rados python3-rbd python3-rgw python3.7 qemu-server spiceterm The following NEW packages will be installed: alsa-topology-conf alsa-ucm-conf build-essential cpp cpp-10 dpkg-dev fakeroot g++ g++-10 gcc gcc-10 libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl libasan6 libatomic1 libboost-iostreams1.74.0 libbpf0 libbrotli1 libc-devtools libcc1-0 libcdio19 libcodec2-0.9 libcom-err2:i386 libcrypt-dev libcwidget4 libdav1d4 libdeflate0 libdpkg-perl libfakeroot libfile-fcntllock-perl libgcc-10-dev libgd3 libgfortran5 libgssapi-krb5-2:i386 libicu67 libigdgmm11 libinih1 libip4tc2 libip6tc2 libisl23 libitm1 libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386 liblapack3 libldb2 liblinear4 libllvm11 liblsan0 libmfx1 libmpc3 libmpdec3 libmpfr6 libmysofa1 libnsl-dev libnsl2:i386 libnss-nis libnss-nis:i386 libnss-nisplus libnss-nisplus:i386 libperl5.32 libpgm-5.3-0 libpocketsphinx3 libpython3.9 libpython3.9-minimal libpython3.9-stdlib libsphinxbase3 libsrt1.4-gnutls libstdc++-10-dev libtirpc-dev libtirpc3:i386 libtsan0 libubsan1 libvpx6 libvulkan1 libx264-160 libx265-192 libxcb-randr0 libz3-4 libzpool5linux lua-lpeg mesa-vulkan-drivers ocl-icd-libopencl1 perl-modules-5.32 pocketsphinx-en-us python3-ldb python3-talloc python3.9 python3.9-minimal systemd-timesyncd The following packages have been kept back: zfs-initramfs zfs-zed The following packages will be upgraded: aptitude aptitude-common curl dh-python gdisk groff-base gstreamer1.0-libav gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-x i965-va-driver intel-media-va-driver iproute2 iptables libaa1 libanyevent-perl libaom0 libapparmor-perl libapt-pkg-perl libasound2 libasound2-data libass9 libauthen-pam-perl libavcodec58 libavfilter7 libavformat58 libavutil56 libblockdev-part2 libc-bin libc-dev-bin libc6 libc6:i386 libc6-dev libc6-i386 libcairo-gobject2 libcairo2 libchromaprint1 libclone-perl libcommon-sense-perl libcrypt-openssl-bignum-perl libcrypt-openssl-random-perl libcrypt-openssl-rsa-perl libcrypt-ssleay-perl libcurl3-gnutls libcurl4 libegl-mesa0 libfcgi-perl libfilesys-df-perl libflac8 libflite1 libfreetype6 libgbm1 libgl1-mesa-dri libglapi-mesa libglx-mesa0 libgme0 libgoogle-perftools4 libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libhtml-parser-perl libhttp-message-perl libiptc0 libjemalloc2 libjson-xs-perl liblilv-0-0 liblinux-inotify2-perl liblocale-gettext-perl libmp3lame0 libmpg123-0 libnet-dbus-perl libnet-dns-sec-perl libnet-libidn-perl libnet-ssleay-perl libnorm1 libnspr4 libnss-systemd libopenjp2-7 libopenmpt0 libopus0 libpam-systemd libpixman-1-0 libpng16-16 libpolkit-agent-1-0 libpolkit-gobject-1-0 libpostproc55 libpulse0 libpython2-stdlib libpython2.7 libpython2.7-minimal libpython2.7-stdlib libpython3-stdlib librdkafka1 librrd8 librrds-perl librsvg2-2 librsvg2-common librubberband2 libsdl1.2debian libsensors5 libserd-0-0 libsidplay1v5 libslang2 libsmbclient libsndfile1 libsocket6-perl libsord-0-0 libsoup2.4-1 libsoxr0 libspeex1 libsqlite3-0 libsratom-0-0 libsub-name-perl libswresample3 libswscale5 libsystemd0 libtag1v5 libtag1v5-vanilla libtcmalloc-minimal4 libtemplate-perl libterm-readline-gnu-perl libtext-charwidth-perl libtext-iconv-perl libtiff5 libtokyocabinet9 libtwolame0 libudev1 libuuid-perl libvisual-0.4-0 libvorbis0a libvorbisenc2 libvorbisfile3 libwbclient0 libwebp6 libwebpmux3 libxapian30 libxml-libxml-perl libxml-parser-perl libxml2 libxslt1.1 libxtables12 libxvidcore4 libyaml-libyaml-perl libzfs4linux libzmq5 libzvbi-common libzvbi0 locales mawk mesa-va-drivers mesa-vdpau-drivers nmap nmap-common perl perl-base pigz policykit-1 postfix postfix-sqlite python-six python2 python2-minimal python2.7 python2.7-minimal python3 python3-apt python3-cffi-backend python3-chardet python3-distutils python3-lib2to3 python3-markupsafe python3-minimal python3-pycurl python3-six python3-yaml rsyslog samba-common samba-libs smbclient sqlite3 systemd udev xfsprogs xserver-xorg-core zfsutils-linux 185 upgraded, 92 newly installed, 51 to remove and 2 not upgraded. Need to get 281 MB/281 MB of archives. After this operation, 42.8 MB disk space will be freed. Do you want to continue? [Y/n]
 
pve6to7:
pve6to7 --full = CHECKING VERSION INFORMATION FOR PVE PACKAGES = Checking for package updates.. WARN: updates for the following packages are available: proxmox-widget-toolkit, corosync, libnozzle1, libqb100, perl-base, libpolkit-gobject-1-0, python-six, libcrypt-ssleay-perl, libnet-libidn-perl, libwebp6, libhttp-message-perl, libencode-perl, libavformat58, libsrt1.4-gnutls, libopenjp2-7, proxmox-backup-file-restore, libcmap4, libqb100, postfix, libicu67, libavfilter7, libmfx1, libmysofa1, libpocketsphinx3, libsphinxbase3, ocl-icd-libopencl1, ocl-icd-libopencl1, libaa1, librrds-perl, libpve-access-control, libpve-rs-perl, proxmox-mini-journalreader, libchromaprint1, iptables, libip4tc2, libip6tc2, python3-distutils, libterm-readline-gnu-perl, libnet-ssleay-perl, libcurl4, libbrotli1, libpve-storage-perl, libposix-strptime-perl, libxapian30, proxmox-archive-keyring, xserver-xorg-core, libnorm1, libc6-dev, libcrypt-dev, libnsl-dev, libegl-mesa0, libcairo-gobject2, libswresample3, libwbclient0, libicu67, libsystemd0, pve-firmware, libpython2-stdlib, libzmq5, libpgm-5.3-0, gstreamer1.0-plugins-good, libvpx6, libsratom-0-0, libglapi-mesa, libpixman-1-0, libasound2-data, python2.7-minimal, libquorum5, libqb100, libcrypt-openssl-random-perl, libsqlite3-0, librsvg2-common, postfix-sqlite, ksm-control-daemon, pve-qemu-kvm, liburing1, libvirglrenderer1, libproxmox-acme-plugins, libopenmpt0, liblilv-0-0, libpve-cluster-api-perl, libpve-cluster-perl, libpython2.7, libfilesys-df-perl, python2.7, libfcgi-perl, libmp3lame0, libc6, libc6, pve-docs, libuuid-perl, pve-ha-manager, libproxmox-acme-perl, zfs-initramfs, liblocale-gettext-perl, python2, python3, python3.9, libpolkit-agent-1-0, pve-firewall, libjs-extjs, libvorbisfile3, udev, locales, gstreamer1.0-plugins-base, python3-six, pve-container, zfs-zed, proxmox-backup-client, libblockdev-part2, libzfs4linux, libopus0, librubberband2, libanyevent-perl, pve-cluster, libqb100, libpostproc55, libudev1, rsyslog, librados2-perl, vncterm, libsoup2.4-1, libbrotli1, libjson-xs-perl, spiceterm, libgbm1, libapt-pkg-perl, libaom0, librdkafka1, python3-pycurl, zfsutils-linux, libzpool5linux, samba-libs, libldb2, libpython3.9, python3-ldb, python3-talloc, sqlite3, libiptc0, libip4tc2, gdisk, libtcmalloc-minimal4, pve-i18n, pve-xtermjs, libpve-u2f-server-perl, ifupdown2, libtiff5, libdeflate0, groff-base, python3-minimal, libclone-perl, libapparmor-perl, libsub-name-perl, libc-bin, libpulse0, pve-manager, libjs-qrcodejs, libproxmox-rs-perl, libpve-rs-perl, libass9, libmpg123-0, libxvidcore4, nmap, liblinear4, lua-lpeg, xfsprogs, libicu67, libinih1, librsvg2-2, python2-minimal, libzvbi0, aptitude-common, libvotequorum8, libqb100, libvorbisenc2, libnet-dbus-perl, libtag1v5, libpython3-stdlib, libpython3.9-stdlib, python3-cffi-backend, spl, libpve-guest-common-perl, proxmox-websocket-tunnel, samba-common, mawk, libspeex1, novnc-pve, python3-markupsafe, libavcodec58, libcodec2-0.9, libdav1d4, libmfx1, libvpx6, libx264-160, libx265-192, librrd8, pve-lxc-syscalld, libpve-common-perl, libnetaddr-ip-perl, libproxmox-rs-perl, libc6-i386, libnet-dns-sec-perl, libpam-systemd, libgstreamer-plugins-base1.0-0, libavutil56, libmfx1, ocl-icd-libopencl1, ocl-icd-libopencl1, proxmox-backup-restore-image, lxc-pve, libsndfile1, python3-lib2to3, python3-yaml, libgoogle-perftools4, gstreamer1.0-x, libyaml-libyaml-perl, libcrypt-openssl-rsa-perl, systemd, libip4tc2, qemu-server, swtpm, swtpm-tools, libsdl1.2debian, libgme0, libcrypt-openssl-bignum-perl, dh-python, libcfg7, libqb100, libtemplate-perl, libnvpair3linux, libauthen-pam-perl, libproxmox-backup-qemu0, libsoxr0, libwebpmux3, libuutil3linux, libcommon-sense-perl, iproute2, libbpf0, libgl1-mesa-dri, libllvm11, libvulkan1, libswscale5, libxml-libxml-perl, libknet1, libsmbclient, smartmontools, smbclient, libjemalloc2, libsord-0-0, libnss-systemd, libasound2, pve-kernel-helper, libvisual-0.4-0, libxtables12, libsocket6-perl, policykit-1, gstreamer1.0-libav, libsidplay1v5, libc-dev-bin, intel-media-va-driver, libigdgmm11, libxml2, libicu67, libflac8, libpython2.7-minimal, libtwolame0, libfreetype6, libbrotli1, pve-edk2-firmware, perl, perl-modules-5.32, libperl5.32, libpve-http-server-perl, criu, python3-protobuf, libxml-parser-perl, mesa-vdpau-drivers, libllvm11, liblinux-inotify2-perl, libvorbis0a, libtag1v5-vanilla, libicu67, i965-va-driver, libcairo2, libpython2.7-stdlib, pigz, libtext-iconv-perl, libcpg4, libqb100, libzvbi-common, curl, libserd-0-0, aptitude, libboost-iostreams1.74.0, libcwidget4, nmap-common, libpve-apiclient-perl, libhtml-parser-perl, libsensors5, python3-chardet, libgstreamer1.0-0, libnspr4, libcurl3-gnutls, libbrotli1, libflite1, python3-apt, libcorosync-common4, libtokyocabinet9, mesa-va-drivers, libllvm11, libxslt1.1, libtext-charwidth-perl, gstreamer1.0-plugins-ugly, libcdio19, libx264-160, proxmox-ve, pve-kernel-5.15, libglx-mesa0, lxcfs, btrfs-progs, libslang2, libpng16-16 Checking proxmox-ve package version.. PASS: proxmox-ve package has version >= 6.4-1 Checking running kernel version.. PASS: expected running kernel '5.4.157-1-pve'. = CHECKING CLUSTER HEALTH/SETTINGS = PASS: systemd unit 'pve-cluster.service' is in state 'active' PASS: systemd unit 'corosync.service' is in state 'active' PASS: Cluster Filesystem is quorate. Analzying quorum settings and state.. INFO: configured votes - nodes: 3 INFO: configured votes - qdevice: 0 INFO: current expected votes: 3 INFO: current total votes: 3 Checking nodelist entries.. PASS: nodelist settings OK Checking totem settings.. PASS: totem settings OK INFO: run 'pvecm status' to get detailed cluster status.. = CHECKING HYPER-CONVERGED CEPH STATUS = SKIP: no hyper-converged ceph setup detected! = CHECKING CONFIGURED STORAGES = PASS: storage 'VMBackups1' enabled and active. PASS: storage 'local' enabled and active. PASS: storage 'local-lvm' enabled and active. = MISCELLANEOUS CHECKS = INFO: Checking common daemon services.. PASS: systemd unit 'pveproxy.service' is in state 'active' PASS: systemd unit 'pvedaemon.service' is in state 'active' PASS: systemd unit 'pvestatd.service' is in state 'active' INFO: Checking for running guests.. PASS: no running guest detected. INFO: Checking if the local node's hostname 'pve' is resolvable.. INFO: Checking if resolved IP is configured on local node.. PASS: Resolved node IP '10.12.17.25' configured and active on single interface. INFO: Checking backup retention settings.. PASS: no problems found. INFO: checking CIFS credential location.. PASS: no CIFS credentials at outdated location found. INFO: Checking custom roles for pool permissions.. INFO: Checking node and guest description/note legnth.. PASS: All node config descriptions fit in the new limit of 64 KiB PASS: All guest config descriptions fit in the new limit of 8 KiB INFO: Checking container configs for deprecated lxc.cgroup entries PASS: No legacy 'lxc.cgroup' keys found. INFO: Checking storage content type configuration.. PASS: no problems found INFO: Checking if the suite for the Debian security repository is correct.. PASS: already using 'bullseye-security' SKIP: No containers on node detected. = SUMMARY = TOTAL: 25 PASSED: 22 SKIPPED: 2 WARNINGS: 1 FAILURES: 0 ATTENTION: Please check the output for detailed information!

pveversion:
root@pve:/etc/apt# pveversion -v proxmox-ve: 6.4-1 (running kernel: 5.4.157-1-pve) pve-manager: 6.4-15 (running version: 6.4-15/af7986e6) pve-kernel-5.4: 6.4-17 pve-kernel-helper: 6.4-17 pve-kernel-5.3: 6.1-6 pve-kernel-5.4.189-1-pve: 5.4.189-1 pve-kernel-5.4.178-1-pve: 5.4.178-1 pve-kernel-5.4.157-1-pve: 5.4.157-1 pve-kernel-4.15: 5.4-8 pve-kernel-5.3.18-3-pve: 5.3.18-3 pve-kernel-4.15.18-20-pve: 4.15.18-46 pve-kernel-4.15.18-12-pve: 4.15.18-36 ceph-fuse: 15.2.15-pve1~bpo10 corosync: 3.1.5-pve2~bpo10+1 criu: 3.11-3 glusterfs-client: 9.2-1 ifupdown: residual config ifupdown2: 3.0.0-1+pve4~bpo10 ksm-control-daemon: 1.3-1 libjs-extjs: 6.0.1-10 libknet1: 1.22-pve2~bpo10+1 libproxmox-acme-perl: 1.1.0 libproxmox-backup-qemu0: 1.1.0-1 libpve-access-control: 6.4-3 libpve-apiclient-perl: 3.1-3 libpve-common-perl: 6.4-5 libpve-guest-common-perl: 3.1-5 libpve-http-server-perl: 3.2-4 libpve-storage-perl: 6.4-1 libqb0: 1.0.5-1 libspice-server1: 0.14.3-2.1 lvm2: 2.03.11-2.1 lxc-pve: 4.0.6-2 lxcfs: 4.0.7-1 novnc-pve: 1.1.0-1 proxmox-backup-client: 1.1.13-2 proxmox-mini-journalreader: 1.1-1 proxmox-widget-toolkit: 2.6-2 pve-cluster: 6.4-1 pve-container: 3.3-6 pve-docs: 6.4-2 pve-edk2-firmware: 2.20200531-1 pve-firewall: 4.1-4 pve-firmware: 3.3-2 pve-ha-manager: 3.1-1 pve-i18n: 2.3-1 pve-qemu-kvm: 5.2.0-7 pve-xtermjs: 4.7.0-3 qemu-server: 6.4-2 smartmontools: 7.2-pve2 spiceterm: 3.1-1 vncterm: 1.6-2 zfsutils-linux: 2.0.7-pve1
My sources.list file:
root@pve:/etc/apt# cat sources.list deb http://download.proxmox.com/debian/pve bullseye pve-no-subscription deb http://deb.debian.org/debian-security/ bullseye-security main contrib non-free deb http://deb.debian.org/debian bullseye-backports main contrib non-free deb http://ftp.debian.org/debian bullseye main contrib deb http://ftp.debian.org/debian bullseye-updates main contrib
pls help me is a production server
 
Last edited:
do you have a ceph repository configured? if not, you probably need the following since you have a PVE-provided ceph package installed at the moment:

Code:
echo "deb http://download.proxmox.com/debian/ceph-octopus bullseye main" > /etc/apt/sources.list.d/ceph.list

then run apt update, and post the output of that and of apt dist-upgrade
 
Fabian, when you answered me, I had already run the apt upgrade command without dist-.. and it seemed to work for me, because a message came up that I was going to update to version 7.
Then when I was done I put what you told me, since I don't use Ceph and then apt dist-upgrade and finished the update, then apt autoremove.
Now all my nodes have the same version.
but I have another question, why do I get so many kernels?:
Code:
root@pve:~# pveversion -v
proxmox-ve: 7.2-1 (running kernel: 5.15.35-2-pve)
pve-manager: 7.2-4 (running version: 7.2-4/ca9d43cc)
pve-kernel-5.15: 7.2-4
pve-kernel-helper: 7.2-4
pve-kernel-5.4: 6.4-17
pve-kernel-5.15.35-2-pve: 5.15.35-5
pve-kernel-5.4.189-1-pve: 5.4.189-1
pve-kernel-4.15: 5.4-8
pve-kernel-4.15.18-20-pve: 4.15.18-46
pve-kernel-4.15.18-12-pve: 4.15.18-36
ceph-fuse: 15.2.16-pve1
corosync: 3.1.5-pve2
criu: 3.15-1+pve-1
glusterfs-client: 9.2-1
ifupdown: residual config
ifupdown2: 3.1.0-1+pmx3
ksm-control-daemon: 1.4-1
libjs-extjs: 7.0.0-1
libknet1: 1.24-pve1
libproxmox-acme-perl: 1.4.2
libproxmox-backup-qemu0: 1.3.1-1
libpve-access-control: 7.2-2
libpve-apiclient-perl: 3.2-1
libpve-common-perl: 7.2-2
libpve-guest-common-perl: 4.1-2
libpve-http-server-perl: 4.1-2
libpve-storage-perl: 7.2-4
libqb0: 1.0.5-1
libspice-server1: 0.14.3-2.1
lvm2: 2.03.11-2.1
lxc-pve: 4.0.12-1
lxcfs: 4.0.12-pve1
novnc-pve: 1.3.0-3
proxmox-backup-client: 2.2.3-1
proxmox-backup-file-restore: 2.2.3-1
proxmox-mini-journalreader: 1.3-1
proxmox-widget-toolkit: 3.5.1
pve-cluster: 7.2-1
pve-container: 4.2-1
pve-docs: 7.2-2
pve-edk2-firmware: 3.20210831-2
pve-firewall: 4.2-5
pve-firmware: 3.4-2
pve-ha-manager: 3.3-4
pve-i18n: 2.7-2
pve-qemu-kvm: 6.2.0-10
pve-xtermjs: 4.16.0-1
qemu-server: 7.2-3
smartmontools: 7.2-pve3
spiceterm: 3.2-2
swtpm: 0.7.1~bpo11+1
vncterm: 1.7-1
zfsutils-linux: 2.1.4-pve1
Thanks a lot man! You save me
 
you can remove those kernel version you no longer need (only the latest is always required, since it's part of the dependencies of proxmox-ve)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!