[SOLVED] Disk Error?

Pablo1732

Member
Dec 25, 2021
38
3
13
Hello,
I use a MiniPC as a proxmox backup server. I have a 2.5 inch 128GB SSD connected via a USB3.0 adapter. The operating system is installed on it. And I have an 8TB USB hard drive connected for the backups. I know this is not the best solution, but it has worked for me for over a year without any problems. But now the whole system crashes as soon as backups are made or as soon as the system does anything. When I connect a monitor the error is displayed on the picture attached. As soon as I unplug the PC and restart it, everything works again for a short time.

I would like to know if this is a problem with the SSD on which the system is installed, or with the data hard drive. Which of the two is broken?
 

Attachments

  • IMG_6628-.jpg
    IMG_6628-.jpg
    482.6 KB · Views: 10
What is lsblk returning?
My guess would be faulty SSD or USB-to-SATA adapter as it looks like swap is affected too and this should usually be on your system disk.
 
Last edited:
What does smartctl -a /dev/sda return? You could also start a SMART self-test with smartctl -t long /dev/sda.

I would also try to backup "/etc" as soon as possible before it completely fails.
 
Last edited:
What does smartctl -a /dev/sda return? You could also start a SMART self-test with smartctl -t long /dev/sda.
I have already connected the SSD with the same adapter to a Windows PC and performed a long SMART test there but "unfortunately" it did not show any errors. I have also already completely reinstalled the system for testing
 
I have nevertheless made a quick test on this system again
 

Attachments

  • Screenshot 2023-10-12 185129.jpg
    Screenshot 2023-10-12 185129.jpg
    334.8 KB · Views: 8
Then it's probably a connection problem (as the selftest is disk internal and not the host doing IO to disk) because of a bad usb port, usb controller, usb cable, SATA-to-USB adapter or bad external PSU.
I would try another USB port, usb cable and SATa-to-USB adapter.
 
Last edited:
USB is know to make problems. I had my Promox OS disk's connected to an internal USB 3.0 Y Port splitter and they lost multiple times the connection which resulted in very interesting feelings provided by my kernel. Also I connected once my 6TB disk via USB to my Proxmox Backup VM and it also resulted in multiple disconnects which forced me to connect it via SATA. Since then no problem ever again.. It is very related to your USB 3.0 chip and also you should make sure to have an adapter which provides its own powersource so you don't stress out the USB-Controller to much. Also you must be aware that your USB-Controller shares a lot stuff with other I/O components which result in funny behavior if your I/O is under heavy load.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!