[SOLVED] Debian 10 LXC Container won't start after 'apt upgrade'


Sep 14, 2019
I have a problem with my proxmox (6.0-4). When I create a Debian 10 container using the official Debian 10 image (debian-10.0-standard_10.0-1_amd64.tar.gz) everything works, untill I reboot the container. After that, it wont start again.

Output of apt upgrade on container:
29 packages can be upgraded. Run 'apt list --upgradable' to see them.
N: Repository 'http://ftp.debian.org/debian buster InRelease' changed its 'Version' value from '10.0' to '10.1'
Reading package lists... Done
Building dependency tree... Done
Calculating upgrade... Done
The following packages will be upgraded:
  base-files bzip2 e2fsprogs gpgv libbz2-1.0 libcom-err2 libcryptsetup12 libexpat1 libext2fs2 libldap-2.4-2 libldap-common
  libncurses6 libncursesw6 libnghttp2-14 libnss-systemd libpam-systemd libss2 libsystemd0 libtinfo6 libudev1 ncurses-base
  ncurses-bin ncurses-term python3-reportbug reportbug systemd systemd-sysv tzdata udev
29 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 10.4 MB of archives.
After this operation, 17.4 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://security.debian.org buster/updates/main amd64 libexpat1 amd64 2.2.6-2+deb10u1 [106 kB]
Get:2 http://ftp.debian.org/debian buster/main amd64 base-files amd64 10.3+deb10u1 [69.7 kB]
Get:3 http://security.debian.org buster/updates/main amd64 libnghttp2-14 amd64 1.36.0-2+deb10u1 [85.0 kB]
Get:4 http://ftp.debian.org/debian buster/main amd64 ncurses-bin amd64 6.1+20181013-2+deb10u1 [406 kB]
Get:5 http://ftp.debian.org/debian buster/main amd64 ncurses-base all 6.1+20181013-2+deb10u1 [258 kB]
Get:6 http://ftp.debian.org/debian buster/main amd64 libnss-systemd amd64 241-7~deb10u1 [204 kB]
Get:7 http://ftp.debian.org/debian buster/main amd64 libsystemd0 amd64 241-7~deb10u1 [330 kB]
Get:8 http://ftp.debian.org/debian buster/main amd64 libpam-systemd amd64 241-7~deb10u1 [208 kB]
Get:9 http://ftp.debian.org/debian buster/main amd64 systemd amd64 241-7~deb10u1 [3495 kB]
Get:10 http://ftp.debian.org/debian buster/main amd64 udev amd64 241-7~deb10u1 [1276 kB]
Get:11 http://ftp.debian.org/debian buster/main amd64 libudev1 amd64 241-7~deb10u1 [149 kB]
Get:12 http://ftp.debian.org/debian buster/main amd64 systemd-sysv amd64 241-7~deb10u1 [98.8 kB]
Get:13 http://ftp.debian.org/debian buster/main amd64 libcryptsetup12 amd64 2:2.1.0-5+deb10u2 [193 kB]
Get:14 http://ftp.debian.org/debian buster/main amd64 libext2fs2 amd64 1.44.5-1+deb10u1 [220 kB]
Get:15 http://ftp.debian.org/debian buster/main amd64 e2fsprogs amd64 1.44.5-1+deb10u1 [575 kB]
Get:16 http://ftp.debian.org/debian buster/main amd64 bzip2 amd64 1.0.6-9.2~deb10u1 [48.4 kB]
Get:17 http://ftp.debian.org/debian buster/main amd64 libbz2-1.0 amd64 1.0.6-9.2~deb10u1 [45.3 kB]
Get:18 http://ftp.debian.org/debian buster/main amd64 gpgv amd64 2.2.12-1+deb10u1 [584 kB]
Get:19 http://ftp.debian.org/debian buster/main amd64 libncurses6 amd64 6.1+20181013-2+deb10u1 [102 kB]
Get:20 http://ftp.debian.org/debian buster/main amd64 libtinfo6 amd64 6.1+20181013-2+deb10u1 [325 kB]
Get:21 http://ftp.debian.org/debian buster/main amd64 libncursesw6 amd64 6.1+20181013-2+deb10u1 [132 kB]
Get:22 http://ftp.debian.org/debian buster-updates/main amd64 tzdata all 2019c-0+deb10u1 [261 kB]
Get:23 http://ftp.debian.org/debian buster/main amd64 ncurses-term all 6.1+20181013-2+deb10u1 [490 kB]
Get:24 http://ftp.debian.org/debian buster/main amd64 reportbug all 7.5.3~deb10u1 [128 kB]
Get:25 http://ftp.debian.org/debian buster/main amd64 python3-reportbug all 7.5.3~deb10u1 [134 kB]
Get:26 http://ftp.debian.org/debian buster/main amd64 libcom-err2 amd64 1.44.5-1+deb10u1 [68.4 kB]
Get:27 http://ftp.debian.org/debian buster/main amd64 libldap-common all 2.4.47+dfsg-3+deb10u1 [89.6 kB]
Get:28 http://ftp.debian.org/debian buster/main amd64 libldap-2.4-2 amd64 2.4.47+dfsg-3+deb10u1 [225 kB]
Get:29 http://ftp.debian.org/debian buster/main amd64 libss2 amd64 1.44.5-1+deb10u1 [72.8 kB]
Fetched 10.4 MB in 1s (12.8 MB/s)

root@proxmox01:~# pct start 110
Job for pve-container@110.service failed because the control process exited with error code.
See "systemctl status pve-container@110.service" and "journalctl -xe" for details.
command 'systemctl start pve-container@110' failed: exit code 1

Sep 25 08:03:56 proxmox01 systemd[1]: Starting PVE LXC Container: 110...
Sep 25 08:03:57 proxmox01 lxc-start[17080]: lxc-start: 110: lxccontainer.c: wait_on_daemonized_start: 856 No such file or director
Sep 25 08:03:57 proxmox01 lxc-start[17080]: lxc-start: 110: tools/lxc_start.c: main: 330 The container failed to start
Sep 25 08:03:57 proxmox01 lxc-start[17080]: lxc-start: 110: tools/lxc_start.c: main: 333 To get more details, run the container in
Sep 25 08:03:57 proxmox01 lxc-start[17080]: lxc-start: 110: tools/lxc_start.c: main: 336 Additional information can be obtained by
Sep 25 08:03:57 proxmox01 systemd[1]: pve-container@110.service: Control process exited, code=exited, status=1/FAILURE
Sep 25 08:03:57 proxmox01 systemd[1]: pve-container@110.service: Failed with result 'exit-code'.
Sep 25 08:03:57 proxmox01 systemd[1]: Failed to start PVE LXC Container: 110.

Now, I have been all around the internet to find a solution to this problem (I will link the most usefull ones below), and what I have figured out is that I need to update to 6.0-7, but I simply don't know how to do that. Some have had "Stretch" in their apt sources, and needed to change that to "Buster" to make it work out. My problem is that it already says "Buster" in all of my apt sources, but I am just unable to get any further.
Reddit Thread
Forum Post Regarding the same problem
Forum post

Here is the output of an apt update && apt upgrade on my proxmox host.
Hit:1 http://security.debian.org buster/updates InRelease
Hit:2 http://ftp.dk.debian.org/debian buster InRelease                                       
Hit:3 http://ftp.dk.debian.org/debian buster-updates InRelease                               
Err:4 https://enterprise.proxmox.com/debian/pve buster InRelease
  401  Unauthorized [IP: 443]
Reading package lists... Done                         
E: Failed to fetch https://enterprise.proxmox.com/debian/pve/dists/buster/InRelease  401  Unauthorized [IP: 443]
E: The repository 'https://enterprise.proxmox.com/debian/pve buster InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Here you can see the output of pveversion -v
proxmox-ve: 6.0-2 (running kernel: 5.0.15-1-pve)
pve-manager: 6.0-4 (running version: 6.0-4/2a719255)
pve-kernel-5.0: 6.0-5
pve-kernel-helper: 6.0-5
pve-kernel-5.0.15-1-pve: 5.0.15-1
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.0.2-pve2
criu: 3.11-3
glusterfs-client: 5.5-3
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.10-pve1
libpve-access-control: 6.0-2
libpve-apiclient-perl: 3.0-2
libpve-common-perl: 6.0-2
libpve-guest-common-perl: 3.0-1
libpve-http-server-perl: 3.0-2
libpve-storage-perl: 6.0-5
libqb0: 1.0.5-1
lvm2: 2.03.02-pve3
lxc-pve: 3.1.0-61
lxcfs: 3.0.3-pve60
novnc-pve: 1.0.0-60
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.0-5
pve-cluster: 6.0-4
pve-container: 3.0-3
pve-docs: 6.0-4
pve-edk2-firmware: 2.20190614-1
pve-firewall: 4.0-5
pve-firmware: 3.0-2
pve-ha-manager: 3.0-2
pve-i18n: 2.0-2
pve-qemu-kvm: 4.0.0-3
pve-xtermjs: 3.13.2-1
qemu-server: 6.0-5
smartmontools: 7.0-pve2
spiceterm: 3.1-1
vncterm: 1.6-1
zfsutils-linux: 0.8.1-pve1

I hope you can help :)

As you're already using 6.0 no changes from Stretch to buster are needed.

But you only have enabled the enterprise repository but have no valid Subscription to access it.
So either add one or switch over to the "Proxmox VE No-Subscription Repository"

See: https://pve.proxmox.com/wiki/Package_Repositories
  • Like
Reactions: Rowe
Huh. I guess I am just the idiot who didn't read enough to get that.
Thank you very much though, everything works now.

Btw is it a line you would normally have to populate yourself?
Btw is it a line you would normally have to populate yourself?

Not if you have a subscription for the enterprise repository, which may be wanted for production system to ensure the most stable and tested software gets installed. If you do not have such a subscription, then yes, another repository option needs to be added.
Not if you have a subscription for the enterprise repository, which may be wanted for production system to ensure the most stable and tested software gets installed. If you do not have such a subscription, then yes, another repository option needs to be added.

Fair enough, thanks.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!