Can't start container after updating

PlOrAdmin

New Member
May 22, 2019
20
0
1
45
Hi, running PVE 6.0-4

I had a CT running pihole and updated it(apt update, apt upgrade) connecting with lxc-attach --name ID

After I typed reboot it dropped back to host shell.

I cannot start container. I get this error. Not sure what I am looking for when I run the commands to troubleshoot.

The CT wasn't important so I tried to reproduce the problem. Created new container, update within and reboot. Same issue.
Is this a bug in PVE6 or am I doing something that shouldn't be needing doing?

I posted this question on reddit and another user experienced same issue. https://old.reddit.com/r/Proxmox/comments/d1yy4c/cant_start_container_after_updating_it/

Thanks.
 

Chris

Proxmox Staff Member
Staff member
Jan 2, 2019
378
38
28
Hi,
please start the container in foreground mode and provide the debug logs. For this you have to run lxc-start -n CTID -F -l DEBUG -o /tmp/lxc-CTID.log with CTID being the ID of your container.
 

Chris

Proxmox Staff Member
Staff member
Jan 2, 2019
378
38
28
Hi,

I don't understand what foreground mode is. Here is the log file from another fresh CT install.

Thanks.
There is an error stating that Debian 10.1 is not supported, which is not true for up to date packages. Please update all the packages on your PVE host to the latest version and try again.
 

PlOrAdmin

New Member
May 22, 2019
20
0
1
45
Hi,

My host(v 6.0-4) was updated already. I installed deb9 CT also as a test. It works after updates/reboot but 10 does not. I even tried DHCP in as a grasping of straws to see if my configuration of static IP was the problem lol.

The version pveam available shows for 10 is: debian-10.0-standard_10.0-1_amd64.tar.gz

I'm going to run my CTs in 9 for now. I hope this helps you folks diagnose what's going on. If you want me to test anything further I'll do my best to help.

Thanks.
 

Rowe

New Member
Sep 14, 2019
1
0
1
20
Hello. I would like to add that I am having the exact same problem as well.
The host is fully updated. Whenever I run apt update && apt upgrade on any container, and reboot it afterwards, it cannot start again. Just like OP.

Here is a log file from a fresh container, not that I think it will be any different from OPs, but anyways.
 

Attachments

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!