command 'apt-get update' failed: exit code 100

Peter123

Member
Mar 5, 2018
16
0
6
50
Same Problem here again with Proxmox 5.4-3 without subscription, not being able to "apt update":

Ign:1 http://ftp.debian.org/debian stretch InRelease
Hit:2 http://ftp.debian.org/debian stretch Release
Hit:4 http://security.debian.org stretch/updates InRelease
Hit:5 http://download.proxmox.com/debian/pve stretch InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
W: Target Packages (pve-no-subscription/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:5 and /etc/apt/sources.list.d/pve-install-repo.list:1
W: Target Packages (pve-no-subscription/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:5 and /etc/apt/sources.list.d/pve-install-repo.list:1
W: Target Translations (pve-no-subscription/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:5 and /etc/apt/sources.list.d/pve-install-repo.list:1
W: Target Translations (pve-no-subscription/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:5 and /etc/apt/sources.list.d/pve-install-repo.list:1
W: Target Packages (pve-no-subscription/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:5 and /etc/apt/sources.list.d/pve-install-repo.list:1
W: Target Packages (pve-no-subscription/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:5 and /etc/apt/sources.list.d/pve-install-repo.list:1
W: Target Translations (pve-no-subscription/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:5 and /etc/apt/sources.list.d/pve-install-repo.list:1
W: Target Translations (pve-no-subscription/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:5 and /etc/apt/sources.list.d/pve-install-repo.list:1


/etc/apt/sources.list:
deb http://ftp.debian.org/debian stretch main contrib
# PVE pve-no-subscription repository provided by proxmox.com,
# NOT recommended for production use
deb http://download.proxmox.com/debian/pve stretch pve-no-subscription
# security updates
deb http://security.debian.org stretch/updates main contrib
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
14,109
508
133
W: Target Packages (pve-no-subscription/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:5 and /etc/apt/sources.list.d/pve-install-repo.list:1
read your error message and fix it.

> rm /etc/apt/sources.list.d/pve-install-repo.list
 

Peter123

Member
Mar 5, 2018
16
0
6
50
Wasn't sure if it is ok to delete the pve-install-repo.list (and did not find any hint in the docs about that).

Thanks.
 

Boogie2005

New Member
Jan 13, 2020
24
0
1
64
So, leider habe ich auch bei Proxmox Update diese Meldung. Das Ergebnis:

root@xxxx:~# pveversion -v
proxmox-ve: 6.1-2 (running kernel: 5.3.13-1-pve)
pve-manager: 6.1-5 (running version: 6.1-5/9bf06119)
pve-kernel-5.3: 6.1-1
pve-kernel-helper: 6.1-1
pve-kernel-5.3.13-1-pve: 5.3.13-1
pve-kernel-5.3.10-1-pve: 5.3.10-1
ceph: 14.2.6-pve1
ceph-fuse: 14.2.6-pve1
corosync: 3.0.2-pve4
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: 0.8.35+pve1
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.13-pve1
libpve-access-control: 6.0-5
libpve-apiclient-perl: 3.0-2
libpve-common-perl: 6.0-9
libpve-guest-common-perl: 3.0-3
libpve-http-server-perl: 3.0-3
libpve-storage-perl: 6.1-3
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve3
lxc-pve: 3.2.1-1
lxcfs: 3.0.3-pve60
novnc-pve: 1.1.0-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.1-2
pve-cluster: 6.1-2
pve-container: 3.0-16
pve-docs: 6.1-3
pve-edk2-firmware: 2.20191127-1
pve-firewall: 4.0-9
pve-firmware: 3.0-4
pve-ha-manager: 3.0-8
pve-i18n: 2.0-3
pve-qemu-kvm: 4.1.1-2
pve-xtermjs: 3.13.2-1
qemu-server: 6.1-4
smartmontools: 7.0-pve2
spiceterm: 3.1-1
vncterm: 1.6-1
zfsutils-linux: 0.8.2-pve2


Kann mir jemand erklären, wie ich den Fehler beheben kann? Verbinde ich mich mit Putty auf den Proxmox Server klappt apt-get update und upgrade ohne Probleme.

update.jpg
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
3,068
330
83
Kann mir jemand erklären, wie ich den Fehler beheben kann?
die Meldung im Tasklog:
401 Unauthorized deutet darauf hin, dass keine gültige subscription auf der node eingespielt ist.
* Wenn eine subscription vorhanden ist, diese Einspielen (pvesubscription set <key>)
* Wenn keine subscription vorhanden ist - das pve-no-subscription repository eintragen - siehe https://pve.proxmox.com/pve-docs/pve-admin-guide.html#sysadmin_package_repositories

Verbinde ich mich mit Putty auf den Proxmox Server klappt apt-get update und upgrade ohne Probleme.
* bitte hier das ganze output posten
* PVE muss mit `apt-get dist-upgrade` oder `apt full-upgrade` upgegraded werden - eine `apt-get upgrade` führt relativ oft zu Problemen.

Ich hoffe das hilft!

P.S. bitte lieber einen neuen thread eröffnen als auf einen von vor 2.5 Jahren begonnenen antworten.
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
3,068
330
83
welche befehle?
bei dem link werden nur die inhalte der sources.list bzw. sources.list.d/pve.list files gezeigt
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
3,068
330
83
Code:
cat /etc/apt/sources.list
grep '' /etc/apt/sources.list.d/*
(mit cat wird der inhalt eines files auf stdout angezeigt, `grep ''` macht das war auch aber schreibt auch den namen des files vor jede zeile)
(siehe `man cat`, `man grep`)

Ich hoffe das hilft
 

Boogie2005

New Member
Jan 13, 2020
24
0
1
64
Beim zweiten Befehl sieht das dann so aus:
root@xxxxx:~# grep '' /etc/apt/sources.list.d/*
/etc/apt/sources.list.d/ceph.list:deb http://download.proxmox.com/debian/ceph-nautilus buster main
/etc/apt/sources.list.d/pve-enterprise.list:deb https://enterprise.proxmox.com/debian/pve buster pve-enterprise
/etc/apt/sources.list.d/pve-enterprise.list.save:deb http://download.proxmox.com/debian/pve buster pve-no-subscription
/etc/apt/sources.list.d/pve-enterprise.list.save.1:deb http://download.proxmox.com/debian/pve buster pve-no-subscription
/etc/apt/sources.list.d/pve-enterprise.list.save.2:deb http://download.proxmox.com/debian/pve buster pve-no-subscription
/etc/apt/sources.list.d/pve-enterprise.list.save.3:deb http://download.proxmox.com/debian/pve buster pve-no-subscription
/etc/apt/sources.list.d/pve-enterprise.list.save.4:deb http://download.proxmox.com/debian/pve buster pve-no-subscription
/etc/apt/sources.list.d/pve-enterprise.list.save.5:deb http://download.proxmox.com/debian/pve buster pve-no-subscription
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
3,068
330
83
was sind diese '.save' files?

Jedenfalls - /etc/apt/sources.list.d/pve-enterprise.list (apt beachtet nur files die mit '.list' enden) enthält nur das enterprise repository - auf das geht der Zugriff nur mit einer gültigen subscription.

Wenn keine subscription vorhanden ist - einfach in dem file den inhalt aus einem der anderen files eintragen:
Code:
deb http://download.proxmox.com/debian/pve buster pve-no-subscription
 

123proxerei

New Member
Jan 10, 2020
5
2
3
33
Hallo zusammen,
ich bekomme beim Versuch node.js upzudaten auch folgende Fehlermeldung:

Code:
## Installing the NodeSource Node.js 10.x repo...


## Populating apt-get cache...

+ apt-get update
OK:1 http://security.debian.org buster/updates InRelease
OK:2 http://security.debian.org/debian-security buster/updates InRelease
OK:3 http://ftp.de.debian.org/debian buster InRelease
OK:4 http://ftp.de.debian.org/debian buster-updates InRelease
Holen:5 http://download.proxmox.com/debian/pve buster InRelease [3.051 B]
Fehl:5 http://download.proxmox.com/debian/pve buster InRelease
  Die folgenden Signaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht verfügbar ist: NO_PUBKEY 7BF2812E8A6E88E0
Paketlisten werden gelesen... Fertig
W: GPG-Fehler: http://download.proxmox.com/debian/pve buster InRelease: Die folgenden Signaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht verfügbar ist: NO_PUBKEY 7BF2812E8A6E88E0
E: Das Depot »http://download.proxmox.com/debian/pve buster InRelease« ist nicht signiert.
N: Eine Aktualisierung von solch einem Depot kann nicht auf eine sichere Art durchgeführt werden, daher ist es standardmäßig deaktiviert.
N: Weitere Details zur Erzeugung von Paketdepots sowie zu deren Benutzerkonfiguration finden Sie in der Handbuchseite apt-secure(8).
W: Ziel Packages (pve-no-subscription/binary-amd64/Packages) ist mehrfach konfiguriert in /etc/apt/sources.list:6 und /etc/apt/sources.list.d/pve-no-subscription.list:3
W: Ziel Packages (pve-no-subscription/binary-all/Packages) ist mehrfach konfiguriert in /etc/apt/sources.list:6 und /etc/apt/sources.list.d/pve-no-subscription.list:3
W: Ziel Translations (pve-no-subscription/i18n/Translation-de_DE) ist mehrfach konfiguriert in /etc/apt/sources.list:6 und /etc/apt/sources.list.d/pve-no-subscription.list:3
W: Ziel Translations (pve-no-subscription/i18n/Translation-de) ist mehrfach konfiguriert in /etc/apt/sources.list:6 und /etc/apt/sources.list.d/pve-no-subscription.list:3
W: Ziel Translations (pve-no-subscription/i18n/Translation-en) ist mehrfach konfiguriert in /etc/apt/sources.list:6 und /etc/apt/sources.list.d/pve-no-subscription.list:3
Error executing command, exiting
root@ioBrokerVM:~# sudo apt-get install -y nodejs
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
nodejs ist schon die neueste Version (10.18.0-1nodesource1).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Die erwähnte Mehrfachkonfiguration kann ich leider nicht finden, weil im Ordner /etc/apt/sources.list.d/ soweit ich es sehen kann gar keine "pve-no-subscription.list" liegt. Trotzdem scheint er hier ein Problem zu haben. Kann das jemand auflösen?
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
3,068
330
83
Paketlisten werden gelesen... Fertig W: GPG-Fehler: http://download.proxmox.com/debian/pve buster InRelease: Die folgenden Signaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht verfügbar ist: NO_PUBKEY 7BF2812E8A6E88E0 E: Das Depot »http://download.proxmox.com/debian/pve buster InRelease« ist nicht signiert.
da fehlt der key für das Proxmox repository - siehe https://pve.proxmox.com/pve-docs/chapter-sysadmin.html#_secureapt

Die erwähnte Mehrfachkonfiguration kann ich leider nicht finden
apt liest '/etc/apt/sources.list' und alle files die auf '/etc/apt/sources.list.d/*.list' matchen - da wird irgendwo das PVE repo drinnen stehen

Ich hoffe das hilft
 

123proxerei

New Member
Jan 10, 2020
5
2
3
33
Hi, ich war da völlig auf dem falschen Fuß. Ich habe die Anleitung für die Updates von poxmox ohne
Subscription schlicht auf einer VM statt der Hauptinstallation durchgeführt. So konnte ich auf der VM node.js nicht updaten und die Updates zu proxmox waren auch nicht möglich. Vielen Dank für die Unterstützung.
 
  • Like
Reactions: Stoiko Ivanov

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!