command 'apt-get update' failed: exit code 100

scaa

Active Member
Nov 20, 2015
119
2
38
Seit heute plötzlich auf mehrerwn Hosts Probleme mit dem cronjob /usr/bin/pveupdate
Fehlermeldung:
command 'apt-get update' failed: exit code 100

Weiss jemand was los sein könnte?
 

scaa

Active Member
Nov 20, 2015
119
2
38
Das sind verschiedene 4er-Versionen. NIcht alle aktuell.
Auf einem ganz aktuellen Host mit Proxmox 5 gibt es zwar nicht diese Meldung beim cronjob, aber ein Update über die Oberfläche scheitert, weil keine Verbindung zu ftp://download.proxmox.com/ zustande kommt.
 

scaa

Active Member
Nov 20, 2015
119
2
38
hier die Ausgabe einer der Hosts:

pveversion -v
proxmox-ve: 4.2-52 (running kernel: 4.4.8-1-pve)
pve-manager: 4.2-11 (running version: 4.2-11/2c626aa1)
pve-kernel-4.4.6-1-pve: 4.4.6-48
pve-kernel-4.4.8-1-pve: 4.4.8-52
lvm2: 2.02.116-pve2
corosync-pve: 2.3.5-2
libqb0: 1.0-1
pve-cluster: 4.0-40
qemu-server: 4.0-79
pve-firmware: 1.1-8
libpve-common-perl: 4.0-67
libpve-access-control: 4.0-16
libpve-storage-perl: 4.0-51
pve-libspice-server1: 0.12.5-2
vncterm: 1.2-1
pve-qemu-kvm: 2.5-19
pve-container: 1.0-67
pve-firewall: 2.0-29
pve-ha-manager: 1.0-31
ksm-control-daemon: 1.2-1
glusterfs-client: 3.5.2-2+deb8u2
lxc-pve: 1.1.5-7
lxcfs: 2.0.0-pve2
cgmanager: 0.39-pve1
criu: 1.6.0-1
zfsutils: 0.6.5-pve9~jessie
 

scaa

Active Member
Nov 20, 2015
119
2
38
Das ist wohl das Problem:

starting apt-get update
Hit http://security.debian.org jessie/updates InRelease
Hit http://security.debian.org jessie/updates/main amd64 Packages
Hit http://security.debian.org jessie/updates/contrib amd64 Packages
Hit http://security.debian.org jessie/updates/contrib Translation-en
Hit http://security.debian.org jessie/updates/main Translation-en
Ign http://ftp.de.debian.org jessie InRelease
Ign https://enterprise.proxmox.com jessie InRelease
Hit http://ftp.de.debian.org jessie Release.gpg
Hit http://ftp.de.debian.org jessie Release
Ign https://enterprise.proxmox.com jessie Release.gpg
Ign https://enterprise.proxmox.com jessie Release
Hit http://ftp.de.debian.org jessie/main amd64 Packages
Hit http://ftp.de.debian.org jessie/contrib amd64 Packages
Ign https://enterprise.proxmox.com jessie/pve-enterprise amd64 Packages/DiffIndex
Hit http://ftp.de.debian.org jessie/contrib Translation-en
Hit http://ftp.de.debian.org jessie/main Translation-en
Ign https://enterprise.proxmox.com jessie/pve-enterprise Translation-en
Err https://enterprise.proxmox.com jessie/pve-enterprise amd64 Packages
server certificate verification failed. CAfile: /etc/apt/pve-repo-ca-certificates.crt CRLfile: none
W: Failed to fetch https://enterprise.proxmox.com/debian/dists/jessie/pve-enterprise/binary-amd64/Packages server certificate verification failed. CAfile: /etc/apt/pve-repo-ca-certificates.crt CRLfile: none

E: Some index files failed to download. They have been ignored, or old ones used instead.
TASK ERROR: command 'apt-get update' failed: exit code 10

---

wie kannich das lösen?
 

wbumiller

Proxmox Staff Member
Staff member
Jun 23, 2015
655
90
48
Da ist wohl noch eine APT Konfiguration aus älteren Paketen vorhanden (eventuell von einem update von pve3 übrig?).
Lösch die folgenden Zeilen aus /etc/apt/apt.conf.d/75pveconf
Code:
Acquire::https::enterprise.proxmox.com::CaInfo "/etc/apt/pve-repo-ca-certificates.crt";
Acquire::https::enterprise.proxmox.com::Verify-Peer "true";
 

scaa

Active Member
Nov 20, 2015
119
2
38
Danke, das war es. Problem auf dem einen Host gelöst.
Werde mir nun die anderen anschauen.
Ja einige der Hosts sind Updates älterer Versionsserien.
 

DerNorden

Member
Jul 9, 2017
56
0
11
40
Hi,

ich habe ein ähnliches Problem glaube ich. Wenn ich über die GUI von Proxmox 5 ein update starte bekomme ich folgende Meldung:

starting apt-get update
Get:1 http://security.debian.org stretch/updates InRelease [62.9 kB]
Ign:2 http://ftp.de.debian.org/debian stretch InRelease
Hit:3 http://ftp.de.debian.org/debian stretch Release
Ign:5 https://enterprise.proxmox.com/debian/pve stretch InRelease
Ign:6 https://enterprise.proxmox.com/debian/pve stretch Release
Ign:7 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise amd64 Packages
Ign:8 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise all Packages
Ign:9 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise Translation-en
Ign:7 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise amd64 Packages
Ign:8 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise all Packages
Ign:9 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise Translation-en
Ign:7 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise amd64 Packages
Ign:8 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise all Packages
Ign:9 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise Translation-en
Ign:7 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise amd64 Packages
Ign:8 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise all Packages
Ign:9 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise Translation-en
Ign:7 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise amd64 Packages
Ign:8 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise all Packages
Ign:9 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise Translation-en
Err:7 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise amd64 Packages
401 Unauthorized
Ign:8 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise all Packages
Ign:9 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise Translation-en
Fetched 62.9 kB in 2s (29.8 kB/s)
Reading package lists...
W: The repository 'https://enterprise.proxmox.com/debian/pve stretch Release' does not have a Release file.
E: Failed to fetch https://enterprise.proxmox.com/debian/pve/dists/stretch/pve-enterprise/binary-amd64/Packages 401 Unauthorized
E: Some index files failed to download. They have been ignored, or old ones used instead.
TASK ERROR: command 'apt-get update' failed: exit code 100

Wieso bekomme ich diese Meldung? Und kann ich so noch updates durchführen? Mir werden zumindest keine angezeigt. Entweder ist mein System aktuell oder das update funktioniert nicht. Meine Version lautet wie folgt:

pveversion -v
proxmox-ve: 5.0-15 (running kernel: 4.10.15-1-pve)
pve-manager: 5.0-23 (running version: 5.0-23/af4267bf)
pve-kernel-4.10.15-1-pve: 4.10.15-15
libpve-http-server-perl: 2.0-5
lvm2: 2.02.168-pve2
corosync: 2.4.2-pve3
libqb0: 1.0.1-1
pve-cluster: 5.0-10
qemu-server: 5.0-12
pve-firmware: 2.0-2
libpve-common-perl: 5.0-16
libpve-guest-common-perl: 2.0-11
libpve-access-control: 5.0-5
libpve-storage-perl: 5.0-12
pve-libspice-server1: 0.12.8-3
vncterm: 1.5-2
pve-docs: 5.0-6
pve-qemu-kvm: 2.9.0-2
pve-container: 2.0-14
pve-firewall: 3.0-1
pve-ha-manager: 2.0-2
ksm-control-daemon: 1.2-2
glusterfs-client: 3.8.8-1
lxc-pve: 2.0.8-3
lxcfs: 2.0.7-pve2
criu: 2.11.1-1~bpo90
novnc-pve: 0.6-4
smartmontools: 6.5+svn4324-1
zfsutils-linux: 0.6.5.9-pve16~bpo90


Viele Grüße aus dem Norden
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
14,109
508
133
das enterprise repo geht nur mit einem subscription key, ist einer hochgeladen?
 

DerNorden

Member
Jul 9, 2017
56
0
11
40
das enterprise repo geht nur mit einem subscription key, ist einer hochgeladen?
Nein, ist nicht hochgeladen. Besitze ich auch nicht. Wie ist dieser da rein gekommen. Vorher hatte ich Proxmox 3.4. Da war das nicht so... Ist bei der 5er Version Enterprise voreingestellt? Und wie kann ich das abändern?
 

DerNorden

Member
Jul 9, 2017
56
0
11
40
Super, danke. Ich war gerade selbst fündig geworden. Habe es entsprechend abgeändert. Und siehe da es funktioniert :).
 

Sven Jörns

Member
May 23, 2017
17
0
6
49
Die Fehlermeldung kann auch kommen, wenn die Subscrition abgelaufen ist.
Mit
Code:
pvesubscription get
kann man sich den Status angucken. Oder auch in der GUI pro Node. Wäre schön, wenn das irgendwo prominenter angezeigt wird. :)
 

daniello

New Member
Oct 13, 2018
17
0
1
50
Hi everyone,

I updated sources.list to no-subscription according to https://pve.proxmox.com/wiki/Package_Repositories.
I'd like to verfiy that my output of apt-get update is okay .. since I still get to see a lot of "enterprise" entries.:

Code:
root@proxmox:/etc/apt# apt-get update
Ign:1 http://ftp.debian.org/debian stretch InRelease
Hit:2 http://ftp.debian.org/debian stretch Release
Hit:3 http://security.debian.org stretch/updates InRelease
Hit:4 http://download.proxmox.com/debian/pve stretch InRelease
Ign:5 https://enterprise.proxmox.com/debian/pve stretch InRelease
Ign:6 https://enterprise.proxmox.com/debian/pve stretch Release
Ign:8 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise amd64 Packages
Ign:9 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise all Packages
Ign:10 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise Translation-en_US
Ign:11 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise Translation-en
Ign:8 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise amd64 Packages
Ign:9 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise all Packages
Ign:10 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise Translation-en_US
Ign:11 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise Translation-en
Ign:8 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise amd64 Packages
Ign:9 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise all Packages
Ign:10 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise Translation-en_US
Ign:11 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise Translation-en
Ign:8 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise amd64 Packages
Ign:9 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise all Packages
Ign:10 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise Translation-en_US
Ign:11 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise Translation-en
Ign:8 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise amd64 Packages
Ign:9 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise all Packages
Ign:10 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise Translation-en_US
Ign:11 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise Translation-en
Err:8 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise amd64 Packages
  401  Unauthorized
Ign:9 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise all Packages
Ign:10 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise Translation-en_US
Ign:11 https://enterprise.proxmox.com/debian/pve stretch/pve-enterprise Translation-en
Reading package lists... Done
W: The repository 'https://enterprise.proxmox.com/debian/pve stretch Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch https://enterprise.proxmox.com/debian/pve/dists/stretch/pve-enterprise/binary-amd64/Packages  401  Unauthorized
E: Some index files failed to download. They have been ignored, or old ones used instead.
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
14,109
508
133
Check documentation chapter "3.4. Package Repositories"
 

daniello

New Member
Oct 13, 2018
17
0
1
50
Check documentation chapter "3.4. Package Repositories"
Same information as in the Wiki .. this was what I made of it before I posted the dump above:

Code:
deb http://ftp.debian.org/debian stretch main contrib

#deb https://enterprise.proxmox.com/debian/pve stretch pve-enterprise

# PVE pve-no-subscription repository provided by proxmox.com,
# NOT recommended for production use
deb http://download.proxmox.com/debian/pve stretch pve-no-subscription

# security updates
deb http://security.debian.org stretch/updates main contrib
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
14,109
508
133
The documentation:

"...You can disable this repository by commenting out the above line using a # (at the start of the line). This prevents error messages if you do not have a subscription key. "

=> see /etc/apt/sources.list.d/pve-enterprise.list
 

daniello

New Member
Oct 13, 2018
17
0
1
50
The documentation:

"...You can disable this repository by commenting out the above line using a # (at the start of the line). This prevents error messages if you do not have a subscription key. "

=> see /etc/apt/sources.list.d/pve-enterprise.list
I see this the place where to comment this out. In the above I put a hash in front of the enterprise line and thought that was it. Thanks!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!