Changed Network Interfaces and Broke Host?


New Member
Oct 17, 2023
I'm really hoping I haven't destroyed my data with this screwup...Specs for the system are:

Ryzen 7 3700x
Asrock b550m-c
32gb ddr4-3200
LSI 9211-8i with IT firmware
Intel X540-T2 -> This is the NIC i was trying to add before all of this went downhill

Proxmox installed on 2 raidz1 1TB ssds which i can see in the mobo's bios
4 VMs installed on these ssd's - only one i really care about is the truenas one.
4x WD red 4tb drives passthroughed and pooled in truesnas VM
1070ti - never got to the point of passing this through but i need it for display output

I was attempting to install a new 4 port nic but quickly learned about how the PCI controller changes the interface names when a new device is added. I saw all the posts about having to change the names in /etc/network/interfaces but the noob that I am changed the current onboard nic name up 1 number (ex. ens5 to ens6). I did this WITHOUT the new nic installed so I changed the default nic interface. I expected the web UI to go down which it did but now when I reboot the system it just hangs on boot. I have the host plugged into a monitor with a keyboard and the host boots as expected to the motherboards post screen, shows the proxmox ve screen where i can select (i believe - see image 1) the kernel or reboot to firmware. I let it time out and then it runs through its boot process but hangs without showing an error. I've gotten to the part of the boot where it shows all the green Oks but its just hanging on: (see image 3)

Starting - Coldplay All udev Devices...

Othertimes when i reboot it will hang on the line just above that one:

VFIO - User Level meta-driver version 0.3

Last night i may have made matters worse, i tried using a ubuntu usb to get into the system but could not mount any of my pve directories because it couldnt find them. I eventually was able to boot into a proxmox usb, launch debugging install, exited out of that and while i was playing around in here i ran zpool import which saw my raid where i installed proxmox. i ran zpool import -f and now when i reboot the installer hangs on a different line (i dont remember that one off hand).

My main goal here is to make sure i can grab my data off of my truenass pool. so if a fresh install of proxmox on a usb will allow me to gain access to my pool, let me know!

If i can recover my current proxmox install that would be very nice but im currently lost trying to read all of the posts and my minimal linux experience is holding me back.



The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!