Ceph version in 4.3?

PigLover

Well-Known Member
Apr 8, 2013
119
36
48
Nothing in the release notes about an upgrade to Ceph. Did Jewel upgrade make it in?
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,521
908
163
Nothing in the release notes about an upgrade to Ceph. Did Jewel upgrade make it in?

No, as there are still some blocker bugs on in the Ceph Jewel packages. As soon as these are fixed and in the packages, we can recommend the upgrade.
 

gkovacs

Well-Known Member
Dec 22, 2008
509
48
48
Budapest, Hungary
No, as there are still some blocker bugs on in the Ceph Jewel packages. As soon as these are fixed and in the packages, we can recommend the upgrade.

among other things, we are waiting for http://tracker.ceph.com/issues/16255 / http://tracker.ceph.com/issues/17347 , which did not make it for the cutoff for 10.2.3 ..

As both issues are resolved now, when can we expect a new Ceph version in PVE? The pve-no-subscription repo for PVE 4.3 still contains Ceph 0.80.7, which is exactly 2 years old...

And what about GlusterFS, where 3.5.2 is included, which is EOL for 4 months now, as 3.8 LTM is out since June...
 

udo

Famous Member
Apr 22, 2009
5,918
180
83
Ahrensburg; Germany
As both issues are resolved now, when can we expect a new Ceph version in PVE? The pve-no-subscription repo for PVE 4.3 still contains Ceph 0.80.7, which is exactly 2 years old...

And what about GlusterFS, where 3.5.2 is included, which is EOL for 4 months now, as 3.8 LTM is out since June...
Hi,
you can use hammer (0.94.x) since a long time (see the ceph entry in the wiki).

Udo
 
  • Like
Reactions: gkovacs

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,521
908
163
...
And what about GlusterFS, where 3.5.2 is included, which is EOL for 4 months now, as 3.8 LTM is out since June...

You should always use latest packages from gluster.org (=3.8 currently), if you use gluster storage on Proxmox VE.
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,521
908
163
As both issues are resolved now, when can we expect a new Ceph version in PVE? ..

As we use the packages from ceph.com, we need to wait till the fixes are in the stable packages, hopefully they release them soon.
 

fabian

Proxmox Staff Member
Staff member
Jan 7, 2016
7,473
1,392
164
As both issues are resolved now, when can we expect a new Ceph version in PVE? The pve-no-subscription repo for PVE 4.3 still contains Ceph 0.80.7, which is exactly 2 years old...

they are not yet resolved - there is no release including the bug fix (yet). the pve-no-subscription repository does not contain any ceph packages at all - the Debian Jessie repositories contain 0.80.x, pveceph configures the ceph.com repositories and installs from there (where you always get the latest release of a certain version, currently pveceph only supports hammer, this will change when jewel is usable in our configuration). please don't spread misinformation.

And what about GlusterFS, where 3.5.2 is included, which is EOL for 4 months now, as 3.8 LTM is out since June...

this has been discusses at length previously, short summary: PVE does not provide any GlusterFS packages at all, the default ones in Jessie are rather old, there are current ones in jessie-backports and the repositories provided by the GlusterFS project which you can use without problems.
 

alexskysilk

Well-Known Member
Oct 16, 2015
727
86
48
Chatsworth, CA
www.skysilk.com
heads up- both 16255 and 17347 have been marked resolved a few days ago. was this fixed to your satisfaction? if not, its time to make alternate arrangements or be stuck at Hammer, which would be a damn shame.
 

morph027

Well-Known Member
Mar 22, 2013
446
61
48
Leipzig
morph027.gitlab.io
Cool down. As hard as i'm waiting for Jewel, the fix needs to be tested by PVE team thoroughly. If you ever were involved in the process of releasing a prodcution ready software for paying customers, you might understand this.
 

fabian

Proxmox Staff Member
Staff member
Jan 7, 2016
7,473
1,392
164
heads up- both 16255 and 17347 have been marked resolved a few days ago. was this fixed to your satisfaction? if not, its time to make alternate arrangements or be stuck at Hammer, which would be a damn shame.

if you look at the bug report and my post here (directly above yours), you can see that they were marked as resolved because they will be included in the upcoming 10.2.4 release. that version is not released yet. please take the time to read the threads you are replying too - it saves everybody else time ;)
 

gkovacs

Well-Known Member
Dec 22, 2008
509
48
48
Budapest, Hungary
No, as there are still some blocker bugs on in the Ceph Jewel packages. As soon as these are fixed and in the packages, we can recommend the upgrade.

they are not yet resolved - there is no release including the bug fix (yet). the pve-no-subscription repository does not contain any ceph packages at all - the Debian Jessie repositories contain 0.80.x, pveceph configures the ceph.com repositories and installs from there (where you always get the latest release of a certain version, currently pveceph only supports hammer, this will change when jewel is usable in our configuration).

Any news on Ceph Jewel landing in Proxmox?

We are really looking forward to using CephFS.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!